Jump to content
Alistair

Mandriva Free 2007 hangs on reboot after HAL

Recommended Posts

Excuse me, but did you install the bootloader on a floppy?

(your kernel complains about a damaged floppy!).

If you did, then use the spare boot floppy, or reinstall the bootloader to a safer medium.

Share this post


Link to post
Share on other sites

Yes I noticed the same thing a few days ago. So I checked the drive. But there was no floppy in the drive. I have been running off the CD the whole time. I have never used GRUB or LILO and haven't a clue how to make a floppy with grub or use it.

 

Now it all makes sense what's been happening.

- e not working

- grub.conf not existing, only lilo.conf

- esc took me to the command prompt but I could not change anything

- I assumed that if Aussie John was using Grub, that FREE 2007 would be the same.

 

Where to from here??

Share this post


Link to post
Share on other sites
Have just installed Free 2007 for the 1st time.
I have been running off the CD the whole time

This is conflicting information. if you were running from

the cd you would have a live distro, and a live distro

on a PIII 500 MHz would be a bit slow. Maybe you meant knoppix?

 

Anyhow, from here, (assuming mandy is installed)

insert mandy cd, boot from cd, within ~10/20s you will get some kind

of menu, try F1 and F2 and F3 you will see different information.

On the command line just type rescue then enter

Then you should have a menu "install bootloader"

follow instruction and install grub rather than lilo,

on the MBR (presumably single boot PC)

quit all that remove cd and reboot, follow now the "e step"

Share this post


Link to post
Share on other sites

This isn't a boot loader problem IMHO; it's a booting problem. Changing from lilo to grub won't help here. You are getting to a boot prompt when you hit the Esc key so lilo is installed. Also if lilo wasn't installed to the mbr which is the default action with mdv2007, you wouldn't get a lilo boot selection screen. The traditional advice is hit the Esc key to get you to a boot prompt and type:

 

linux noapic nolapic acpi=off

 

and then hit Enter.

 

You can also try:

 

linux nopinit

 

If either of the above help, we can later edit the lilo configuration file to automatically pass those parameters every time you boot.

 

This assumes you have aready done a complete mdv2007 default install, you can't get the system to complete a boot and you are accessing the installed files on your hard drive by booting the install cd or a livecd which appears to be the case since you are accessing the boot logs through a mount point. I also assume you would know if you installed the boot loader to a floppy as you have to specifically direct the install program to do that and have to put a floppy in the drive. If you did this and failed to put the floppy in the drive, you wouldn't get as far as you do in the boot process. In fact, you wouldn't boot at all.

If you want, you can boot up with the cd and post the lilo configuration file, /etc/lilo.conf. But as I said, I don't think that's where the problem lays.

 

Also, if you have any usb storage devices connected, try booting with them disconnected. The haldaemon(HAL) specifically deals with this type of removable storage device and that's where you are hanging up.

Share this post


Link to post
Share on other sites

Sorry for the confusion. It was a knoppix CD I've been running off.

 

pmpatrick, I tried those commands with no success

 

I booted directly from the HD which led to the 2 options of LINUX or FAILSAFE

Pressed escape to the command prompt.

typed: linux noapic nolapic acpi=off

Still froze at HAL (It says OK next to HAL. Does that mean that HAL has been successfully passed and that it is the NEXT command that is the problem?)

I could also see that the acpi service had indeed been turned off.

 

Then I tried: linux nopinit

This time the acpi service was back.

The last line was different, not HAL, but instead:

Start ALSA-version 1.0.12: trident OK

 

 

I've never used any floppy.

I have no usb devices connected.

Could the HAL problem point to the floppy drive?

Share this post


Link to post
Share on other sites

Hello Alistair.

You have me totally confused and I think everyone else as well.

Lets go back to the very beginning.

 

1. Are you using a Live CD such as Knoppix in its Live mode, or

2. have you gone a stage further and installed the Live knoppix to your Hard Drive ???.

 

Please tell us which of those two points is the current situation.

When we know this then we can start to get into your problem. Until we get to know this then the scene is just too confused and we really would like to try and help you.

 

Cheers. John

Share this post


Link to post
Share on other sites

Do you have an ide zip drive? Actually, instead of playing 20 questions on your hardware, boot up with your knoppix cd, open a konsole and run:

 

$ su

# lspci

 

and post the output here. That will give a pretty good idea of your hardware configuration. Also post your /etc/lilo.conf file from mdv2007; at least we can see what boot parameters are on the append line. You could also try:

 

linux noapic nolapic acpi=off nopinit

 

if you haven't done that already.

 

Another thing to check. Go into your bios setup and make sure Plug 'n Play is disabled.

 

The good news is you can boot up with knoppix which indicates to me you don't have any severe linux hardware incompatabilities. This appears to be mandriva specific, either something in the mdv kernel or the parallel boot process or a combination/interaction may be causing the problem.

 

Edit: AussieJohn, he appears to have done a standard, default mdv2007 install which apparently went OK but it fails to complete a bootup. He appears to be using a knoppix livecd to boot up and access the mdv root filesystem and mdv boot logs. The knoppix livecd appears to be booting up fine.

Edited by pmpatrick

Share this post


Link to post
Share on other sites
- grub.conf not existing, only lilo.conf

 

Actually it doesn't exist for anyone- the grub configuration file is /boot/grub/menu.lst

But since you have installed LILO and not Grub, this remark is purely academical...

Share this post


Link to post
Share on other sites

PmPatrick, your edit to AussieJohn is precisely correct:

 

Edit: AussieJohn, he appears to have done a standard, default mdv2007 install which apparently went OK but it fails to complete a bootup. He appears to be using a knoppix livecd to boot up and access the mdv root filesystem and mdv boot logs. The knoppix livecd appears to be booting up fine.

 

Exactly.

 

I have very basic hardware: 1 CD rom, 1 ide HD (no zip) , 1 floppy, 1 graphic, 1 network. That's it.

 

Here is lspci:

 

root@ttyp0[knoppix]# lspci

00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03 )

00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)

00:04.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)

00:04.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)

00:04.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)

00:04.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)

00:09.0 Multimedia audio controller: Trident Microsystems 4DWave DX (rev 02)

00:0b.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [boomerang]

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200 AGP (rev 01)

 

 

and lilo.conf:

 

default="linux"

boot=/dev/hda

map=/boot/map

keytable=/boot/no-latin1.klt

menu-scheme=wb:bw:wb:bw

compact

prompt

nowarn

timeout=100

message=/boot/message

image=/boot/vmlinuz

label="linux"

root=/dev/hda1

initrd=/boot/initrd.img

append=" resume=/dev/hda5"

image=/boot/vmlinuz

label="failsafe"

root=/dev/hda1

initrd=/boot/initrd.img

append=" failsafe resume=/dev/hda5"

 

 

In my bios the only reference to PNP is:

PNP OS installed: NO (It has been set to NO the whole time)

It appears to be deactivated, and yet the following lines appear just after the memory check:

Award Plug and PLay bios extension 1.0A

Initialize Plug and Play cards

PNP init completed

 

Doesn't make sense to me.

Share this post


Link to post
Share on other sites

In my earlier post I was guessing that your problem stemmed from Mandriva's introduction of a new parallel initialization system, which replaces the classic sequential initialization system. This means that during boot, many services are started at the same time, improving boot speed.

 

To disable the new parallel initialization system, you use nopinit as a kernel parameter.

 

To specify kernel parameters during installation, simply boot the installer as usual. On the very first interactive screen, where you are presented with the options "Boot from Hard Disk", "Installation" and so on, highlight "Installation" and then just type the kernel parameter required. You will see it being added to the "Boot Options" text box near the bottom of the screen. When you have typed the required kernel parameters, simply hit Enter.

Share this post


Link to post
Share on other sites

Thanks for the clear up. Now I am no longer confused.

Shows how important it is to do a proper layout of a problem such as this one.

Now I can follow the suggestions and hope I may be able to contribute a suggestion or two. :D Earlier I couldn't.

Cheers. John.

Share this post


Link to post
Share on other sites

PMPatrick, I forgot to mention that I tried the series of commands you suggested:

 

linux noapic nolapic acpi=off nopinit

 

No joy.

 

The last line was not HAL, but instead:

Start ALSA-version 1.0.12: trident OK

 

Daniel, thanks for explanation about nopinit - no parallel initializing - to start services in parallel . Being new to this it's good to get some hooks to hang things on.

Share this post


Link to post
Share on other sites

The X server loads right after ALSA; my guess is you have misconfigured your matrox graphics card and that is what is hanging up your boot. You also appear to need those boot parameters to get that far. To test the theory, we can try booting in nongraphical mode so the X server never tries to load. Pass the following boot parameters:

 

linux noapic nolapic acpi=off nopinit 3

 

You are booting to run level 3 which is a nongraphical command line mode. If this works you will get to a command line login which will look like this:

 

localhost login:

 

type in root here and enter your root password when prompted. Then run:

 

# XFdrake

 

which is the mandriva graphics setup program. Check the entries for graphics card, monitor, etc. You navigate from the keyboard as there is no mouse support, just like a bios setup. Most importantly, after making any changes, you can test your new configuration from within XFdrake. Keep trying till you get something that tests out OK. When done, exit XFdrake and type this at the command prompt:

 

# reboot

 

Try rerunning with the same boot options but don't put in the "3" this time.

Edited by pmpatrick

Share this post


Link to post
Share on other sites

Greetings.

I've been having a similar problem with mandriva-one-2007kde.

It does not seem to want to run in live mode. I had downloaded, made sure the checksum was correct and burned with K3b. It begins the boot process and hangs at loading "HAL daemon". I've waited well over 2 minutes with nothing happening.

Now, I assume I can rule out hardware as I had burned 2007 FREE to DVD and it installed with no complications on my (quite old ATA33) experimental drive. In fact it SCREAMS! I had tried Mandriva Live last year with similar results (don't recall which module would hang though) and simply gave up as it was of no importance at the time. This year, however, my IT guy, (died in the wool Microserf SysAdmin) is willing to experiment with the `Dark Side' and I'd like to have some Mandy Goodness to share with him. (along with wanting to install MandyOne for myself, of course)

 

Is there a whitepaper or other reference that I've not found on this subject?

 

Thanks to all in advance.

Edited by Lagrosse

Share this post


Link to post
Share on other sites

Why do you want to bother installing mandy one when you have mandy 2007 working?

 

You could go with the former comment below

and once in text mode, type su to be root

then drakx11 to (re)configure the video card

The X server loads right after ALSA; my guess is you have misconfigured your matrox graphics card and that is what is hanging up your boot. You also appear to need those boot parameters to get that far. To test the theory, we can try booting in nongraphical mode so the X server never tries to load. Pass the following boot parameters:

 

linux noapic nolapic acpi=off nopinit 3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...