Jump to content
shams

can't browse the localhost?

Recommended Posts

hi,

i installed the mandriva 2007, the httpd is runing, i can open the net, bur can run the http://localhost, the browser error is:

The connection has timed out

this is the /var/log/heepd/error_log last lines:

[Mon Nov 13 11:11:24 2006] [notice] core dump file size limit raised to 4294967295 bytes

[Mon Nov 13 11:11:26 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

[Mon Nov 13 11:11:26 2006] [notice] Digest: generating secret for digest authentication ...

[Mon Nov 13 11:11:26 2006] [notice] Digest: done

[Mon Nov 13 11:11:28 2006] [notice] Apache/2.2.3 (Mandriva Linux/PREFORK-1mdv2007.0) configured -- resuming normal operations

Share this post


Link to post
Share on other sites

Is the loopback interface up? You can check with this command:

 

/sbin/ifconfig

 

This is what mine looks like.

 

/sbin/ifconfig

eth0 Link encap:Ethernet HWaddr 00:D0:B7:26:B3:78

inet addr:192.168.1.21 Bcast:192.168.1.255 Mask:255.255.255.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:205643 errors:0 dropped:0 overruns:0 frame:0

TX packets:287936 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:169017581 (161.1 MiB) TX bytes:21051910 (20.0 MiB)

Interrupt:11

 

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:5916 errors:0 dropped:0 overruns:0 frame:0

TX packets:5916 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:1110335 (1.0 MiB) TX bytes:1110335 (1.0 MiB)

Share this post


Link to post
Share on other sites

According to your other two posts, you're running 2006, not 2007?? :unsure:

And in there you say you can't access file:// urls either, is that still true? Have you tried using Konqueror to browse the same files, does that work? And have you tried just dragging normal html files into Konqueror or Firefox to see if they load ok there?

 

Maybe this webserver problem is part of a larger problem, if your other two posts are still current?

Share this post


Link to post
Share on other sites

thanks for replies, the problem is not with the intenet, i can open the web sites, but the only problems is with the local web server this is the output of ifconfig:

# /sbin/ifconfig

ppp0 Link encap:Point-to-Point Protocol

inet addr:203.103.194.46 P-t-P:202.163.90.18 Mask:255.255.255.255

UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1

RX packets:430 errors:0 dropped:0 overruns:0 frame:0

TX packets:494 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:3

RX bytes:391014 (381.8 KiB) TX bytes:104344 (101.8 KiB

there ws no problem of the lcoal server with mandirva 2006, i ust installed the 2007 now i cannot connect to my local web server in the /var/www/html, i check the httpd.conf, that was configured correctly for /var/www/html

An error occurred while loading http://localhost:

Timeout on server

Connection was to localhost at port 80

snd this is the firefox error:

The server at localhost is taking too long to respond

this is httpd.conf:

DocumentRoot "/var/www/html"

 

# This should be changed to whatever you set DocumentRoot to.

#

<Directory "/var/www/html">

# The Options directive is both complicated and important. Please see

# http://httpd.apache.org/docs-2.0/mod/core.html#options

# for more information.

 

Options -Indexes FollowSymLinks MultiViews

 

#

# AllowOverride controls what directives may be placed in .htaccess files.

# It can be "All", "None", or any combination of the keywords:

# Options FileInfo AuthConfig Limit Indexes

 

AllowOverride None

 

# Controls who can get stuff from this server.

Order allow,deny

Allow from all

 

</Directory>

Share this post


Link to post
Share on other sites

Hey,

 

Can you ping localhost & or 127.0.0.1. Also take a look at your /etc/host file & post if your not sure about its contents..

Oh & have you restarted httpd service after editing (Just a thought)

HTH

Edited by jaraeez

Share this post


Link to post
Share on other sites

and this is the /etc/hosts:

# cat /etc/hosts

# Do not remove the following line, or various programs

# that require network functionality will fail.

127.0.0.1 localhost.localdomain localhost

::1 localhost.localdomain localhost

Edited by shams

Share this post


Link to post
Share on other sites

this is the ping result:

# ping 127.0.0.1

connect: Network is unreachable

and this is the firefox error opening http://127.0.0.1/?:

Unable to connect

Firefox can't establish a connection to the server at 127.0.0.1

ok if the problem is loop back device then how i can solve this problem?

Share this post


Link to post
Share on other sites

How come the ping command to 127.0.0.1 worked two posts ago, and now it doesn't??? :unsure:

Are you saying that now neither ping 127.0.0.1 nor ping localhost works at all?

Share this post


Link to post
Share on other sites
How come the ping command to 127.0.0.1 worked two posts ago, and now it doesn't??? :unsure:

Are you saying that now neither ping 127.0.0.1 nor ping localhost works at all?

that was not from manriva 2007, i posted in mistake then i remove that, i can't ping the localhost in mandriva 2007., this is the error:

# ping 127.0.0.1

connect: Network is unreachable

Share this post


Link to post
Share on other sites
that was not from manriva 2007, i posted in mistake then i remove that, i can't ping the localhost in mandriva 2007., this is the error:

# ping 127.0.0.1

connect: Network is unreachable

 

 

As root try the command 'ifconfig lo up' ( without the quotes ). This should try to activate the interface. I can use ifconfig to activate and deactivate my loopback interface.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...