Jump to content
Sign in to follow this  
retcynm

cupsd and mandriva 2007

Recommended Posts

I've installed mandriva 2007 on several machines in our office, and am trying to get printing setup with our networked Brother HL1870n b/w laser printer. I went to brother's website and downloaded and installed their linux drivers (rpm -ivh --no-deps brhl18_2-1.0.0-0-noarch.rpm), then went to localhost:631 and installed the printer, and succesfully printed a test page. Unfortunantly I seem to be unable to print fromn any other applications, on any of the machines.

 

If. for example, I try to print a document from within kedit (File >> Print..), the print window opens, then another dialoge opens that states "Initializing printiong system..." then an error window appears that states "An error occured while retrieveing the printer list: Connection to CUPS server failed. Check that the CUPS server is correctly installed and running. Error: the ipp request failed for an unknown reason." I get the same error dialoges no mater what application I try to print from. I am able to ping the printer by IP address, from the linux boxes.

 

I searched the forums here and came across the following thread:

 

https://mandrivausers.org/index.php?showtop...39&hl=print

 

rpm -qa | grep cups returns:

 

libgnomecups-1.0_1-0.2.2-3mdv2007.0
libcups2-1.2.4-1.1mdv2007.0
cups-common-1.2.4-1.1mdv2007.0
libgnomecups-0.2.2-3mdv2007.0
cups-1.2.4-1.1mdv2007.0

 

chkconfig --list cups returns:

 

cups			0:off   1:off   2:off   3:off   4:off   5:off   6:off

 

service cups status returns:

 

cupsd is stopped

 

and netstat -tan returns no mention of anything on 631.

 

If I go to MCC >> System >> Services, cups is listed as stopped, with "on boot" unchecked. I can start cups from there, or with:

 

service cups start

 

chkconfig --list cups then returns:

 

cups			0:off   1:off   2:on	3:on	4:on	5:on	6:off

 

and netstat -tan returns:

 

tcp		0	  0 :::631					  :::*						LISTEN

 

But, I am still getting the same errors and lack of printing when I try to print. Also when I reboot, CUPSD is no longer running.

 

I've uninstalled and reinstalled both cups and the brother drivers, but

the problem persists on all machines. Any ideas?

 

Thanks

Share this post


Link to post
Share on other sites

Have you applied updates to the system? I saw this on someone who hadn't applied updates and had problems with cups. As soon as they applied the updates, it worked perfectly fine.

Share this post


Link to post
Share on other sites

I also had loads of trouble with cups 1.2.X, under almost any distro I've tried. Luckily enough it works now.

Please pass any useful error messages you can find in /var/log/cups folder, and also copypaste here the content of your /etc/hosts file.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...