Jump to content

firefox plugins - windows media


Recommended Posts

I can't ever play any videos on the web, well hardly ever.


For example, I have tried to play many "help" videos for some equipment I own, or am thinking about buying.


most videos are wmv, and all I get is messages that "can't play this file, you may need to install additional plugins".


How do linux users play these videos?


edit: sorry, I just noticed the windows media thread started by oldnoob... I'll try the suggestions in that thread...


ok, I tried #urpmi win32-codecs, and it said "the packages are already installed"


I thought so, I installed that codec stuff way back after I installed mandriva. Don't know why I haven't ever been able to watch videos.

Edited by null
Link to comment
Share on other sites

all I get is:


[root@localhost Desktop]# urpmi mplayerplugin

ftp://ftp.phys.ttu.edu/pub/MandrivaLinux/official/2006.0/i586/media/contrib/ mplayerplugin-3.11-1mdk.i586.rpm
	0% of 0 completed, ETA = --:--:--, speed = 0					...retri eving failed: curl failed: exited with 9 or signal 0

Installation failed, some files are missing:
ftp://ftp.phys.ttu.edu/pub/MandrivaLinux/official/2006.0/i586/media/contrib/ mplayerplugin-3.11-1mdk.i586.rpm
You may want to update your urpmi database

...retrieving failed: curl: (9) FTP: access denied


so then I did:


[root@localhost Desktop]# urpmi.removemedia -a
removing medium "main"
removing medium "contrib"
removing medium "plf-free"
removing medium "plf-nonfree"
removing medium "updates"
found 0 headers in cache
removing 0 obsolete headers in cache
wrote config file [/etc/urpmi/urpmi.cfg]


and then I went thru the easy urpmi steps to add everything again, with different sources this time:


plf-free and plf-nonfree both worked ok, but all the others failed:


[root@localhost Desktop]# urpmi.addmedia --update updates ftp://mirror.umr.edu/pub/linux/mandrake/Mandrakelinux/official/updates/2007.0/i586/media/main/updates/ with media_info/hdlist.cz
added medium updates
wrote config file [/etc/urpmi/urpmi.cfg]
examining synthesis file [/var/lib/urpmi/synthesis.hdlist.plf-free.cz]
examining synthesis file [/var/lib/urpmi/synthesis.hdlist.plf-nonfree.cz]
retrieving source hdlist (or synthesis) of "updates"...

...retrieving failed: curl: (9) FTP: access denied
retrieval of source hdlist (or synthesis) failed
no hdlist file found for medium "updates"
examining synthesis file [/var/lib/urpmi/synthesis.hdlist.updates.cz]
problem reading synthesis file of medium "updates"
found 0 headers in cache
removing 0 obsolete headers in cache
wrote config file [/etc/urpmi/urpmi.cfg]
unable to update medium "updates"


is it just a matter of trying and trying and trying over and over again until you find sources that work?

if so, the "easy urpmi" name should probably be changed...

Link to comment
Share on other sites

The problem at the moment seems to be most of the mirrors are askew. I have tried 5 or 6 in different countries and finally found one in the USA. It was .edu one. Easy-urpmi is exactly as it says and is not to blame for the difficulties you are having.


Either leave things for a few days or just keep trying different world mirrors.


At the moment I have no problems with Main or Contrib but I still can't seem to get much sense from Updates even from the same mirror that supplies Main and Contrib. I have tried to find Updates, bugfixes and security on Mandrivas Website but it doesn't seem to be there (maybe I can't see it for looking). Maybe that is why the mirrors have problems. Like they say, they are mirrors to Mandriva, so if it is out then so will they be.


Cheers. John.

Link to comment
Share on other sites

Try skipping the 'update' portion of the tree and just install main and contrib and plf for now.


Your other option while you wait for the mirrors to sort out is to download the rpm manually and you can still use urpmi (or the rpm command) to install it.


the mplayerplugin rpm is found in contrib. If you can access a mirror either through your browser or ftp client then try that.




find mplayerplugin-3.25-2mdv2007.0.i586.rpm @




Once downloaded, as root, goto the directory where you downloaded the file and use


urpmi mplayerplugin-3.25-2mdv2007.0.i586.rpm


If dependencies are required you can manually grab those too.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...