Jump to content

Screensaver [solved]


Recommended Posts


On my new Md2007 screen saver doesn't work. Instead of "doing" something the screen just became black. I remember that at Md2006 there was a service xscreensaver that was running all time but here I cannot find it. After the installation of Md2007 it was working, but after I removed some packages the screen saver doesn't work.

I know that it's not crucial the Screen saver but just for curiosity ...

Link to comment
Share on other sites

A black screen usually hints that you're attempting to use an opengl screensaver, but don't have opengl enabled. What's the output of:


glxinfo | grep direct


if that doesn't work, you need to do this first:


urpmi mesa-demos


as this has all the opengl tools inside to to check/test.

Link to comment
Share on other sites

What packages did you remove? You can check, I think in /var/log/urpmi.log


I check in /var/log/user.log


and these are the packages that I removed:


orca-1.0.0-1mdv2007.0 removed

libat-spi0-1.7.11-1mdv2007.0 removed

libgnomespeech7-0.4.5-1mdv2007.0 removed

libgail-gnome-1.1.3-1mdk removed

gnome-speech-0.4.5-1mdv2007.0 removed

gok-1.2.0-1mdv2007.0 removed

at-spi-1.7.11-1mdv2007.0 removed

dasher-4.2.0-1mdv2007.0 removed

libhylafax4.3.0-4.3.0-1mdv2007.0 removed

hylafax-4.3.0-1mdv2007.0 removed

kphone-4.2-7mdv2007.0 removed

hylafax-client-4.3.0-1mdv2007.0 removed

efax-0.9a-7mdv2007.0 removed

kdebase-kdeprintfax-3.5.4-35mdv2007.0 removed

kdebase-3.5.4-35mdv2007.0 removed

kdetv-0.8.9-2mdv2007.0 removed

kdenlive-0.2.4-4mdv2007.0 removed

kdegraphics-kfax-3.5.4-7mdv2007.0 removed

kdepim-kpilot-3.5.4-12mdv2007.0 removed

kdepim-common-3.5.4-12mdv2007.0 removed

kdepim-kmail-3.5.4-12mdv2007.0 removed

kdepim-knode-3.5.4-12mdv2007.0 removed

kdepim-kontact-3.5.4-12mdv2007.0 removed

kdepim-korganizer-3.5.4-12mdv2007.0 removed

task-kde-3.5.1-6mdv2007.0 removed

kdenetwork-kopete-3.5.4-3mdv2007.0 removed

kdenetwork-3.5.4-3mdv2007.0 removed

libkdenetwork2-ksirc-3.5.4-3mdv2007.0 removed

kdenetwork-ksirc-3.5.4-3mdv2007.0 removed

libkdenetwork2-kopete-3.5.4-3mdv2007.0 removed

xpdf-tools-3.01pl2-3mdv2007.0 removed

Link to comment
Share on other sites

It is most likely that the Screensaver was a KDE based GL type screensaver and when you eliminated all the KDE stuff especially Kde-base then you effectively disabled the screensaver.

With all the kde stuff you listed as removed I am suprised that you haven't removed the rest since they would seem to be mostly pointless. :D


Cheers. John.

Link to comment
Share on other sites

the same thing happened to me but I googled a bit and found that if I add




in the screensaver section of ~/.kde/share/config/kdesktoprc then it was fixed. Maybe this will help you too.

Link to comment
Share on other sites

  • 4 months later...

My screen saver doesn't work either, giving me a blank screen like it did for hirohitosan. I tried what cebo said (below), but it didn't work.


the same thing happened to me but I googled a bit and found that if I add




in the screensaver section of ~/.kde/share/config/kdesktoprc then it was fixed. Maybe this will help you too.


Here's the information that ian asked about.

[root@localhost Desktop]# glxinfo | grep direct

direct rendering: No

OpenGL renderer string: Mesa GLX Indirect

[root@localhost Desktop]# uname -a

Linux localhost #1 Sat Feb 24 04:51:15 EST 2007 x86_64 AMD Athlon 64 Processor 3000+ GNU/Linux


Any idea on how to resolve the problem for me? Thanks.

Link to comment
Share on other sites

Kieth -- the output of glxinfo | grep direct shows that you do not have accelerated 3D and OpenGL support, most likely because you use the generic driver and not the hardware specific driver from Nvidia or ATI (or whatever chipset your card uses). If you know the card you have (you can also look it up in the control center under hardware), then you can probably install support via software management -- look for packages with ATI or NVIDIA in their name, for instance dkms-nvidia-8774-4plf2007.0. The process is a bit convoluted, but we can walk you through it. An alternative approach to getting an nvidia driver installed is listed here -- less automated, needs to be redone with every kernel update, but more robust than dkms in my opinion.

Link to comment
Share on other sites

OK, I understand what you're saying.


Not too many months ago, I had a difficult time getting my graphics card working correctly, getting the dkms installed, etc. With help from this forum, I was able to do it. Unfortunately, I do not have 3D acceleration, and cannot have it. Therefore, this time, I think I will just leave well enough alone. I'll just use different screen savers or just let it stay blank. It isn't worth the effort. It isn't worth taking a risk of messing up what I now have. Thanks anyway. I appreciate the offer to help.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...