Jump to content
ianw1974

System not shutting down [solved]

Recommended Posts

When I shutdown my machine, I notice the "power down" option, and then instead of actually shutting down, it starts to reboot itself.

 

Any ideas how I can get this working again? Currently ACPI, APIC and Local APIC are enabled and running on my system if that helps any.

 

EDIT:

 

just tried disabling apic and local apic, but that doesn't solve the problem.

Share this post


Link to post
Share on other sites

Tried typing halt, same results. I know this did work, until I applied updates to the system, and now it failed. However, none of the updates related to acpi.

Share this post


Link to post
Share on other sites

Possibly, not sure. I'll have to check tonight when I get home.

Share this post


Link to post
Share on other sites

OK, just updating this post. I've checked my /etc/inittab, and it's completely normal. Here it is:

 

#
# inittab	   This file describes how the INIT process should set up
#			   the system in a certain run-level.
#
# Author:	   Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
#			   Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by Mandriva Linux are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left.  Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.
pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
#3:2345:respawn:/sbin/mingetty tty3
#4:2345:respawn:/sbin/mingetty tty4
#5:2345:respawn:/sbin/mingetty tty5
#6:2345:respawn:/sbin/mingetty tty6

# Single user mode
~~:S:wait:/bin/sh

 

so am pretty sure this is not the problem. I've just installed apmd, so going to see if this solves the problem when I reboot as the service isn't started just now. Can't remember if this existed on my 2006 system or not.

Share this post


Link to post
Share on other sites

Nope, apmd doesn't solve anything. Dmesg reports that it's overridden by acpi. My /etc/lilo.conf shows:

 

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default="linux"
boot=/dev/hda
map=/boot/map
keytable=/boot/uk-latin1.klt
menu-scheme=wb:bw:wb:bw
compact
prompt
nowarn
timeout=50
message=/boot/message
image=/boot/vmlinuz
	label="linux"
	root=/dev/md1
	initrd=/boot/initrd.img
	append="resume=/dev/md0 splash=silent"
	vga=788
image=/boot/vmlinuz
	label="linux-nonfb"
	root=/dev/md1
	initrd=/boot/initrd.img
	append="resume=/dev/md0"
image=/boot/vmlinuz
	label="failsafe"
	root=/dev/md1
	initrd=/boot/initrd.img
	append="failsafe resume=/dev/md0"

 

and no entry showing acpi is off, so that is fine. So, no idea why all of a sudden it doesn't work.

 

The log files report the appropriate shutdown measure, be it reboot or halt. Reboot does the process normally. Halt does a click like it used to as it's about to shut down - obviously when it's disconnected the hard disks, but boots the system than actually powering it down.

 

I've also tried a previous suggesting of disconnecting it completely from the power, but this doesn't work either.

 

Seems I need another distro for my machine, or wait for some sort of update to fix it.

Share this post


Link to post
Share on other sites

Hm. This is really strange. Did you try another kernel yet? Maybe the resume option kicks in wrongly after shutdown? I'd try to disable it temporarily just to check.

 

HTH,

 

scoonma

Share this post


Link to post
Share on other sites

I was going to try the kernel-tbm last night, but it wouldn't boot - got kernel panic, and then I just couldn't be bothered to get it to work.

 

I've figured I got two solutions for this. The first, is to wait for an acpi update. The second, is compile my own kernel in case something in the kernel is causing the problem.

 

But I've figured, since if I'm going to compile my own kernel and from past experience what doesn't work after doing this within Mandriva, I may as well just install and compile Gentoo on it.

Share this post


Link to post
Share on other sites

It could be that it is cycling the power before the shutdown in a reset... and your bios is set to boot after a power cycle?

 

Did you try a manual

init 0 ? or shutdown -h now ?

Share this post


Link to post
Share on other sites

Nope, it was working perfectly fine with Mandriva 2006. It's only when I put 2007 on that it started to play up. Initially it shut down fine after the first install. Then it never did again after that.

 

As it happens, I'm now part way through a Gentoo install :P so I'll prob never come to realise why this stopped working. It bugs me though, and I really want my machine to shut down. I filed a bug report two weeks ago, but heard nothing.

 

Will stick with Gentoo on this machine, and then maybe go back to Mandriva on it some time if I really feel like it - but I doubt it. All my other machines are OK, and I feel that I really wanted Gentoo anyhow for this machine ;)

Share this post


Link to post
Share on other sites
Nope, it was working perfectly fine with Mandriva 2006. It's only when I put 2007 on that it started to play up. Initially it shut down fine after the first install. Then it never did again after that.

 

As it happens, I'm now part way through a Gentoo install :P so I'll prob never come to realise why this stopped working. It bugs me though, and I really want my machine to shut down. I filed a bug report two weeks ago, but heard nothing.

 

Will stick with Gentoo on this machine, and then maybe go back to Mandriva on it some time if I really feel like it - but I doubt it. All my other machines are OK, and I feel that I really wanted Gentoo anyhow for this machine ;)

If such a devoted user abandons Mandriva, it's quite discouraging :huh:

Share this post


Link to post
Share on other sites
If such a devoted user abandons Mandriva, it's quite discouraging :huh:

 

I don't think Ian abandons Mandriva completely, just for one of his machines. Right?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...