Jump to content
Sign in to follow this  
TheCrizu

Firestarter autostart [solved]

Recommended Posts

I just installed a firestarter firewall from mandriva rpm's,and i just liked it.now,i have encountered a problem,when i tried to make it autostart when logged in.i followed the instructions on their website:

 

Q: How can I get Firestarter to load automatically when I log in as a regular user?

Firestarter running in the system tray

 

Normally when you start Firestarter by clicking an icon or manually from a terminal, the system will prompt you for your root user's password. However, this is a bit of a hassle, especially if you want to run Firestarter all the time when logged in. In that case Firestarter can be loaded in the background when you log in with your regular user, without asking a password and minimized to the system tray (pictured right).

Giving the user permission to launch Firestarter without the root password

 

In order for a regular user to be able to launch Firestarter, the user must be given additional privileges. Edit your /etc/sudoers file in your favorite text editor and add the following line at the end:

username ALL= NOPASSWD: /usr/bin/firestarter

 

Note: Debian users should replace /usr/bin/firestarter with /usr/sbin/firestarter in the above line.

 

Simply replace username with whatever your login is. The specified user is now able to launch Firestarter without being prompted for a password using the command sudo firestarter.

 

A note on the security aspects: This method makes a trade off in local security for convenience. If your user account becomes compromised the attacker will be able to control the firewall. However this method is preferable to having a shared root user password in a multiuser setting. It is also preferable if the alternative is not to run Firestarter at all.

Launching Firestarter minimized to the tray on login

 

Having performed the above configuration of permissions, the system can further be set up to load Firestarter when you log in with your regular user account. Firestarter will in that case load directly into the system tray without user intervention, after which the main interface can be accessed by clicking the tray icon.

 

Using GNOME:

The GNOME sessions manager

 

Open up your GNOME menu, select Preferences followed by Sessions. Switch to the Startup programs tab, pictured right.

 

Click Add and enter

sudo firestarter --start-hidden

as the startup command. Click OK and you're done.

 

To stop Firestarter from loading on login, simply remove its entry from the startup programs listing.

 

Using KDE:

 

Open a terminal and execute the following two commands:

 

echo -e '#'\!'/bin/sh\nsudo firestarter --start-hidden' > ~/.kde/Autostart/firestarter

chmod a+x ~/.kde/Autostart/firestarter

 

Firstarter will now load automatically when KDE starts. To stop Firestarter from loading when you log in, remove the ~/.kde/Autostart/firestarter file.

 

 

I did that exactly,now i'm getting error message:

[user@user Autostart]$ ./firestarter

Sorry, user user is not allowed to execute '/usr/sbin/firestarter --start-hidden' as root on user

 

 

(replaced my username with "user",and "localhost" as well,since there reads my username instead of "localhost",i have configured network that way.)

 

 

I did that terminal session in root, and usermode,just to see if that would have different outcome.it did not.

 

 

Thank you..

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

Well,well,......This is such a shame :woops: :woops: Problem was solved by this:

 

Note: Debian users should replace /usr/bin/firestarter with /usr/sbin/firestarter in the above line.

 

Never have 7 - 10 windows open same time,and making configurations....

 

I really thought,that i tried that thing already......well,anyway it's ok now.

Share this post


Link to post
Share on other sites
Guest Lonnie

There seems to be a bug in /etc/sudoers. I've written an article that describes

a work around:

 

http://www.howtoadvice.com/AutoFirestarter/

 

Ultimately, we should lobby for Firestarter's development team to abstract our

desired behavior (of launching the Firestarter status icon upon login) to a

check box in its preferences menu.

 

Lonnie Lee Best

Share this post


Link to post
Share on other sites
Guest olaf_ej

I'm sorry but the gnome solution is not or no more good.

 

I know, this topic is old but give wrong information now about the gnome autostart solution.

 

So i searched all the evening and find a good (and simple) solution on my mandriva 2010.2 and Gnome.

 

HERE it is:

 

- as root, launch

visudo

- add to the end

username ALL= NOPASSWD: /usr/bin/firestarter

replace "username" by your prefered user

- as root, install xsudo

urpmi xsudo

- open a terminal with your prefered user and launch

gnome-session-properties

- Add an application and fill it :

Name: Firestarter

Command: xsudo /usr/bin/firestarter --start-hidden

Comment: write the name of your dog, or your kid if your dog is ok.

 

Restart and say wouha.

 

In the firestarter settings, it's better to choose to minimize in the task bar, so it won't close when you click the cross.

 

byebye.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...