Jump to content
Sign in to follow this  
Caraibes

Canon ip 1500 printer

Recommended Posts

You could try resolving the host, for example:

 

host canon-europe.com

 

or whatever the domain is. If that fails to give lookup info, then DNS isn't working.

 

You could try another DNS server, a UK one - 194.72.9.39 and make sure this is the only entry in your /etc/resolv.conf and try again. If it works with one and not the other, then that would hint at a DNS lookup problem perhaps.

 

Sometimes ISP's do block IP's because of spam etc, so it could be they fall into an unfortunate range or something.

Share this post


Link to post
Share on other sites

Let's not make it too complicated - I doubt John wants to have that site be accessible on a permanent basis... I did nslookup for www.canon-europe.com, here is IP address:

Non-authoritative answer:
www.canon-europe.com	canonical name = www.wip.canon-europe.com.
Name:   www.wip.canon-europe.com
Address: 217.150.145.20

John, try using the IP address. If it's a DNS problem, you should be able to resolve it by using the IP address in the browser URL.

Share this post


Link to post
Share on other sites

I know I was just giving John the commands to test it out!

Share this post


Link to post
Share on other sites

Thank you both. I tried your suggestions but neither worked.

I tried using Galeon and got the same unsuccessful results as Firefox1.5.

I tried Konqueror and guess what ???. I was able to login in to the site and successfully download the drivers for iP1000, iP1500 and iP2200. The website is quite hairy. I had to try a number of times to get various pages to load but finally got there.

The problem seems to be in Firefox and Galeon, or the Mozilla factor which is common to both. I did try disabling the anti popup and allowed cookies in them both as well but it made no difference.

 

 

Cheers. John.

Edited by AussieJohn

Share this post


Link to post
Share on other sites

Do you have ipv6 enabled in firefox? You can disable this:

 

type "about:config" without the quotes in the url bar and press enter.

filter by ipv6 and set this option to "true" to disable ipv6.

 

Maybe that might help, but unsure, since it's only this website you're experiencing probs with.

Share this post


Link to post
Share on other sites

Thank you Ian, that did the trick .

 

What exactlty is ipv6 anyway ???. I have never found it necessary to make this kind of change before now.

 

Don't forget to keep it in simple laymans language :D :D .

 

Cheers. John.

Share this post


Link to post
Share on other sites

Just an update the Cannon filter drivers from the Japanese ftp site I posted earlier do work in Mandy. In adition to Pixma drivers they also have just about every Canon model driver that they suport in Linux as well as src.rpm.s and even lprng drivers. Guess Lprng is an alternative to cups ?

 

I followed the recommendation on the cups site and downloaded the cnijfilter-common and the mp500 both have to be installed to make the mp500.pdd file needed. 2007 lacked 2 files needed to install the common.

Urpmi and rpmdrake could not resolve the dependencys even though I spent 2 hours re-configuring the mirrors .

 

Google'ing I found http://rpm.pbone.net and in minutes I had found and downloaded libgtk+1.2-1.2.10-45mdv2007 and

libxml1-1.8.17-9mdki586.rpm. Dependency's resolved the filterdrivers installed and I was up and running although I am limited to 600x600 dpi as the Cups website had written.

 

I hope this may be of some help.

Share this post


Link to post
Share on other sites
Thank you Ian, that did the trick .

 

What exactlty is ipv6 anyway ???. I have never found it necessary to make this kind of change before now.

 

Don't forget to keep it in simple laymans language :D :D .

 

Cheers. John.

 

As you know, most IP's are nnn.nnn.nnn.nnn - this is effectively what the call ipv4 - Internet Protocol version 4. IPV6 - Internet Protocol version 6, is an attempt to get even more addresses. Because of course, with ipv4 the internet will run out of being able to provide ipv4 addresses. IPV6 addresses find of look like:

 

 

fff:aaa:0001:bcde:0001:aaaa

 

and so on, not exactly sure how long they are (got ipv6 disabled on my system :P ) but as you can see already with the above random example that I made, it far exceeds ipv4 capability thus providing thousands if not millions more ip addresses than current.

 

There's two ways of disabling ipv6. The first is within the browser, to stop Firefox trying to use it. The second is system level by adding:

 

alias net-pf-10 off

 

to /etc/modprobe.conf. If you do an "ifconfig" if you see an ipv6 entry in the results, then you have ipv6 enabled on your system. It's hardly used at present - if at all, so I just disable it in Firefox and at system level.

Share this post


Link to post
Share on other sites

Thanks Ian I now understand it to a degree. I will have a look in the other file you mention. It probably is disabled there and that would account why Konqueror worked and the mozilla based ones didn't.

 

Thanks once again for your persistance and to everyone one else who contributed.

 

Cheers. John.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...