Jump to content

Can't install Cups - bad signature file

Guest cymro

Recommended Posts

Guest cymro

Hi, Just trying to install cups (warning - newbie here)

rpm -qa | grep cups





urpmi cups




To satisfy dependencies, the following 4 packages are going to be installed (12 MB):
Is this OK? (Y/n) y

The following packages have bad signatures:
/var/cache/urpmi/rpms/libopenslp1-1.0.11-6mdk.i586.rpm: Missing signature (Unable to read rpm file)
/var/cache/urpmi/rpms/xinetd-2.3.13-2mdk.i586.rpm: Missing signature (Unable to read rpm file)
Do you want to continue installation ? (y/N) y
installing cups-1.1.23-17.1.20060mdk.i586.rpm cups-common-1.1.23-17.1.20060mdk.i586.rpm libopenslp1-1.0.11-6mdk.i586.rpm xinetd-2.3.13-2mdk.i586.rpm from /var/cache/urpmi/rpms
unable to install package /var/cache/urpmi/rpms/libopenslp1-1.0.11-6mdk.i586.rpm
unable to install package /var/cache/urpmi/rpms/xinetd-2.3.13-2mdk.i586.rpm
Installation failed:
	xinetd is needed by cups-1.1.23-17.1.20060mdk.i586
	libslp.so.1 is needed by cups-common-1.1.23-17.1.20060mdk.i586


As I mentioned - I am new - can anyone tell me what I am doing wrong. Thanks



[moved from Hardware by spinynorman - welcome aboard :)]

Link to comment
Share on other sites

Welcome aboard :)


What you did is basically okay. If you have broadband, please try the following three steps from a terminal as root user:


urpmi --clean (=clean the rpm system-cache, so you get new packages)

urpmi.update -a (=update all mirror information)

urpmi cups (= well... you know...)


Hope it helps. If not, let us know. Good luck.

Link to comment
Share on other sites

  • 2 weeks later...

Hi Arctic,


I am not sure about the result that cyrmo had... But I am hoping if you can help me even though it has not solved yet...


When I had upgraded to KDE 3.5 before family vacation and printer is not working as well as bad signtures from cups too.... However, tomorrow I will return home to get printer fixed as possible since my cups seems not function right... I tried to update just like cyrmo did; this got me attention and hope if that procedure should fix it even though I upgraded with cups' bad signture??


urpme cups
urpmi --clean
urpmi.update -a
urpmi cups


What do you think of process since cups is still in my system... removed cups before clean the system-cache?



Edited by dmzeplin
Link to comment
Share on other sites

It won't fix the bad\missing signature problems since the problem is in the packages not on your system, well at least with the signatures part. The 2006 release had and it looks like still has a ton of badly signed packages. You can avoid signature checking with the --no-verify-rpm switch e.g.

urpmi --no-verify-rpm cups

Link to comment
Share on other sites

Many thanks for feedback... look like --no-verify-rpm ____ is great idea to do that ensure you will get good signatures...


Apparently, my cups have installed with good signature, but still having problem with printer... I will stop this issue and move on with printer topics...


Many thanks!

Link to comment
Share on other sites

--no-verify-rpm is actually a bad idea... after all, if Mandriva cannot maintain RPM's with valid signatures on their main repository, then what's the point using any sort of validation?

Not that things were MUCH better in the past... but personally, I can't recall having missing or bad signatures from packages of the main repository!

Link to comment
Share on other sites

I see... Guess CUPS has more issues with bad signature than others in 2006.0 since it is building from new? Since I am using Mandriva 2006.0... I also saw libpython has bad signature when I upgraded from 3.4 to 3.5.2 recently... But I need to get CUPS work properly first as I want printer to work as well...


Thanks for your input opinion, I will just install normal operate unless bad signature come up, then i can verify with --no-verify-rpm..... Huh??

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...