Jump to content
Sign in to follow this  
lavaeolus

Things that may be of interest for Notebook Users

Recommended Posts

just some things I experienced on my notebooks with Mandriva 2006

 

Suspend:

 

often Suspend-to-RAM does not work at all, Suspend-to-Disk is less problematic

 

you may need either the up-1GB or the multimedia-kernel for suspend to work at all

 

install the suspend-scripts-force-rpm, although it just changes the basic suspend-scripts, which can be done by hand too

 

cpu-frequency-scaling:

 

powernowd-rpm works on intel-cpus too (it works on all cpus that support frequency-scaling, it does the same as cpudyn, but since I use powernowd, my system runs cooler)

 

laptop-mode-tools may prolong your battery-life, but may need some tweaking

 

if you have a sleep-button, you can configure it either for S-to-R or S-to-D by editing /etc/acpi/events/sleep:

 

event=button/sleep

action=/usr/sbin/pmsuspend2 memory

 

is for Suspend-to-RAM

 

event=button/sleep

action=/usr/sbin/pmsuspend2

 

is for Suspend-to-Disk

 

acme may let you use some of your multimedia-buttons

 

if boot-time is very slow with lilo, you should add the entry

 

compact

 

to the general options of your lilo.conf

Share this post


Link to post
Share on other sites

some updates:

 

since I forgot some things on my original post here they are:

 

acpitool is a nice console tool, it gives you detailed information about the acpi-related stuff on your system, nicest thing is, it can show you if your batteries are still up to their full design capacity or on the way to death, and specially for toshiba-users it has the nice option to force the cpu-fan on or off (although I haven't the chance to test this, no toshiba on hand, sorry)

 

for omnibook users there is a tool called komnibook, but it works only with a kernel that has the omnibook-kernel-module enabled (afaik the multimedia-kernel has it enabled), but tests on two omnibooks were without success, since the tool seems not to work with kernel 2.6

 

Direct Rendering (Hardware-3D) problems with SXGA+ (1400x1050):

 

maybe your Direct Rendering (Hardware-3D) won't work with 1400x1050, you may get it working by reducing the resolution to 1280x1024 (not through grandr or krandr, but by telling XFdrake (or YAST; or whatelse) your monitor does only 1280x1024, but be warned, your screen will look ugly with 1280 scaled up to 1400, so this is only an option if you really need Hardware-3D, and sometimes XFdrake refuses to use these settings, since it insist on your 1400-Display)

 

this Hardware-3D problem is not madriva-specific, had this on several suses and ubuntus too, and if you have xinerama enabled Hardware-3D will get disabled (this is not only the case on Notebooks)

 

hot-swapping

 

once it worked, but now pulling out my hot-swap media-bay locks my system entirely (think this occured first when the kernel was changed to 2.6 and udev was used, but I'm not entirely sure)

 

if you have an IBM Thinkpad, you may be lucky; just be sure that ultrabayd is enabled as a service on startup (you can check/enable this in MCC/System Services), ultrabayd is part of the tpctl-package, so check if it is installed on your thinkpad (it should be)

 

you may try to unregister your media-bay/corresponding IDE-interface with hdparm, but this may or may not work (for me it did not :wacko: )

 

this is again not mandriva-specific, tested it on suse 9.3 and ubuntu 6.06, all the same, for ubuntu there is a utility called hotswap (there is even a GUI-interface), but it seems that it tries nothing else than what I tried through hdparm (btw, it did not work for me, and it seems that the basic-tool is not maintained anymore)

 

I tried this with kernels up to 2.6.15 (the one in ubuntu), since the IDE-part seems to be a work in progress at the moment, tests with newer kernels may give different results

 

there is another thinkpad specific tool called apmiser, don't know what it does, but seems to do some energy-saving if you're on batteries, just like the laptop-mode-tools

 

an update to multimedia-buttons: even with acme not all of your buttons may work (I have four on my omnibook, those for browser and email work, the other two, which were for HP-specific tools don't)

 

this maybe a bit offtopic, but the volume, mute and email-button (for chat-button I don't know, don't use it) on my logitech mx-610 all work without any configuration needed :D

 

one last note: do not use too many tools in parallel, e. g. cpudyn AND powernowd (mandriva lets you install both, while ubuntu wisely uninstalls one of them), some tools may interfere with each other, especially be cautious with all those energy-saving tools, sometimes I have the impression they are not more than placebo

Edited by lavaeolus

Share this post


Link to post
Share on other sites

some things got better with hot-swapping:

 

after I installed the package udev-tools I get at least a half-working hot-swap; when I pull out the media-bay the system freezes, but when I put it back in the system responds again, before it would just freeze and could only be reawakened by a reset

 

one thing still remains mysterious: after that gnome thinks I have a cd-burner but the dvd-drive still works ok

 

this lasts until I either run harddrake or reboot

Edited by lavaeolus

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...