Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Guest henrikuggla

Trouble upgrading to Cups 1.2.1

Recommended Posts

Guest henrikuggla

Hi

 

I recently upgraded to your cups 1.2.1. After the upgrade my printer didn't work anymore. Cups says it is "off-line" and it seems that cups can't see my paralell port. I'm quite new to Linux and need help to get my printer working again.

 

regards

/HU

Share this post


Link to post
Share on other sites

First, a huge welcome to MUB. Just the bestest site in the universe (well pretty close). :D

 

 

 

I guess you did Cups from Cooker. I found that too. The only way out is to uninstall it and reinstall the updated version for your particular OS.

 

I have an Epson Photo-EX and it too is a parallel port printer.

 

Cooker is experimental and not fully debugged packages. You always use it at your risk. You may find sum suggestions in the Cooker forum here but don't hold your breath.

 

Cheers. John.

Edited by AussieJohn

Share this post


Link to post
Share on other sites
Guest henrikuggla

I idid try to uninstall the cups rpm and replace it with the older official cups 1.1 but the problem remained. It must be a configuration issue or perhaps some other rpm installed along with the cups rpm.

 

I'm using Mandriva 2006 and installed the rpm from http://www.mde.djura.org/. I was aware that it wasn't an official package but I didn't think it was experimental.

 

Thanks for your quick reply but the problem remains

 

/HU

Share this post


Link to post
Share on other sites
I'm using Mandriva 2006 and installed the rpm from http://www.mde.djura.org/. I was aware that it wasn't an official package but I didn't think it was experimental.

Isnt experimental inthe way you say it, the problem is that kde nows needs to be fixed due to this new cups, anyway to fix this edit the file /etc/cups/cupsd.conf and replace the line (or put it as a comment):

 

Listen /var/run/cups/cups.sock

 

with the line:

Listen localhost

 

Then logout and voila, you have cups working again :)

Share this post


Link to post
Share on other sites
Guest henrikuggla

I've tried what you said but the problem remains. In cups web interface there is no paralell port in the list of ports when adding a printer. In kde the local printer radio button is greyed out when adding a printer.

 

/HU

Share this post


Link to post
Share on other sites
I've tried what you said but the problem remains. In cups web interface there is no paralell port in the list of ports when adding a printer. In kde the local printer radio button is greyed out when adding a printer.

 

/HU

There isnt any problem, the option to add a printer through a paralel ot usb port appears greyed when there isnt no printer attached to your machine, this is logical.

 

If you attach a printer to your machine then the option will appear available.

Share this post


Link to post
Share on other sites
Guest henrikuggla

The printer IS attached to the computer! When I run Mandriva printerdrake it detects it and installs it but printerdrake says it is inactive and nothing happens when I try to activate it. Cups says that the printer port is busy. Nothing gets printed. At one time the the printer que got printed at boot but then the issue remained.

 

Sometimes when I've tried to reinstall the printer using printerdrake there is a message box saying something about making printing port available to cups but cups still can't see any paralell port.

 

/HU

Share this post


Link to post
Share on other sites

the only problem i had was that after i add the printer i didnt saw it available so i id logout and then the printer was available.

 

A fact is that to print a file is too slow, really very slow, ill try check what is delaying it so much.

Share this post


Link to post
Share on other sites

I have tried but i really dont see how is possible to run cups-1.2.1 well, so i have decided to start using cups-1.1.2 from Mandriva 2006 and next kde releases will be built against that cups version.

 

greetings,

Share this post


Link to post
Share on other sites
Guest henrikuggla

Hi again!

 

I installed Hplip and got a port in Cups called hp:/par/HP_LaserJet_5L?device=/dev/parport0. Using that port makes the printer work. Hplip doesn't support my printer though so installing Hplip doesn't make sense exept for the port.

 

/HU

Share this post


Link to post
Share on other sites

I'm not a Mandriva user anymore, but I'd like to report that in the Arch Linux forums we have a HUGE list of complaints about cups 1.2.X ...

My printer works OK, but it's not local, so it seems there is really something wrong about the new cups versions, especially if they are called from KDE applications.

mmodem's decision seems the right thing to do at the moment.

Share this post


Link to post
Share on other sites

Likewise I just updated to cups-1.2.1-4 from the MDE repo and had a similar problem in that KDE apps could not find the cups server - saying that it was not there or misconfigured. After much hair pulling - removing the packages with nodeps and reinstalling cups, cups-common, and libcups2 the problem was still there. I did get it working by explicitly stating the SeverName in cupsd.conf and client.conf (located in /etc/cups/), also turned browsing off in cupsd.conf.

 

This works - but it takes aabout 5 seconds for the printer to befound

 

 

The printer is a Canon S-750 with turboprint

Share this post


Link to post
Share on other sites

In cups.conf replace the line that haves (or just put it as a comment):

Listen /var/run/cups/cups.sock

 

replace with:

Listen localhost

 

And from now on the only prob will be the time that takes to load.

Share this post


Link to post
Share on other sites

Here's what I had to do in debian etch:

 

In kdeprintrc,make sure you have these lines,

 

[CUPS]

Host=localhost

Port=631

 

in /etc/cups/cupsd.conf, comment out,

 

#Listen /var/run/cups/cups.sock

 

Finally,

 

/etc/init.d/cupsys restart

Edited by agendelman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×