Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
aioshin

how to force change of password on next login?

Recommended Posts

ok.. Im still on LE 2005, and dont find that option on it, ( I dont know if 2006 have this).. on xandros, it has an option on GUI passwd management to force the user to change the passwd on the next login... on cli.. -e option is used on the command "passwd".. same with OpenSuse, it has the -e option to do the same on cli... how should I do it on mandriva? any Idea? (man page says nothing about it...)

 

TIA!!!

 

btw, NIS or LDAP is not an option... :P

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

passwd -e [accountname]

should work on all systems. try checking passwd options with:

man passwd

i don't understand why mandriva would remove this option...and unfortunately I don't have mandriva installed to check...

Share this post


Link to post
Share on other sites

here''s the output of passwd --help on Mandriva 2005 and they are similar with centos (an RHClone)

Usage: passwd [OPTION...] <accountName>

-k, --keep-tokens keep non-expired authentication tokens

-d, --delete delete the password for the named account (root only)

-l, --lock lock the named account (root only)

-u, --unlock unlock the named account (root only)

-f, --force force operation

 

-x, --maximum=DAYS maximum password lifetime (root only)

-n, --minimum=DAYS minimum password lifetime (root only)

-w, --warning=DAYS number of days warning users receives before

password expiration (root only)

-i, --inactive=DAYS number of days after password expiration when an

account becomes disabled (root only)

-S, --status report password status on the named account (root

only)

--stdin read new tokens from stdin (root only)

 

Help options:

-?, --help Show this help message

--usage Display brief usage message

 

and in opensuse

 

passwd - change password information

 

-f Change the finger (GECOS) information

-h Change the home directory

-s Change the login shell

-g Change the group password

-k Change the password only if expired

-q Try to be quiet

-S Show the password attributes

-a Only with -S, show for all accounts

-d Delete the password for the named account

-l Locks the password entry for "account"

-u Try to unlock the password entry for "account"

-e Force the user to change password at next login

-n min Set minimum field for "account"

-x max Set maximum field for "account"

-w warn Set warn field for "account"

--service srv Use nameservice 'srv'

-D binddn Use dn "binddn" to bind to the LDAP directory

-P path Search passwd and shadow file in "path"

--stdin Read new password from stdin (root only)

--help Give this help list

--usage Give a short usage message

--version Print program version

 

yeah.. I dont understand why that option is not available...on mandy

Edited by aioshin

Share this post


Link to post
Share on other sites

I also have 2005 and I haven't got the -e option either. It's not in the help, it's not in the man, and when I try it I get the error:

passwd: bad argument -e: unknown option

.

Sorry I can't help fix it but at least now you know it's not just you :)

Share this post


Link to post
Share on other sites

I dont get it... might be that RedHat does not have that option either.. as i've mentioned above.. the output of command "passwd --help" on my Mandriva 2005 and on My Centos Box are similar.. does not have the -e option... Centos is a Clone of redhat.. but why?

.

Is there a way to re-install the passwd util package? from source?

Share this post


Link to post
Share on other sites

did you check in the user configuration program (GUI) that mandriva provides? maybe they have the option hidden in there.

Share this post


Link to post
Share on other sites
did you check in the user configuration program (GUI) that mandriva provides? maybe they have the option hidden in there.

 

I already check the GUI passwd management of mandriva and NONE..

 

Are you sure the "shadow" package is installed? (it isn't by default in some distros).

 

#urpmi shadow-util
The package(s) are already installed

 

I think that's what you mean.. so its been already installed.

.

Oh mandy.. mandy, what have you done?...

Edited by aioshin

Share this post


Link to post
Share on other sites

Couldn't find it either... Only thing available was the old "change password after XX days" function. :unsure:

Share this post


Link to post
Share on other sites

I can confirm Red Hat doesn't have it either. So it's not just Mandy that have done it.

 

Unfortunately, you can't remove passwd, since it will remove basesystem and break your system. This is what it said on mine:

 

urpme passwd
removing package basesystem-10.1-5mdk.i586 will break your system
Nothing to remove

Share this post


Link to post
Share on other sites

mandy, redhat, centos, have'nt check FC about it, but I dont understand why that option is not available on them, is that particular function, on them some kind of vulnerability? :unsure:

.

hope they will add that function on their passwd-util, Suse, Xandros and Mepis have that so why not on them... though a very little function, but still, very important on a system that handles multiple users...

Edited by aioshin

Share this post


Link to post
Share on other sites

eh... to them... disregard the request..(but just incase they would like to, its better).. . got an answer from a certain guy. though different command but sort of have the same effect ..

 

#chage -d 0 username

 

sorry, I really did'nt know it, but now I know

.

 

Thanks Guys !

Edited by aioshin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×