Jump to content
neilinoz

Firefox 1.5.0.3 problems

Recommended Posts

I just installed Firefox 1.5.0.3 and I am quite impressed by it so far, especially some of the extensions - Noscript 1.1.4.1 being my fave.

 

But there is something wrong. I have a blog page and whenever I try to edit or write blogs it is verrrrrry slow in responding. I thought it might have something to do with Noscript so I enabled all scripts for blogger.com and blogspot.com but that hasn't solved it. I went to my internet banking site and that functioned perfectly.

 

According to my gnome system monitor (which I use despite the fact I use KDE) whenever I am in blogger and am trying to write, paste and edit my blog postings, the CPU runs at 100%. It is as though blogger - no other site - is causing my entire system to slow down. This was not happening while I was using my previous Firefox (1.0.2).

 

I have the following extensions:

 

DOM inspector 1.8.0.3

PDF Download 0.6

Tabbrowser preferences 1.2.8.9

Flashblock 1.5.1

Nuke anything 0.2

Noscript 1.1.4.1

Fasterfox 1.0.3 (set at "courteous")

Videodownloader 1.0

Yahoo Mail notifier 0.9.9.2

 

I also have Chatzilla 0.9.73 but found it not to my taste so I uninstalled it. However it is still sitting in my "Extensions" list and cannot be installed/uninstalled or accessed.

Share this post


Link to post
Share on other sites

If you set fasterfox to normal mode and then check out the blogger site, how does it perform?

 

I'm just wondering, in case that particular site has something that counteracts fasterfox, if that is possible, by slowing it down, rather than making it work faster.

Share this post


Link to post
Share on other sites

I put fasterfox on "Turbocharged". Everything downloaded quickly enough, but as soon as I started editing, pasting etc it slowed down the same way as before with 100% CPU load.

Share this post


Link to post
Share on other sites

OK, but rather than accellerate it, try it at normal speed without all the alterations. I just want to see if fasterfox is the cause of the problem. It could be that their site is setup to detect fasterfox and slow it down.

 

But this is a guess, just trying to eliminate fasterfox as the cause.

 

EDIT:

 

I'm using FF 1.5.0.3 without any of these problems. These are my extensions:

 

Talkback
DOM Inspector
Download Manager Tweak
Adblock
Inline Auto Complete
PDF Download
Fasterfox

 

I'd be tempted to disable/remove some of your extensions as they could be the cause of the problems.

Share this post


Link to post
Share on other sites

No, fasterfox didn't change the problem when I disabled it. I'll remove my extensions and see what happens. More soon.

-------------------

Okay, I have removed all of my extensions with the exception of DOM inspector (which is Thunderbird) and Chatzilla (which, for some reason, I can't uninstall), and the problem still remains with blogger.

 

I'm thinking it might have something to do with my choice of character encoding. Changing between Western (ISO-8859-1) and Unicode (UTF-8) makes no difference. When I go Edit --> Preferences --> Content, my default font is Times New Roman. When I from there to --> advanced, my proportional is "Serif", my Serif is Times New Roman, my Sans serif is Arial and my Monospace is courier. I am mentioning this because I remember changing this just after getting 1.5.0.3 and waiting a HECK of a long time for Firefox to respond again, which leads me to believe that this may actually be the problem.

 

Meanwhile I am going to reinstall my extensions.

Edited by neilinoz

Share this post


Link to post
Share on other sites

You don't have to remove your extensions, start FF1.5 in safemode, it will start with all extensions disabled, if the problem goes away, then you could start to look at your extensions one by one to eliminate them.

 

/path/to/firefox/firefox -safe-mode

 

[EDIT] To late she cried :)

Edited by jagwah

Share this post


Link to post
Share on other sites

I've been playing around with the fonts and character coding. Still no change.

 

I'm fairly certain that Firefox is trying to execute something heavy on CPU usage that can be found when you do editing in Blogger.

Share this post


Link to post
Share on other sites

Went into a command shell as SU and typed the command. Another Firefox browser opened, I went into that browser and tried to edit/paste in blogger - same problem. CPU at 100% etc.

 

I have Mozilla 1.7.12 installed just in case I have problems with Firefox, and I have just tried editing/pasting in blogger.

 

No problems at all.

 

I'm hoping this fact might help people's problem solving.

 

(No I don't wish to migrate back to Mozilla)

Share this post


Link to post
Share on other sites

If I had your problem, I would uninstall Firefox and reinstall it. Also, you could try another version (like 1.5.0.2) to test if the problem is with the new version. You can get it easily from places like www.seerofsouls.com. Just download and install the rpm, not the whole hdlist.

 

Post here again if you have problems.

Share this post


Link to post
Share on other sites

I uninstalled it via Mandriva Software Packages Removal and then installed it again via Install Software.

 

It sped up slightly but the problem is still there. I'll uninstall it again and install 1.5.0.2.

Share this post


Link to post
Share on other sites

Rename your /home/username/.mozilla directory as this is your cache, plus plugins etc.

 

Then restart Firefox after to create new cache, etc.

 

mv .mozilla .mozilla.old

 

as an example from within the username directory, where username = your user. If Firefox, regardless of version, finds the .mozilla directory, it will use this by default, so you'd end up with the same problems.

Share this post


Link to post
Share on other sites

Installed 1.5.0.2 and changed .mozilla directory name. When I started Firefox everything was different with all my bookmarks gone etc etc which obviously means I did the right thing.

 

Problems with blogger? Yes. Still.

 

:wall:

 

So obviously the problem lies with Firefox itself. I'm starting to think now the possibility that my CPU is finally showing its lack of grunt - it is a P3 600E. I've noticed that performance is handicapped when opening 4 or more pages in tabs at once - which was true with 1.0.2 but even more so now. I'm tempted to say that 1.5.0.3 is not really suitable for older CPUs.

Share this post


Link to post
Share on other sites

Rename your /home/username/.mozilla directory as this is your cache, plus plugins etc.
Then restart Firefox after to create new cache, etc.

 

ianw1974:

Running firefox -profilemanager accomplishes the same thing. This command can be used to create a new user within .mozilla with a new cache, bookmarks, preferences, etc.

 

neilinoz:

You P3 600 should be fine with firefox, so don't throw it away yet. :P . The only other suggestion I have is to try posting your problem on the MozillaZIne forums (http://forums.mozillazine.org/). There are some very firefox savy folks there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...