Jump to content
jethro

USB crashes

Recommended Posts

Add this line to your /etc/modprobe.conf:

 

install usb-interface /sbin/modprobe uhci-hcd; /bin/true

 

and comment out this one by putting a # in front of it:

 

#install usb-interface /sbin/modprobe ohci-hcd; /sbin/modprobe ehci-hcd; /bin/true

 

does it help? (I put the # in above, so you can see how this line should look when finished).

Share this post


Link to post
Share on other sites

This what modprobe.conf looks like now:

[jethro@0a0d12f9a6a ~]$ cat /etc/modprobe.conf
remove snd-hda-intel /sbin/modprobe -r snd-pcm-oss; /sbin/modprobe --first-time -r --ignore-remove snd-hda-intel
install snd-hda-intel /sbin/modprobe --first-time --ignore-install snd-hda-intel && { /sbin/modprobe snd-pcm-oss; /bin/true; }
alias eth0 8139too
alias sound-slot-0 snd-hda-intel
alias net-pf-10 off
install scsi_hostadapter /sbin/modprobe sata_sil; /bin/true
# install usb-interface /sbin/modprobe ohci-hcd; /sbin/modprobe ehci-hcd; /bin/true
install usb-interface /sbin/modprobe uhci-hcd; /bin/true
remove unknown /sbin/modprobe --first-time -r --ignore-remove unknown
install unknown /sbin/modprobe --first-time --ignore-install unknown
remove snd-atiixp /sbin/modprobe --first-time -r --ignore-remove snd-atiixp
install snd-atiixp /sbin/modprobe --first-time --ignore-install snd-atiixp
options snd-hda-intel position_fix=1
alias ath0 ath_pci
alias ath0:9 ath_pci

 

For a moment there I thought it worked and I was very happy, but after 20 minutes or so, the USB crashed again :(

 

This is what lsmod looks like:

root@0a0d12f9a6a jethro]# lsmod | grep usb
usbmouse				3808  0
usbhid				 42528  0
usbcore			   100476  5 usbmouse,usbhid,ehci_hcd,ohci_hcd

Edited by jethro

Share this post


Link to post
Share on other sites

This is contents of my /etc/modprobe.conf:

 

alias eth0 e100
install usb-interface /sbin/modprobe uhci-hcd; /bin/true
options snd  device_mode=0666
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

 

the last 3 lines are relating to my sound card. I checked another machine I have, and it just has one other the scsi_hostadapter. Going by your /etc/modprobe.conf, I've made some changes, so let's see what happens next. First take a copy of your current file just in case:

 

cp /etc/modprobe.conf /etc/modprobe.conf.old

 

now, the new config:

 

#Network config
alias eth0 8139too
alias net-pf-10 off

#SCSI hostadapter
install scsi_hostadapter /sbin/modprobe sata_sil; /bin/true

# USB config
# first line is old config commented out, second is new one
# install usb-interface /sbin/modprobe ohci-hcd; /sbin/modprobe ehci-hcd; /bin/true
install usb-interface /sbin/modprobe uhci-hcd; /bin/true

#Sound config
remove snd-hda-intel /sbin/modprobe -r snd-pcm-oss; /sbin/modprobe --first-time -r --ignore-remove snd-hda-intel
install snd-hda-intel /sbin/modprobe --first-time --ignore-install snd-hda-intel && { /sbin/modprobe snd-pcm-oss; /bin/true; }
alias sound-slot-0 snd-hda-intel

# not sure about these unknown lines, possibly something to do with soundconfig
remove unknown /sbin/modprobe --first-time -r --ignore-remove unknown
install unknown /sbin/modprobe --first-time --ignore-install unknown
#continue of sound config
remove snd-atiixp /sbin/modprobe --first-time -r --ignore-remove snd-atiixp
install snd-atiixp /sbin/modprobe --first-time --ignore-install snd-atiixp
options snd-hda-intel position_fix=1

 

I would be tempted to place # in front of all the sound lines just purely while we are testing to see what happens. I have a very minimal config for mine, and I use alsa for sound. I'm not sure if yours is or not. But that's something that's easily identifiable later.

Share this post


Link to post
Share on other sites

Alright, this is how my /etc/modprobe.conf looks now:

[jethro@0a0d12f9a6a IsaViz]$ cat /etc/modprobe.conf
### Network config
alias eth0 8139too
#alias net-pf-10 off

### SCSI hostadapter
install scsi_hostadapter /sbin/modprobe sata_sil; /bin/true

### USB config
# first line is old config commented out, second is new one
# install usb-interface /sbin/modprobe ohci-hcd; /sbin/modprobe ehci-hcd; /bin/true
install usb-interface /sbin/modprobe uhci-hcd; /bin/true

### Sound config
#remove snd-hda-intel /sbin/modprobe -r snd-pcm-oss; /sbin/modprobe --first-time -r --ignore-remove snd-hda-intel
#install snd-hda-intel /sbin/modprobe --first-time --ignore-install snd-hda-intel && { /sbin/modprobe snd-pcm-oss; /bin/true; }
#alias sound-slot-0 snd-hda-intel

### not sure about these unknown lines, possibly something to do with soundconfig
#remove unknown /sbin/modprobe --first-time -r --ignore-remove unknown
#install unknown /sbin/modprobe --first-time --ignore-install unknown

### continue of sound config
#remove snd-atiixp /sbin/modprobe --first-time -r --ignore-remove snd-atiixp
#install snd-atiixp /sbin/modprobe --first-time --ignore-install snd-atiixp

 

I commented as much as possible, but my USB still crashes.

Share this post


Link to post
Share on other sites

I'm wondering if it's something to do with your udev rules, which are causing the crash.

 

Was this an upgrade of a previous system, or a clean install?

Share this post


Link to post
Share on other sites
I'm wondering if it's something to do with your udev rules, which are causing the crash.

 

Was this an upgrade of a previous system, or a clean install?

It was a clean install from the Mandriva One Beta Live CD.

 

Can I see this "udev rules" somewhere?

Share this post


Link to post
Share on other sites

Just out of interest, have you tried Mandriva 2006 instead? I'm wondering if it's something to do with Mandriva One instead being beta that's causing all this.

 

Mandriva One and Mandriva 2006 are virtually the same anyway, but since Mandriva One is beta, you'd probably be better off with something non-beta like Mandriva 2006.

Share this post


Link to post
Share on other sites

I have been told that, although it is called "Beta" it is actually a finished version. I could not install Mandriva 2006 because of the problem that it did not recognize my hard drive controller. So Mandriva 2006 is not an option for me.

 

Is there a way to modify these "udev rules" or something? What do they actually do?

Share this post


Link to post
Share on other sites

I'm no expert on the udev stuff, but it controls all your devices, etc. The rules are normally under /etc/udev.

 

It could be a bit hit and miss trying to sort these out, but it's all I can think of as to why you're having problems with your usb. We've figured the module is loading OK, so that's fine.

 

Have you been able to apply updates to the system?

 

EDIT:

 

I've had a thought, have you tried downloading and using a knoppix live cd? Do you have usb problems when using this? Also, if you boot and solely use the Mandriva One CD as a live cd, do you have the usb problems?

Share this post


Link to post
Share on other sites

I was able to update my system, I am doing this quite regular.

 

This is what I can find about the udev rules:

[jethro@laptop rules.d]$ pwd
/etc/udev/rules.d
[jethro@laptop rules.d]$ ll
totaal 148
-rw-r--r--  1 root root 18278 feb 24 14:04 50-mdk.rules
-rw-r--r--  1 root root   288 jan 26 20:04 60-dynamic.rules
-rw-r--r--  1 root root	51 okt 27  2005 60-hal.rules
-rw-r--r--  1 root root 36188 feb 24 14:04 70-hotplug_map.rules
-rw-r--r--  1 root root   109 dec 29 21:56 70-hp1000fw.rules
-rw-r--r--  1 root root 31300 jan 26 20:16 70-libgphoto2.rules
-rw-r--r--  1 root root 28363 feb 27 14:48 70-libusbscanner.rules
-rw-r--r--  1 root root   252 dec  2 12:28 80-eagle-usb.rules
-rw-r--r--  1 root root   184 sep 15  2005 80-speedtch.rules
-rw-r--r--  1 root root   100 sep 16  2005 alsa.rules
-rw-r--r--  1 root root   307 feb 24 14:04 hotplug.rules
-rw-r--r--  1 root root   312 feb 24 14:04 provision.tbl

 

I will boot with Mandriva One this evening or tomorrow to see if I get the USB problem then to. If I remember it correctly there where no problems when I booted from it in the past and there where also no problems when I first installed it.

Share this post


Link to post
Share on other sites

I do not have the USB problem with Knoppix or Mandriva One Beta, so it should be fixable. Perhaps there is something wrong with my device section in xorg.conf?

Share this post


Link to post
Share on other sites

xorg is mainly for the graphical display of your machine as well as keyboard and mouse. This won't be the problem for your usb devices. All this is x server related stuff.

 

I'm not sure what else to suggest, other than a clean install and see how it works. I remember you said it worked, and then stopped working, so can only think that an update caused your problem.

 

I would do a clean install, and use this for a few weeks and see what happens. Do not apply updates though, since this was when the problem started.

Share this post


Link to post
Share on other sites

Well, untill now the problem only arised when using my mouse. When I used my mouse something crashed, causing all of my USB devices to go down. So I can imagine the section about my mouse in the xorg.conf file can be wrong.

Share this post


Link to post
Share on other sites

Can you post your /etc/X11/xorg.conf, and I'll take a look at it and see if anything is obvious as to what's wrong.

Share this post


Link to post
Share on other sites

Here it is:

[jethro@dhcppc2 X11]$ cat xorg.conf

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "synaptics"
Load "dri"
Load "glx"
EndSection

Section "ServerFlags"
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us_intl"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "InputDevice"
Identifier "SynapticsMouse1"
Driver "synaptics"
Option "Protocol" "auto-dev"
Option "Device" "/dev/input/mice"
Option "MinSpeed" "0.09"
Option "MaxSpeed" "0.18"
Option "BottomEdge" "4200"
Option "SHMConfig" "on"
Option "FingerLow" "25"
Option "LeftEdge" "1700"
Option "MaxTapMove" "220"
Option "MaxTapTime" "180"
Option "FingerHigh" "30"
Option "VertScrollDelta" "100"
Option "TopEdge" "1700"
Option "AccelFactor" "0.0015"
Option "RightEdge" "5300"
EndSection
#############################
# Het ServerLayout gedeelte #
#############################
#Section "ServerLayout"
# Identifier "dual head configuration"
# InputDevice "Keyboard1" "CoreKeyboard"
# InputDevice "Mouse1" "CorePointer"
# InputDevice "SynapticsMouse1" "AlwaysCore"
# Screen "aticonfig Screen 0"
# Screen "aticonfig Screen 1" RightOf "aticonfig Screen 0"
#EndSection

Section "ServerLayout"
Identifier "big desktop configuration"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
InputDevice "SynapticsMouse1" "AlwaysCore"
Screen "aticonfig Screen 0"
EndSection
########################
# Het monitor gedeelte #
########################

Section "Monitor"
Identifier "aticonfig Monitor 0"
HorizSync 28-96
VertRefresh 50-75
Option "DPMS"
EndSection

Section "Monitor"
Identifier "aticonfig Monitor 1"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1280x768"
HorizSync 31.5 - 90.0
VertRefresh 60.0 - 60.0
Option "DPMS"
EndSection
########################
# Het device gedeelte  #
########################

Section "Device"
Identifier "ATI Graphics Adapter 0"
Driver "fglrx"
Screen 0
BusID "PCI:1:5:0"
#Option "DesktopSetup" "0x00000000" #Don't change this for dualhead
Option "DesktopSetup" "Horizontal"
#Option "Mode2" "1024x768"
Option "Mode2" "1280x1024"
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 1"
Driver "fglrx"
Screen 1
BusID "PCI:1:5:0"
Option "DesktopSetup" "0x00000000"  #Don't change this for dualhead
EndSection
########################
# Het screen gedeelte  #
########################

Section "Screen"
Identifier "aticonfig Screen 0"
Device "ATI Graphics Adapter 0"
Monitor "aticonfig Monitor 0"
DefaultDepth 24

Subsection "Display"
	Depth 24
	Modes "1280x800" "1280x1024" "1024x768" "800x600" "640x480"
	Viewport 0 0
EndSubsection
EndSection

Section "Screen"
Identifier "aticonfig Screen 1"
Device "ATI Graphics Adapter 1"
Monitor "aticonfig Monitor 1"
DefaultDepth 24

Subsection "Display"
	Depth 24
	Modes "1280x1024" "1024x768" "800x600" "640x480"
	Viewport 0 0
EndSubsection
EndSection

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...