Jump to content
jethro

USB crashes

Recommended Posts

Hi everybody,

 

I have a Toshiba A100-510 laptop. When I use a logitech optical usb mouse, the usb ports almost always crash after a period of time. This mostly is after 5 to 10 minutes. If it happens I am not able to use any usb devices anymore, not even after replugging them. I have to reboot my laptop to be able to use the usb ports again. I also have this problem with another mouse.

 

This is what /var/log/messages says right after a crash:

[usb]Apr 11 08:14:22 laptop ntpd[4035]: synchronized to LOCAL(0), stratum=10

Apr 11 08:14:22 laptop ntpd[4035]: kernel time sync disabled 0041[/usb]

 

This is what /var/log/dmesg says:

usb 1-1: new full speed USB device using ohci_hcd and address 3
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 4 ports detected
usb 1-1.1: new low speed USB device using ohci_hcd and address 4
usb 1-1.2: new low speed USB device using ohci_hcd and address 5
EXT3 FS on sda5, internal journal
Adding 1125928k swap on /dev/sda6.  Priority:-1 extents:1
devfs_mk_dev: could not append to parent for md/1
md: md1 stopped.
md: md0 stopped.
usbcore: registered new driver hiddev
input: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:13.0-1.1
input: USB HID v1.00 Keyboard [USBPS2] on usb-0000:00:13.0-1.2
input: USB HID v1.00 Mouse [USBPS2] on usb-0000:00:13.0-1.2
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.01:USB HID core driver
usbcore: registered new driver usbkbd
drivers/usb/input/usbkbd.c: :USB HID Boot Protocol keyboard driver
usbcore: registered new driver usbmouse
drivers/usb/input/usbmouse.c: v1.6:USB HID Boot Protocol mouse driver
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda7, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
ntfs: Ignoring new-style parameters in presence of obsolete ones
NTFS driver 2.1.22 [Flags: R/O DEBUG MODULE].
NTFS volume version 3.1.
loop: loaded (max 8 devices)
hdc: ATAPI 24X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20

 

Does anybody know a way to solve this?

 

Best regards,

Jethro

Share this post


Link to post
Share on other sites

What kernel version are you running:

 

uname -a

 

will tell you which version. Please post. Have you applied updates to your system yet?

Share this post


Link to post
Share on other sites

This is what uname -a returns:

Linux laptop 2.6.12-17mdk-i586-up-1GB #1 Mon Feb 13 12:49:13 MST 2006 i686 Intel(R) Celeron(R) M processor		1.40GHz unknown GNU/Linux

 

I applied updates most recently last week, I will update my system again tonight. Is this a known issues with this kernel? If it is I'm not aware of it.

Share this post


Link to post
Share on other sites

I've updated my system and installed the most recent kernel: 2.6.12-18mdk-i586-up-1GB but I still have the same problem. Does anybody have any idea?

Share this post


Link to post
Share on other sites

Have you another mouse you can try in case it's the mouse itself causing the problem. If you have a spare usb mouse that is.

 

I use a Toshiba Satellite Pro A10 with a MS USB mouse no problem, so just trying to figure out why it's different for you.

 

Oh, one more thing, double check the BIOS, they have a setting for relating to Plug and Play OS, make sure this is not chosen, else you'll have problems with hardware detection. Maybe this is causing the problem. I know I changed it in mine, but that was because it wasn't detecting the printer.

Share this post


Link to post
Share on other sites

I have tested it with two different USB mouses (both Logitech) and I had the same problem.

 

I had this option called "Legacy USB support" which was enabled. I disabled it. How is the option called in you BIOS? Add this point there are no crashes, but I'm just working with this option for about 5 minutes.

Share this post


Link to post
Share on other sites

I'll have to check my laptop and let you know what settings I've got. Hope the legacy one you've changed sorts it out!

 

If not, I'll post back shortly.

Share this post


Link to post
Share on other sites

I checked my BIOS. On page 2 there is a setting called "Device Config". This can be set to OS, or another option. Do not have it set to Setup By OS.

 

Also, my Legacy USB for KB/Mouse is enabled, but it all works fine for me. Maybe your legacy option solved your problem. If so, do post back to confirm.

Share this post


Link to post
Share on other sites

Untill now the problem is solved, but I can be sure after working with it a few days. If the problem occurs again I will report back here, otherwise it is solved. Thanks for you help!

Share this post


Link to post
Share on other sites

It seems like the problem is still present but it happens a lot less. Do you have any more ideas?

Share this post


Link to post
Share on other sites

Did you check the Device Config option in the BIOS to see if set to be controlled by the OS or not? This could be affecting it.

Share this post


Link to post
Share on other sites
Did you check the Device Config option in the BIOS to see if set to be controlled by the OS or not? This could be affecting it.

I think I do not have that option, is that possible? If I look at my BIOS I seem to have very few options.

Share this post


Link to post
Share on other sites

Perhaps booting with "noapic" and or "nolapic" might help, when I tested this the USB didn't crashed but I did not try it for a very long period of time because if I boot with this options my network card doesn't work e.g. I have no internet.

 

I have two questions:

1 - might "noapic" and / or "nolapic" help?

2 - how can I fix it so that my network card keeps working while booting with these options?

Share this post


Link to post
Share on other sites

It is strange your network card stops working, what network card is it?

Share this post


Link to post
Share on other sites
It is strange your network card stops working, what network card is it?

This is what I find out using 'lspci':

02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...