Jump to content
Sign in to follow this  
mr_coffee

Can't seem to get sound blaster audigy to work ~

Recommended Posts

Hello everyone, i have a Soundblaster audigy, u can see what type in mysignature. I am running Mandriva 2006 and the sound isn't working at all, i had this problem before awhie ago when i tried to first install mandriva 2006 powerpack but i just reb00ted and it fixed the problem automatically. I did a clean install again to fix my internet connection, so sound again doesn't work. This time the reb00ting isn't fixing it!

 

Under Sound Configuration it says:

HEre u can select an alternative driver (either OSS or ALSA) for your sound card (Creative Labs|EMU10K2 Audigy Audio Process). Your card currently uses the ALSA "snd-emu10k1" driver (default driver for your sound card is "snd-emu10k1"

 

It also shows a OSS driver called , Audigy, and another one called emu10k1, i tried both of them, both didn't work either!

 

Linux reads it as:

Identification

Vendor: ‎Creative Labs

 

Description: ‎EMU10K2 Audigy Audio Processor

 

Media class: ‎MULTIMEDIA_AUDIO

 

Connection

Bus: ‎PCI

 

Bus PCI #: ‎2

 

PCI device #: ‎5

 

PCI function #: ‎0

 

Vendor ID: ‎4354

 

Device ID: ‎4

 

Sub vendor ID: ‎4354

 

Sub device ID: ‎8194

 

Driver

Module: ‎snd-emu10k1

 

Alternative drivers: ‎audigy, emu10k1

 

 

 

[root@mybox etc]# lspcidrake -v|fgrep AUDIO
snd-emu10k1	 : Creative Labs|EMU10K2 Audigy Audio Processor [MULTIMEDIA_AUDIO] (vendor:1102 device:0004 subv:1102 subd:2002)
[root@mybox etc]# grep sound-slot /etc/modules.conf

 

This is suppose to tell me if my sound is muted or not:

[root@mybox etc]# aumix -q
aumix:  error opening mixer

 

 

Here is supppose to show me if my services can be run on int3?

[root@mybox etc]# /sbin/chkconfig --list sound
sound		   0:off   1:off   2:on	3:on	4:on	5:on	6:off
[root@mybox etc]# /sbin/chkconfig --list alsa
alsa			0:off   1:off   2:off   3:off   4:off   5:off   6:off

 

 

 

 

i'm not sure if this is helpful or not, it said in the sound trouble shooting it will show you if my driver i need is loaded or not:

 

[root@mybox etc]# /sbin/lsmod
Module				  Size  Used by
sg					 35676  0
nls_cp437			   6336  1
vfat				   11840  1
fat					47676  1 vfat
cpufreq_ondemand		7144  0
cpufreq_conservative	 8328  0
cpufreq_powersave	   2272  0
p4_clockmod			 5412  1
speedstep_lib		   4356  1 p4_clockmod
freq_table			  4672  1 p4_clockmod
raw					 7648  1
md5					 4576  1
ipv6				  247936  10
snd_emu10k1		   119972  0
snd_rawmidi			21312  1 snd_emu10k1
snd_seq_device		  7884  2 snd_emu10k1,snd_rawmidi
snd_ac97_codec		 85180  1 snd_emu10k1
snd_pcm				83812  2 snd_emu10k1,snd_ac97_codec
snd_timer			  22596  2 snd_emu10k1,snd_pcm
snd_page_alloc		  9384  2 snd_emu10k1,snd_pcm
snd_util_mem			4256  1 snd_emu10k1
snd_hwdep			   7936  1 snd_emu10k1
snd					48644  7 snd_emu10k1,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm,snd_timer,snd_hwde
p
soundcore			   8256  1 snd
parport_pc			 34020  1
lp					 11080  0
parport				33864  2 parport_pc,lp
ipt_IFWLOG			  3876  1
ipt_psd				44424  1
ip_set_iptree		   6568  2
ipt_REJECT			  5344  4
ipt_LOG				 7392  7
ipt_state			   2304  14
ipt_pkttype			 2176  4
ipt_set				 2912  2
ipt_CONNMARK			2688  0
ipt_MARK				2976  0
ipt_ROUTE			   5508  0
ipt_connmark			2208  0
ipt_owner			   3904  0
ipt_recent			 10412  0
ipt_iprange			 2304  0
ipt_physdev			 2736  0
ipt_multiport		   3104  0
ipt_conntrack		   2784  0
iptable_mangle		  3008  0
ip_set_portmap		  4864  0
ip_set_macipmap		 4772  0
ip_set_ipmap			4864  0
ip_set_iphash		   6948  0
ip_set				 20284  11 ip_set_iptree,ipt_set,ip_set_portmap,ip_set_macipmap,ip_set_ipmap,ip_set_iphash
ip_nat_irc			  2816  0
ip_nat_tftp			 2208  0
ip_nat_ftp			  3552  0
iptable_nat			21524  3 ip_nat_irc,ip_nat_tftp,ip_nat_ftp
ip_conntrack_irc	   71376  1 ip_nat_irc
ip_conntrack_tftp	   4080  1 ip_nat_tftp
ip_conntrack_ftp	   72400  1 ip_nat_ftp
ip_conntrack		   42504  9 ipt_state,ipt_conntrack,ip_nat_irc,ip_nat_tftp,ip_nat_ftp,iptable_nat,ip_conntra
ck_irc,ip_conntrack_tftp,ip_conntrack_ftp
iptable_filter		  3072  1
ip_tables			  22656  20 ipt_IFWLOG,ipt_psd,ipt_REJECT,ipt_LOG,ipt_state,ipt_pkttype,ipt_set,ipt_CONNMARK
,ipt_MARK,ipt_ROUTE,ipt_connmark,ipt_owner,ipt_recent,ipt_iprange,ipt_physdev,ip
t
_multiport,ipt_conntrack,iptable_mangle,iptable_nat,iptable_filter
r8169				  23756  0
af_packet			  19272  0
floppy				 57108  1
eth1394				18536  0
video				  15076  0
thermal				11944  0
tc1100_wmi			  6084  0
processor			  19560  1 thermal
fan					 4164  0
container			   4000  0
button				  5840  0
battery				 8452  0
ac					  4260  0
ide_cd				 39172  0
ohci1394			   34068  0
ieee1394			  291832  2 eth1394,ohci1394
loop				   16072  0
nls_iso8859_1		   4672  2
ntfs				  215448  1
supermount			 33552  1
sr_mod				 16516  0
nvram				   9064  0
nvidia			   3696136  12
agpgart				30252  1 nvidia
usblp				  12096  0
tsdev				   7008  0
usbmouse				5184  0
usb_storage			83556  0
usbhid				 46464  0
ata_piix				8260  0
ehci_hcd			   31048  0
uhci_hcd			   30960  0
usbcore			   111612  7 usblp,usbmouse,usb_storage,usbhid,ehci_hcd,uhci_hcd
evdev				   8672  0
ext3				  127784  2
jbd					54360  1 ext3
sd_mod				 17280  6
ahci					9860  4
libata				 43268  2 ata_piix,ahci
scsi_mod			  123560  6 sg,sr_mod,usb_storage,sd_mod,ahci,libata

 

 

THanks! :D

Share this post


Link to post
Share on other sites

ALSA seems to be "off" in the services, which will probably be your problem. First:

 

chkconfig alsa on

 

to enable it. Then try rebooting and/or:

 

service alsa start

 

and check if sound is working now. If in X, restart X or logout and back in again and test it. If not, then from the command prompt, run:

 

alsaconf

 

run through and configure it, and then reboot and test again. Sounds might be muted though, so use KMix or alsamixer at command line to unmute everything.

Share this post


Link to post
Share on other sites

Hm....

I did what you said, and i got:

[root@mybox coffee]# service alsa start
ALSA driver (version 1.0.9b) is already running.
[root@mybox coffee]# alsaconf

 

ANd its saying alsaconf isn't a command any idea why?

 

Now i'm getting the following, still no sound:

[root@mybox coffee]# service alsa start
ALSA driver (version 1.0.9b) is already running.
[root@mybox coffee]# /sbin/chkconfig --list sound
sound		   0:off   1:off   2:on	3:on	4:on	5:on	6:off
[root@mybox coffee]# /sbin/chkconfig --list alsa
alsa			0:off   1:off   2:on	3:on	4:on	5:on	6:off
[root@mybox coffee]#

Edited by mr_coffee

Share this post


Link to post
Share on other sites

Hey guys, thanks it finally worked after another reB00t! but it sounds like hell, can someone post a screenshot of what their kmix looks like? mine is all jacked up to the highest on everything that might be why but i don't see any presets to change it. Or does anyone kknow of a website that says what a good balance is? Thanks again guys!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...