Jump to content
rbk25

ati 9600 newbie help to install drivers

Recommended Posts

I have already started backing up all my data, so i can start the reformat in about 10 min. It shouldnt be big deal getting my system back up to par since i use easy urpmi, for a newbie.

I will try the exact steps that you posted above. I do have one question. Do i need to still download opengl from ati's website or is it going to already be in my distro?

 

thanks again. i really appreciate your help.

Share this post


Link to post
Share on other sites

No, nothing needs to be downloaded from ATI. OpenGL is in the MESA libraries we will be installing. Much better :P

Share this post


Link to post
Share on other sites

OK, just add this to the bottom. It should be like the section I have in my xorg.conf as I posted.

Share this post


Link to post
Share on other sites

as of right now i have added the dri section as you mentioned above and rebooted and checke it. looked ok to me

but still

# glxinfo | grep direct
Loading required GL library /usr/X11R6/lib/libGL.so.1.2
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect
[root@localhost ryan]#

Share this post


Link to post
Share on other sites

OK, did you install Mesa? You can do this through System/Configuration/Packaging/Install Software, and choosing the all option, and then search for mesa.

 

Then select the package named Mesa-......mdk.rpm or whatever, the libmesa required will then also be selected.

 

Or, it can be done from the prompt using:

 

urpmi Mesa

 

let me know how you've got on. If you still find that it's not working, and the load dri line and the Section dri has been included (as per the format in my xorg.conf), please post all your xorg.conf so I can take a look, and see if there is anything obvious.

Share this post


Link to post
Share on other sites

Oh, and make sure that mesa is type Mesa when you use the urpmi command, else it won't be able to install.

 

Or alternatively, use the GUI Install Software as mentioned just to make sure.

Share this post


Link to post
Share on other sites

Might it be the other way around?? i did already isntall Mesa but not mesa

 

# urpmi mesa
To satisfy dependencies, the following 3 packages are going to be installed (6 MB):
libxmms1-1.2.10-20mdk.i586
xmms-1.2.10-20mdk.i586
xmms-mesa-1.2.10-20mdk.i586
Is this OK? (Y/n) y


[root@localhost ryan]# urpmi Mesa
The package(s) are already installed
[root@localhost ryan]#

 

I did cancel out of the above mesa install before it downloaded

Edited by rbk25

Share this post


Link to post
Share on other sites

here is my xorg.conf file

 

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
   # Multiple FontPath entries are allowed (they are concatenated together)
   # By default, Mandrake 6.0 and later now use a font server independent of
   # the X server to render fonts.
   FontPath "unix/:-1"
EndSection

Section "ServerFlags"
   #DontZap # disable <Crtl><Alt><BS> (server abort)
   AllowMouseOpenFail # allows the server to start up even if the mouse does not work
   #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
   Load "dbe" # Double-Buffering Extension
   Load "v4l" # Video for Linux
   Load "extmod"
   Load "type1"
   Load "freetype"
   Load "dri" # direct rendering
   Load "/usr/X11R6/lib/modules/extensions/libglx.a"
EndSection

Section "InputDevice"
   Identifier "Keyboard1"
   Driver "keyboard"
   Option "XkbModel" "pc105"
   Option "XkbLayout" "en_US"
   Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
   Identifier "Mouse1"
   Driver "mouse"
   Option "Protocol" "ExplorerPS/2"
   Option "Device" "/dev/mouse"
   Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
   Identifier "monitor1"
   VendorName "Plug'n Play"
   ModelName "DELL P780"
   HorizSync 30-85
   VertRefresh 48-120
   
   # TV fullscreen mode or DVD fullscreen output.
   # 768x576 @ 79 Hz, 50 kHz hsync
   ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
   
   # 768x576 @ 100 Hz, 61.6 kHz hsync
   ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
   Identifier "device1"
   VendorName "ATI"
   BoardName "ATI Radeon (fglrx)"
   Driver "radeon"
   Option "DPMS"
EndSection

Section "Screen"
   Identifier "screen1"
   Device "device1"
   Monitor "monitor1"
   DefaultColorDepth 16
   
   Subsection "Display"
       Depth 8
       Virtual 1024 768
   EndSubsection
   
   Subsection "Display"
       Depth 15
       Virtual 1024 768
   EndSubsection
   
   Subsection "Display"
       Depth 16
       Virtual 1024 768
   EndSubsection
   
   Subsection "Display"
       Depth 24
       Virtual 1024 768
   EndSubsection
EndSection

Section "ServerLayout"
   Identifier "layout1"
   InputDevice "Keyboard1" "CoreKeyboard"
   InputDevice "Mouse1" "CorePointer"
   Screen "screen1"
EndSection

Section "DRI"
   Mode 0666
EndSection

Share this post


Link to post
Share on other sites

Can you add this just above the load "dri" line:

 

load "glx"

 

reboot, and see what glxinfo gives?

Share this post


Link to post
Share on other sites

when i type

# glxinfo | grep direct

I get nothing

but glxinfo i get

$ glxinfo
name of display: :0.0
Loading required GL library /usr/X11R6/lib/libGL.so.1.2
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
   GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
   GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
   GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
   GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
   GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
   GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
   GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
   GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
   GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
GLX extensions:
   GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
   GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
   GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
   GLX_SGIX_visual_select_group
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
   GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
   GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
   GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
   GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
   GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
   GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
   GL_ARB_transpose_matrix, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
   GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_logic_op,
   GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
   GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
   GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
   GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_secondary_color,
   GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
   GL_EXT_stencil_two_side, GL_EXT_stencil_wrap, GL_EXT_subtexture,
   GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
   GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
   GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias, GL_EXT_texture_object,
   GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
   GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
   GL_ATIX_texture_env_combine3, GL_IBM_texture_mirrored_repeat,
   GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
   GL_NV_blend_square, GL_NV_point_sprite, GL_NV_texgen_reflection,
   GL_NV_texture_rectangle, GL_SGIS_generate_mipmap,
   GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
   GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
   GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
   GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

  visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None
0x24 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  0 0 None
0x25 16 tc  0 24  0 r  y  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
0x26 16 tc  0 24  0 r  .  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
0x27 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None
0x28 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  0 0 None
0x29 16 dc  0 24  0 r  y  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
0x2a 16 dc  0 24  0 r  .  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None

Share this post


Link to post
Share on other sites

OK, but did you add the:

 

load "glx"

 

above the line load "dri", that I mentioned in previous post?

 

If so, then put a "#" at the beginning of the load "dri" line, as well as the three Section "DRI" lines you added at the bottom of xorg.conf and reboot and see what glxinfo reports then.

Share this post


Link to post
Share on other sites

No, shouldn't need to. See above post on further editing on xorg.conf. It suggests disabling dri, but we leave the load "glx" line, to see if it works.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...