Jump to content

Major problems with Audacity


Recommended Posts

This is actually a problem which got solved, but only because my brother is a minor deity in the Linux Pantheon and I had a bootable Knoppix CD - both of which were able to solve the problem.


I've been using Konqueror to copy and paste my CDs onto my Hard Drive. While in Konqueor, I type audiocd:/ in the location and up comes the CD. I then copy the entire album as an .ogg file into my music folder on the hard drive.


But occasionally things slowed up. My CD would stall sometimes and be unable to complete the process. One solution I had to this was to use the DVD-R/RW drive I have and switch the KDE--->Sound--->Audio CDs address from /dev/cdrom0 to /dev/cdrom1.


The other solution I had was to copy the album as a .wav file, and then, once it has been saved onto the HDD, to then open it with Audacity. Once Audacity opened it (it would take 4-5 minutes to open) I would then export it as an .ogg file. Once that was completed, I would then delete the .wav file.


The problem was that sometimes the PC would freeze up. Not even going into the command prompt (CTRL-ALT-F1) would help since once I typed in Root as the username it would not even ask me for a password. Instead, it came up with:


0000:00:0a.0 : tulip_stop_rxtx() failed


I know now that this is something to do with the internet connection through my router, which I was connected to while ripping my CDs. I'm not sure why this occurred, but whenever the Audacity process would stuff up and freeze everything, that tulip message was what I would get whenever I did a CTRL-ALT-F1 to go to the command prompt (my motive for going to the command prompt was to do a "shutdown -r now" command).


With everything frozen - even the command prompt - I had no other choice but to hit the reset button and do a dirty reboot. During Lilo, I would be prompted to check the disk since "the system appears to have shut down uncleanly".


These were irritating problems, but nothing as to what happened last night. If you understand already what was going on, then you can probably predict what was happening.


Whilst opening and modifying an .ogg file with audacity, I suddenly got an error message which said that the temporary file space was running out. Everything froze again and I was forced to do another dirty reboot. Again I tried to modify the .ogg file (an album) with Audacity, only for it to tell me that, again, I had run out of temporary file space. Again everything froze up and I did a dirty reboot.


Except this time, KDE did not boot. In fact, during the Lilo process I got this warning:


"Partmon: Checking if partitions have enough free diskspace"


Then it said "Warning. </> has <0> free which is less than <20000>". Rather than booting up KDE, I went straight to the command prompt. Even after shutting down cleanly and starting again, the problem remained.


Fortunately my brother had given me a Knoppix 3.2 bootable CD. I put the CD in while the system was restarting, and was able to run Linux from there. Opening up my copy of O'Reilly's "Linux in a Nutshell" (which I rarely open and rarely understand), I decided to play around with the fdisk and df commands.


While running directly from the CD, and using the df command, I was able to determine that the boot partition was rather full. I rebooted again without the CD and went into the command prompt (after going through the "Warning </> has <0> free etc"). After typing df -k and the the /dev location I discovered that my boot partition was 100% full.


So this morning I ring my brother who, as I have said, is rather expert at Linux. I was able to connect to the internet while running Knoppix, and I was able to type commands my brother gave me so that our two computers would connect. He discovered the problem.


Essentially the problem was that the temporary files from Audacity that had been left over whenever I did a dirty reboot were piling up in the Boot partition. Eventually the partition filled up and I could no longer boot the computer properly into KDE. My brother eliminated these temporary files for me. As a result, I can now boot up properly.


None of this answers the reason why I would occasionally get those "tulip_stop" warnings, unless of course there were temporary files being placed into the boot partition as a normal part of the internet connection process - in which case "tulip_stop" was an indication that the boot partition was being badly hit by another program.


In order to prevent this from occurring again, my brother advised me to go into Konqueror and type in "fish://root@localhost/" which would then, after giving my root password, allow me access to the TMP folder and let me manually remove any offending files. He gave me this advice after I told him that I wasn't exactly comfortable with using the command prompt to do such things.


I don't know if this is a design flaw with Audacity or with Mandriva 2006 or with both. If I had a larger boot partition the problem would have taken longer to surface.


Any ideas? Comments? Is there anything I have forgotten to tell anyone?

Edited by neilinoz
Link to comment
Share on other sites

Your problem seems to ba bad harddisk I/O.

I had a similar problem (less intensive) with an older BIOS revision of an MSI mainboard I had- problem well solved after the last BIOS revision offered by MSI.

In any case, it has absolutely nothing to do with Audacity.

As for the full /tmp problem: Can you post your /etc/fstab here?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...