Jump to content

Good install but locks before getting to login


Recommended Posts

What you need is the kernel-source for 2006, so that the driver can be compiled into the kernel.


First, type:


uname -a


at a konsole prompt, and you will get a kernel version number.  2006 if I remember correct is  So if you then type this at the prompt:


urpmi kernel-source


you can then choose the corresponding kernel source.  I believe the best one for you will be option 2 that pops up.


Then install the Nvidia driver again and you should be OK this time round.

Even neater is


urpmi kernel-source-'uname -r'




hint: when we tell you commands like uname you can type man uname at the prompt and learn a bit about them :D


Hence ianw1974 is entirely correct and John was correct (except it is not necassary its optional) but linux often offers many ways ....


The uname command gives all info with -a but -r gives the kernel name ... (which is the version)

because its in single quotes bash will evaluate it so it reads as if you typed the whole line (try just uname -r and uname -a)

urpmi will fetch the source .. you probably only need the kernel headers for the new kernel (because 10 and 2006 use different krnel versions by default) and the nvidia driver needs the headers at least to compile against ...


The reason you don't need the PNP working is linux (or xorg) will first take what you tell it and trust you .. then fall back on detection :D This is VERY useful for me because my second screen is a projector and its not usually switched on so if it tried to autodetect it wouldn't find anything and if it was in Windows I guess it would autoinstall everytime I switched it on in linux I just tell it its there and switch it off/on as I need.

Link to comment
Share on other sites

Mission Accomplished!


I did use the ianw1974's suggestion to get it to work. I may have mis-typed Gowator's because it didn't work. Looking back at the suggestion, I think I may have put a space in the wrong place. I am finally replying in 2006 and it feels great.


Thanks to everyone that had a part in "teaching an old dog a new trick."

Link to comment
Share on other sites


The only space was after urpmi .... because the rest is all one 'word' I couldn't try that because I don't have mandrake installed but the same worked in Debian :D but the point is there is always mutliple ways to skin a kat in linux :D


The best thing is if you understand why ... and you can just use the man command to check out all rthe little commands we give you :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...