Jump to content

DWL G650 Problems

Guest merlin73

Recommended Posts

Guest merlin73


This is my first post. I've recently installed Mandrake 10.0 to dual boot with XP. It's been a while since I've used linux, so I consider myself a newbie but some of it is coming back. Anyway I've got a DWL-G650 wireless card that I can't get working on my laptop. I've read through the other posts and several websites for help. I've tried Madwifi and ndiswrapper but I can't get either to compile. Can someone tell me what I'm doing wrong?



Link to comment
Share on other sites

Guest merlin73

Thanks Qchem for the greets.


Here's a screen dump of what it says when I type make. This is for ndiswrapper but it does the same for madwifi, so I'm guessing I'm missing something.



make -C driver

make[1]: Entering directory `/home/merlin/ndiswrapper-1.5/driver'

make -C /lib/modules/2.6.3-7mdk/build SUBDIRS=/home/merlin/ndiswrapper-1.5/driver \


make[2]: Entering directory `/usr/src/linux-2.6.3-7mdk'

*** Warning: Overriding SUBDIRS on the command line can cause

*** inconsistencies

make[3]: `arch/i386/kernel/asm-offsets.s' is up to date.

CHK include/asm-i386/asm_offsets.h

LD /home/merlin/ndiswrapper-1.5/driver/built-in.o

CC [M] /home/merlin/ndiswrapper-1.5/driver/hal.o

CC [M] /home/merlin/ndiswrapper-1.5/driver/iw_ndis.o

CC [M] /home/merlin/ndiswrapper-1.5/driver/loader.o

CC [M] /home/merlin/ndiswrapper-1.5/driver/misc_funcs.o

CC [M] /home/merlin/ndiswrapper-1.5/driver/ndis.o

CC [M] /home/merlin/ndiswrapper-1.5/driver/ntoskernel.o

CC [M] /home/merlin/ndiswrapper-1.5/driver/ntoskernel_io.o

CC [M] /home/merlin/ndiswrapper-1.5/driver/pe_linker.o

CC [M] /home/merlin/ndiswrapper-1.5/driver/proc.o

CC [M] /home/merlin/ndiswrapper-1.5/driver/wrapper.o

/home/merlin/ndiswrapper-1.5/driver/wrapper.c: In function `wrapper_init':

/home/merlin/ndiswrapper-1.5/driver/wrapper.c:1808: warning: implicit declaration of function `create_singlethread_workqueue'

/home/merlin/ndiswrapper-1.5/driver/wrapper.c:1808: warning: assignment makes pointer from integer without a cast

CC [M] /home/merlin/ndiswrapper-1.5/driver/usb.o

/home/merlin/ndiswrapper-1.5/driver/usb.c: In function `usb_exit_device':

/home/merlin/ndiswrapper-1.5/driver/usb.c:151: warning: implicit declaration of function `usb_kill_urb'

/home/merlin/ndiswrapper-1.5/driver/usb.c: In function `wrap_select_configuration':

/home/merlin/ndiswrapper-1.5/driver/usb.c:889: error: invalid type argument of `->'

/home/merlin/ndiswrapper-1.5/driver/usb.c:891: error: invalid type argument of `->'

make[3]: *** [/home/merlin/ndiswrapper-1.5/driver/usb.o] Error 1

make[2]: *** [/home/merlin/ndiswrapper-1.5/driver] Error 2

make[2]: Leaving directory `/usr/src/linux-2.6.3-7mdk'

make[1]: *** [default] Error 2

make[1]: Leaving directory `/home/merlin/ndiswrapper-1.5/driver'

make: *** [all] Error 2

Link to comment
Share on other sites

Guest merlin73
the ndiswrapper rpm in the sources works fine for this card on my 2006 system  -- try the rpm before you build a version from source


I was just reading on ndiswrapper.wiki site that I need to update mandrake to 10.1 I have no idea how to do that so I think I will have to try madwifi again.

Link to comment
Share on other sites

There's a couple of methods for upgrading. One is using CD/DVD media, the other is using urpmi sources. This will take time since you're downloading it over the internet as the upgrade takes place.


The preferred method is from the CD/DVD media however. Just boot from it, and go for it.


Over urpmi it's more difficult/time consuming, and it doesn't always work how you want it to. I found this when trying to upgrade from 10.1 Official to LE2005. Could never get my Intel Video card working properly. But a clean install of LE2005 and it worked a treat.


If I was you, I'd build it clean, but make sure you backup your important data first. This is what most tend to recommend.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...