Jump to content
Sign in to follow this  
VILLA21

No languages other than US English

Recommended Posts

Just installed Mandrva 2006 RC2 plus all the updates from Cooker. The only issue i have so far is the Greek language installation. I configure my keyboard to use US English and Greek but i cannot switch to Greek, any ideas pls?

Share this post


Link to post
Share on other sites

Here's the output of locale:

LANG=en_US

LC_CTYPE=en_US

LC_NUMERIC=el_GR

LC_TIME=en_US

LC_COLLATE=en_US

LC_MONETARY=el_GR

LC_MESSAGES=en_US

LC_PAPER=el_GR

LC_NAME=el_GR

LC_ADDRESS=el_GR

LC_TELEPHONE=el_GR

LC_MEASUREMENT=el_GR

LC_IDENTIFICATION=el_GR

LC_ALL=

I tried to configure it only in MCC. What i have to add in xorg.conf or i18n?

Share this post


Link to post
Share on other sites

For troublefree Greek support, you must use UTF-8.

 

Add to all the lines in the i18n file .UTF-8 at the end, and set the LANG as:

en_US.UTF-8:en_US:en

 

 

Your input device section in xog.conf should be something like that:

 

Section "InputDevice"

Identifier "Keyboard0"

Driver "keyboard"

Option "XkbModel" "pc105"

Option "XkbLayout" "us,el"

Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"

EndSection

 

If you set your system like that then you don't need at all the KDE keyboard switcher- all is done at the xorg level, which is good (e.g. Openoffice working properly without any KDE bindings).

 

The above changes require restart to apply properly.

 

You can also change the locale settings via mcc, and tick in the "use unicode by default" option.

Edited by scarecrow

Share this post


Link to post
Share on other sites

I did all the changes as u suggested, still no joy. There is no "use unicode by default" option in MCC. In KDE CC-->Country-Region & Country i got only an option to add US English and British English. :o

Share this post


Link to post
Share on other sites

locale -a output:

C
CP1251
el
el_GR
el_GR.ISO-8859-7
el_GR.UTF-8
en
en_AU
en_AU.ISO-8859-1
en_AU.UTF-8
en_BE
en_BE.ISO-8859-1
en_BE.ISO-8859-15
en_BE.UTF-8
en_BW
en_BW.ISO-8859-1
en_BW.UTF-8
en_CA
en_CA.ISO-8859-1
en_CA.UTF-8
en_DK
en_DK.ISO-8859-1
en_DK.UTF-8
en_GB
en_GB.ISO-8859-1
en_GB.UTF-8
en_HK
en_HK.ISO-8859-1
en_HK.UTF-8
en_IE
en_IE.ISO-8859-1
en_IE.ISO-8859-15
en_IE.UTF-8
en_IN
en_IN.UTF-8
en_NZ
en_NZ.ISO-8859-1
en_NZ.UTF-8
en_PH
en_PH.ISO-8859-1
en_PH.UTF-8
en_SG
en_SG.ISO-8859-1
en_SG.UTF-8
en_US
en_US.ISO-8859-1
en_US.UTF-8
en_ZA
en_ZA.ISO-8859-1
en_ZA.UTF-8
en_ZW
en_ZW.ISO-8859-1
en_ZW.UTF-8
greek
ISO-8859-1
ISO-8859-10
ISO-8859-13
ISO-8859-14
ISO-8859-15
ISO-8859-2
ISO-8859-3
ISO-8859-4
ISO-8859-5
ISO-8859-7
ISO-8859-9
KOI8-R
KOI8-U
POSIX
UTF-8

How to rebuild locale?

Edited by VILLA21

Share this post


Link to post
Share on other sites
Somewhere in KDE control centre there is "keyboard layout".

 

Might that be what you are looking for?

That"s the fisrt thing i'd tried, i enabled keyboard layouts, add greece(gr) in the active layouts field and i when i click the US flag to switch to Greek i get an error (err). :angry:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...