Jump to content
lawsonrc

Frame buffer problem [solved]

Recommended Posts

I just reinstalled Mdv2005 and finally got nvidia and X to work. This time the installation recognized my monitor (Viewsonic A90f+) and installed the Nvidia generic XF driver (my card is XF 5200).

 

Here is the new problem:

 

When I try to restart or shutdown, the last screen that appears is an ugly moire pattern (not sure if this is the right term or not). It hangs on the moire pattern screen and I have to do the "dirty" shutdown by pressing the power button for 6 or 7 seconds to power off.

 

I have set the screen size to 1024 x 768 and the refresh rate is 85 hz.

 

All help with this i greatly appreciated.

 

Richard

Edited by lawsonrc

Share this post


Link to post
Share on other sites

UPDATE: I may be using the wrong word when I say "moire pattern". This happens not only at shutdown, but also when I try to go from GUI into text mode (CTRL +ALT + F2-F6).

 

Some one told me that this all has to do the Frame Buffer (which I don't quite understand). When I boot into linux-nonfb, the problem doesn't exist.

 

HOWEVER, I much prefer the GUI way of booting in (although I don't like the boot theme with the starry-eyed penguin...great for a 5 year old!).

 

I've always liked how it looks so much nicer to see the details with the blue background and the nice font size, than with the ugly black background, especially when someone seeing Mandriva, or Linux for the first time is around.

 

So....How can I get back to using the Lilo/Graphical way to boot up and get rid of the frame buffer problem?

 

Thanks,

Richard

Edited by lawsonrc

Share this post


Link to post
Share on other sites

It does not work on my 19" Teac TFT either, no matter which resolution I pass to LILO/grub, and not only with Mandy, but any Linux I have tried so far. That is when both the analog and the DRI connectors are on, with only the analog connector it's OK.

The solution is simple though: Disable framebuffer.

Share this post


Link to post
Share on other sites

Thanks scarecrow for the advice. This is one option I considered, but am resistant to do for the following reasons:

 

Previous Mandrake versions worked with framebuffer enabled and I've always been able to do the graphical login.

 

All other distros that I've used don't have the framebuffer problem: Libranet, Xandros, SuSE, Fedora Core, and others.

 

As stated above, I prefer that people I know that may be interested in Linux will see the graphical login with details rather than the ugly text login, which turns off most people accustomed to Windows and Mac.

 

I'm trying to show that Mandriva is REALLY ready for primetime as strictly point and thus ready for the masses.

 

Thus I'd like a solution which has framebuffer enabled and working right instead of disabled.

 

Thanks again,

Richard

Edited by lawsonrc

Share this post


Link to post
Share on other sites

Possible solution (fixed my framebuffer)

 

Section "Device"

 

Option "ConnectedMonitor" "CRT"

EndSection

Share this post


Link to post
Share on other sites

I stopped using fb over 1.5 years ago. One nvidia card, two monitors and boxes, 20 distros, and 10 nvidia drivers it never worked going back to console from gui. In one two words......

my nvidia

 

There's 50+ post on the board about it and I've never seen a solution. There must be one for those that it has worked for before but what? It would be nice to know.

Share this post


Link to post
Share on other sites
There must be one for those that it has worked for before but what? It would be nice to know.

 

I am not new to linux, and I have read 5000+ posts about the issue at every possible Linux forum. Framebuffer does NOT work with my current TFT screen with DRI on. I had absolutely no issues with my previous 19" Hyundai CRT, or in my Tosh and Acer laptops... but on this freakin' screen it simply does NOT work with DRI on, period an fullstop.

Disabling the freako will just make your boot sequence and init 3 sessions a bit uglier, but you won't have to tatter your brains about cosmetics...

Share this post


Link to post
Share on other sites

Some information on the ConnectedMonitor thing: it should be set to CRT if you have any type of screen plugged into the conventional VGA connector (even if it's an LCD display). It should be set to the other value (I think it's DVI, right?) if you have any kind of screen plugged into the newfangled DVI connector. The driver is for the card, so all it knows about are the connectors, not the actual monitors. Logical if you sit and think about it for a minute, but not obvious from the terms the driver uses.

Share this post


Link to post
Share on other sites

Thanks to everyone who has responded so far.

 

bvc--it's great to see your participation once again occasionally in the forums. Welcome back!

 

k6h Which file did you add the following?

 

Option "ConnectedMonitor" "CRT"

 

I looked at xorg.conf and it doesn't appear to be the correct file.

 

If there are further suggestions, I am open to them.

 

Richard

Share this post


Link to post
Share on other sites

It worked! All solved! Hallelujah!

 

:banana::beer::headbang::cheeky::lol2::thanks:

 

Many many thanks to k6h and to my fellow Houstonian and Texan: bvc!!!

 

I added Option "ConnectedMonitor" "CRT" to the xorg.conf file and it solved the problem!

 

This forum is the greatest!!

 

Richard

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...