Jump to content

Thunderstorms - now no cable 'Net (solved-sorta)


Recommended Posts

This is pretty strange...the storms may not actually have anything to do with my problem, but it seems like too much of a coincidence not to be related somehow.


Last night big thunderstorms rolled through all night. However, our lights never went out and when I got up this morning my computer was still up, and I was still logged in with everything just like it had been. In short, everything seemed perfectly normal. The only problem was I had no 'Net connection. So I started going through the usual suspects...


But just for general info, first let me say I'm using 10.1 and have 2 nics, eth0 with dhcp for the cable connection, eth1 with a static IP so the Linux box can handle routing and firewalling for other computers. No hardware changes for a long time. No changes in network configuration for much longer. Hadn't even rebooted in a couple of months. Anyway...


1. I use Road Runner, and the cable modem had the proper lights lit, etc. I had a connection light on the nic card. I reboot the modem, lights come back up OK.

2. Tried to restart the connection in MCC - failed.

3. Checked network configuration - OK.

4. Uplugged the cable from the cable modem to eth0 and tried it in my Winshaft notebook. Worked perfectly, so now I'm sure the cable connection itself is OK.

5. Tried to delete the present eth0 connection and start with a new one - connection still failed.

6. Stopped all firewalling - shorewall, iptables - no difference.

7. Getting a little more desperate, I tried the old Windoze fix - reboot - and I REALLY hate to reboot. But I figured if I had a hardware problem I'd have to shutdown anyway. Still no good. During boot I get the dreaded red 'FAILED' on eth0, but eth1 comes up a green 'OK'. Now, ever since I loaded 10.1 eth0 would come up 'OK', but I'd still have no 'Net untill I started the connection manually or through MCC. That was no big deal since it always worked and I normally reboot only every few months. But I never got 'FAILED' before.

8. By now I'm thinking my eth0 nic has been zapped somehow. But I've got plenty of nics, so I change not one, but both nics, using Realtek 8139s as before (same 8139too driver). Still no good.

9. Hmmm...maybe the PCI slot got zapped somehow. Not likely, but...so I swapped around cards and slots and put the sound card in the slot previously used by eth0 as a test. No change, and the sound card still works.

10. I give up for now and post a cry for help here.


I don't know...everything seems fine, but no go. Any help would be much appreciated.

Edited by Crashdamage
Link to comment
Share on other sites

That happens to me about once a month or less with roadrunner and it is usually during storms, which yes, is weird. I have to shut everything off including the ups, modem, router EVERYTHING for several minutes then turn everything on and boot. That fixes it here. I d/k what or why.

Link to comment
Share on other sites

A quick update for anyone wondering about a fix...


I did fix it, but I can't exactly say how. I was reading this:




...and that seemed to be exacly what was happening - same exact error messages, etc discussed in that thread. Now, I never needed to make the edits regarding adding

"acpi=off noapic" to etc/lilo.conf before and couldn' t really think of any reason I should need to now, but it worked for davcefai, so what the...I tried it anyway.

No joy. I only mention it here in case it works for someone else like it did for davcefai.


By now much more than a little frustrated, I plugged the cable modem back into my Winshaft laptop so I could log into work and get something done. Ugghh. But this time it wouldn't go. When I did that before it took right off. I had to fiddle around some with rebooting the modem again and hitting the "Repair Connection" button in XPee a couple of times (flushes all settings and gets a new lease) before Gates and the notebook let me become a citizen of the 'Net again.


But that gave me hope for getting the Linux box going again...maybe it's NOT my Linux box after all. Obviously, I should try the same thing in Linux I did in Windoze to get up and running. I plugged the cable back in, rebooted the modem and opened MCC to use the quick'n easy method to fool with connections. (I know, but I'm still not a real threat at the CLI with networking stuff, so sometimes I still get weak and lean on a GUI). Anyway, bottom line is after deleting all connections and redoing them a couple of times - just generally messing around - finally it took off! I re-enabled Shorewall, NAT, IPmasq, Portsentry, etc. and all is back to normal.


So I don't really have a *specific* fix - type 'xyz' in a terminal and all will be well.. I was just jackin' around and got it working in spite of myself. But at least now I know for sure it never was a hardware thing, and if it ever happens again I'll have a little better idea how to attack the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...