Jump to content
Helmut

Will not shut off after shutdown [solved]

Recommended Posts

Hi Folks,

I'm now running LE2005 on two quite similar workstations with different mainbords. Both were upgraded from mdk 10.1 recently. One PC had this problem in 10.1 and has kept it after upgrading to LE2005:

 

At the very end of the normal and as it seems correct and completed shutdown sequence, the computer stays on and does not go off.

To be precise, after all processes are killed and all drives are turned off, nothing else happens. The power button on the PC's case needs to be pressed manually.

 

Grateful for any ideas,

Helmut.

 

[moved from Software by spinynorman]

Edited by Helmut

Share this post


Link to post
Share on other sites
Guest flytopia
At the very end of the normal and as it seems correct and completed shutdown sequence, the computer stays on and does not go off.

 

I solved this problem by enabling ACPI in Lilo.

 

Can't remember the exact process (I'm at work) but you need to go into MCC, find the Lilo configuration option (under Boot?) and tick "Use ACPI".

 

You'll need to reboot for the Lilo options to take effect, but then the next time you shutdown the PC should switch off

 

flytopia

Share this post


Link to post
Share on other sites
Guest flytopia

Back home now, so here's more details.

 

1. Start MCC

2. Click on the Boot Loader icon.

3. Check the "Enable ACPI" box.

4. Click Next, then Finish.

5. Reboot.

6. Try shutting down. The PC shoud switch off.

 

Hopefully :unsure:

 

flytopia

Share this post


Link to post
Share on other sites

Thanks flytopia for the reply,

 

ACPI is now enabled via the MCC which wasn't before,

but it still don't shut off.

regards,

Helmut

Edited by Helmut

Share this post


Link to post
Share on other sites

install all ACPI packages (theres 2 of them) in rpmdrake, i solved this problem by doing this, and upgrading to the newest kernel (also in mcc rpmdrake)

 

hope this helps

Share this post


Link to post
Share on other sites

It's not that big of a deal. In lilo.conf acpi=off should do the trick. If not then change acpi=off or acpi=ht to noacpi. Then try acpi=ht. One of them will work. I've had this minor annoyance several times and that's what fixed it. You don't need to install any freakin' software or get the newest kernel. Try it. Your 'puter won't blow up.

 

Glennzo

Share this post


Link to post
Share on other sites

Thanks ERD and Glennzo,

but it still don't work.

All ACPI packages were installed already.

I tried acpi=ht, noacpi and acpi=off, each time with rstart inbetween.

Unfortunately its still not shutting the power switch off. It did so a long time ago, so I suppose its not the hardware... Grateful for any ideas.

 

regards, Helmut

Share this post


Link to post
Share on other sites

In previous versions I have resolved this problem by recompiling the kernel and including all APM modules and leaving out ACPI in the build.

 

Maybe this will work...

Share this post


Link to post
Share on other sites

You need to run 'lilo' as root whenever you change lilo.conf manually, remember. If you don't, the changes aren't incorporated.

Share this post


Link to post
Share on other sites

Search this forum for "poweroff". This problem arises over and over again since, I think, MDK 8.0. I have lost hope that Mandrake will ever get it right...

Share this post


Link to post
Share on other sites

It's a hardware dependent thing, caused by badly written BIOSes. On non-broken hardware, it works. It's more obvious on MDV than other distros because we enable APIC by default, and about 90% of the time this problem shows up when APIC is enabled. Many distros leave it disabled by default.

Share this post


Link to post
Share on other sites

Thanks folks,

You know, there was a time when it actually did work on this computer!

In the mean time everthing you said has been tried (exept for a total reinstall) but the problem persists. Thanks a lot anyhow. I think I'll just have to stick with it...

regards,

Helmut

Share this post


Link to post
Share on other sites

Hi Scarecrow!

I tried it with power management in BIOS on, and also with off. Originally it worked fine with mdk 10.1, then it didn't any more. After upgrade to SE2005 this fault remained. Just wondering if it needs all ACPI's including in BIOS turned on first, then reinstall, then maybe ACPI back off?

regards,

Helmut.

Edited by Helmut

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...