Jump to content
Sign in to follow this  
reflection666

no-ip + sshd

Recommended Posts

can no-ip domains work with sshd? I think they keep being forworded to port 80 or smthng but I want to use port 666 (for security reasons)

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

It ought to work. AFAIK, no-ip act as a simple DNS server, any traffic sent to the domains you register is sent straight to the IP address you specify, no filtering is done unless you ask for it (they have a feature which futzes SMTP ports so you can run a mailserver even if your ISP blocks port 25).

Share this post


Link to post
Share on other sites

You should be OK - you'll just have to make sure people point their ssh clients to your_server.no-ip.com:666

 

Post your results!

Share this post


Link to post
Share on other sites

the problem is tha *I haven't* been able to login remotly (sshed a machine at the university and sshed to my domain -p 666 through the remote terminal).

 

I've forwarded port 666 in my router to my LAN IP

I've opened port 666 on my shorewall rules

sshd listen to 666

 

So think no-ip cannot forwart to tha kind of ports (only standard 80-80-21) -- though I think there are some ed2k no-ip servers...

 

I work on it some more....

Share this post


Link to post
Share on other sites

the easy way to take the whole no-ip thing out of the loop is just to try connecting straight to your public IP address. If that doesn't work, the problem lies somewhere else. /etc/hosts.allow and /etc/hosts.deny ?

Share this post


Link to post
Share on other sites

What security level is your SSH server at? If it's on "Higher" or "Paranoid" you need to add the following to your /etc/hosts.allow file:

sshd:ALL

Otherwise, no-ip isn't your problem, they forward all ports to the same destination. Make sure that your router is forwarding 666 to your server, your server has 666 open, and /etc/ssh/sshd_config is listening on 666 (most of which you mentioned you already did - I'm just being clear for those who just walked into the room). Then, when you try to connect with a client app, like Tectia, FileZilla, Putty, or BitVise, make sure it's set to the SFTP using SSH2 protocol, and replace 22 for the port setting with ... you guessed it folks ... 666.

 

That really should be all you have to do. Keep at it - it will work!

Share this post


Link to post
Share on other sites
I do ssh into my computer on a non-stnndard ssh port (23) using no-ip.com. Works fine.

and I do it with dyn-dns.org with no messing about!

 

 

like adamw says I think your prob is something else not working... can you http on port 80? can you ssh locally? have you got a hosts.deny set and hosts.allow set to your domain?

Share this post


Link to post
Share on other sites

yeah, I can verify I just ssh'ed to my home machine - www.happyassassin.net - and it worked fine. I use no-ip for my DNS service. so your problem is elsewhere.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...