Jump to content
sitor

DV export to camera not working in 2005 LE?

Recommended Posts

Hello,

 

I think this is a bug, so I already reported this to bugzilla, however maybe someone might help me with a quick fix or workaround. Please find below what I reported to bugzilla:

 

Hello,

 

I'm quite a heavy kino user (importing from camera, editing and exporting back to camera). I installed MDV 2005LE and started using kino. Importing and editing goes real good, however, exporting back to camera does not work at all. I have been trying to figure out why, but I'm not at all an expert in this kind of matters.

This is how far I got:

 

gscanbus gave me this result (but I don't have a clue how to interpret it):

SelfID Info

-----------

Physical ID: 0

Link active: Yes

Gap Count: 63

PHY Speed: S100

PHY Delay: <=144ns

IRM Capable: Yes

Power Class: None

Port 0: Connected to parent node

Init. reset: No

CSR ROM Info

------------

GUID: 0x00804580211492FE

Node Capabilities: 0x000083C0

Vendor ID: 0x00008045

Unit Spec ID: 0x0000A02D

Unit SW Version: 0x00010001

Model ID: 0x00000000

Nr. Textual Leafes: 1

Vendor: MATSUSHITA ELECTRIC IND. CO

Textual Leafes:

Panasonic

AV/C Subunits

-------------

Tape Recorder: 1

Video Camera: 1

Vendor Unique: 1

 

I checked the kino preferences for the export device. According to what I found on the kino site, it is set correctly to /dev/ieee1394/dv/host0/PAL/out. However, this device does not seem to exist on my system. I tried to create it (as root) with mknod -m 666 /dev/dv1394 c 171 34 as indicated on http://www.linux1394.org/dv1394.php, but that did not seem to work. I did not get any error, but in /dev there is still no /ieee1394 subfolder, and kino still can't do the export.

 

Don't know what I can do to further investigate.

 

Thanks in advance for any help.

 

Ciao,

 

Sitor

Share this post


Link to post
Share on other sites

OK, I did some more googling and testing, and this is what I got:

mknod -m 666 /dev/dv1394 c 171 34 did not create /dev/ieee1394/dv/host0/PAL/out. Apparently http://www.linux1394.org/dv1394.php is outdated. I found out that currently that command creates /dev/dv1394 plain and simple. Setting that in the preferences of kino did the trick. :D :D :D

However after rebooting, /dev/dv1394 was gone again. :( So I added mknod -m 666 /dev/dv1394 c 171 34 to the /etc/rc.local script. Now upon boot the device /dev/dv1394 is created automatically.:)

 

Of course it would be better if MDL 2005 LE would do this without tinkering from the user required. So I hope they will fix this anyhow.

 

Oh, yeah, in MDL 10.0 I always needed to run kino as root, or it would not let me control the camera. That is fixed now. That is a good thing. I must say that I am quite satisfied of MDL 2005 LE. Except for this one bug no real annoying problems, and that while having installed immediately when the new version was available only to club members! :D :D

 

Good work done by all the hackers of MDL! :thanks::thanks::thanks:

 

Ciao,

Sitor

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...