Jump to content
Sign in to follow this  
inflexion

Samba with no passwords

Recommended Posts

Know a little about samba so have set it to allow address that start with 10.0. and i can access the laptop by doing

smb://ip address

 

then it gives me a login but there is no password set on the win machine so i cant access the shares.

Share this post


Link to post
Share on other sites

Which Windows? If XP or 2000 have you tried logging in as administrator? More details on your Samba and Windows setup would be helpful.

Share this post


Link to post
Share on other sites

its xp the win machine.

 

Like ive said though the only thing that ive done it set to allow the ip address in the conf file.

 

in windows its just set up as normal ie. Shared folders and all of the default names taken

Share this post


Link to post
Share on other sites

smbpasswd -n username

      -n    This  option  specifies  that the username following should have

              their password set to null (i.e. a blank password) in the  local

              smbpasswd file. This is done by writing the string "NO PASSWORD"

              as the first part of the first password stored in the  smbpasswd

              file.

 

              Note  that  to  allow  users to logon to a Samba server once the

              password has been set to "NO PASSWORD" in the smbpasswd file the

              administrator  must  set the following parameter in the [global]

              section of the smb.conf file :

 

              null passwords = yes

 

              This option is only available when running smbpasswd as root.

Share this post


Link to post
Share on other sites

you dont really need to touch anything in the conf file of your samba if all you want to do is to access your win xp from you linux machine... and like polemicz said, try to log on it ( ur XP) from ur Linux using the admin username... also, if that user you intend to use to login from ur linux is a normal user in ur Xpee, try to create its own shared folder there

Share this post


Link to post
Share on other sites

whoops .. mis read,

I was reading it the other way around ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...