Jump to content

Thac and Zé's KDE 3.4 rpms


Recommended Posts

My update to 3.4-thac went very smoothly, once again thanks thac!


Here is my little problem: The lilo entries have disappeared from the kdm screen. In 3.2.x and 3.3.x the lilo entries used to be under "Restart Computer" when selecting "Shutdown" from the kdm login screen, now they are gone. Also I have seen on a screenshot that under 3.4 the lilo options also exist on the window that appears when a user selects logout -- they are not there, either, in my system.


Do lilo entries appear on your 3.4 kdm/logout dialog?


Thank you in advance.

Link to comment
Share on other sites

  • Replies 266
  • Created
  • Last Reply

Top Posters In This Topic

Guest Vorik

Hi all,


I'd just like to take a moment to share my troubles upgrading to KDE 3.4


First, I tried to use Konstruct to do it, but it was using the wrong directory (~/kde3.4)

I havent got a clue how I can use that folder to start KDE 3.4 automatically and googled a lot, but couldnt find it.


Secondly, I changed the path that Konstruct uses to /usr. This worked, except that my menu was empty, and basically nothing worked. (including the kde configuration apps) --> System wrecked


After a reinstall, I found that thac had rpms! GREAT!

So, I did a urpmi --auto-select and the system doesn't boot anymore (hangs after alsa starts)


Next reinstall.. here we are now.. Which leads to my question: What is the SAFEST way to upgrade to KDE 3.4?




Link to comment
Share on other sites

The safest way is to know what you are doing :). And urpmi is quite easy to get to know. :)


For the alsa problem press ctrl - c. The boot process should continue.


Thac: I had the same problem as described here with one of my email accounts (http://bugs.kde.org/show_bug.cgi?id=97139). I solved it by installing the sasl plugin pachages but I guess kmail is dependent on it so these packages should be installed as dependencies.

Link to comment
Share on other sites

Ok...now my issue.


First, I had another, unrelated kernel problem but I got that fixed. Now I have a KDE problem, I think I know what might fix it, but I want to check first.


Here's the deal: nothing works. My desktop settings weren't saved, so my side panels are gone (see my latest KDE screenshots at http://www.liquidzoo.net to know what I mean). This, I believe, is caused by the fact that the kicker panels are now simply called panels, instead of Child Panels like they were in 3.3 and 3.2. Something changed in the later versions of 3.3.2 because even saving the desktop settings doesn't work. I have 2 fully transparent Eterms that do not start correctly (buttonbar and scrollbar are visible).


I *think* that I can solve these issues by logging out, moving my ~/.kde folder and logging in again. I'll try it when I get home from work (unless someone else has another suggestion) but I do have another question: I was under the impression that 3.4 had the option to start another KDE session (like the XP Switch User option) so I could leave my desktop up and have my fiancee log into hers. I can't find this option anywhere, though. Anyone know?

Link to comment
Share on other sites

Guest Vorik

Gee, I took another gamle and did 'urpmi kdebase'


It worked for the most part, except for the following issues:


-mkdkdm is broken. I get ALL the useraccounts in it, and when I log in using mdkkdm the screen flashes a few times and returns to the MdkKDM menu. As a workaround, I've installed xdm.

-Menu items missing (lots of them, yet not all)

-Doubled up menu items (eh. pretty much all of them)


If I find any more, I'll edit it in.


Any help very much appreciated.

Link to comment
Share on other sites

When my computer starts up, the login box contains not just my user, but all the other system accounts adm, apache, bin and so on - root as well.


Trying to login as me (or root), just bounces me back to the same screen. The 'Reboot' and 'Halt' buttons have no response.


I can drop to shell, login as either myself or root, and do everything as normal.


Any help would be appreciated.

Link to comment
Share on other sites

I've got the same problem, Joe. I've spent the last 3 days attempting to get it working. Right now, I'm 'urpmi --auto-select' with just the sources from easy urpmi. After that I plan on 'urpmi kdebase' in an effort to upgrade from KDE 3.2 to 3.3. Then, I will add Thac's rpms to my source list and again 'urpmi kdebase', hoping to upgrade from 3.3 to 3.4, but who knows if this will work. If it doesn't, I'll just stick with 3.2, as it works just fine. I'll let you know if this works.

Link to comment
Share on other sites

If I'm correct, KDE 3.3 is not yet part of 10.1 main or update mirrors.


Good to hear the symptoms are quite similar across the board.


- I have the login issue (have to Ctrl+Alt+Backspace 4 times to get a shell I can startx from)


- I have the mangled menus (all the K stuff x2, most other stuff disparu). Konqueror also has two sets of nav buttons (same issue, different place?)


Here's a fresh one - no sound. On login it's actually mute, and un-muting it in Kmix doesn't survive reboot.


I remember a quite simple GUI settings fix that sorted this back in 10.0 - except I don't remember which bl**dy slider/button/whatever it was. Anyone?

Link to comment
Share on other sites

Cheers - Gonna reboot and see if anything happened. Here's what I got (did it twice for some reason):


[root@localhost robin]# genkdmconf
Information: reading old xdm config file /etc/X11/xdm/xdm-config
Warning: cannot copy file /etc/X11/xdm/xdm-keys
[root@localhost robin]# genkdmconf
Information: reading old kdmrc /usr/share/config/kdm/kdmrc (from kde >= 2.2.x)
Information: old kdmrc is from kde >= 3.1 (config version 2.3)

Link to comment
Share on other sites

Hmmm.... having to be very careful now, as my mouse wheel now prefers to move me back and forth thru my Firefox history and between windows.


To quote Sean Connery in The Last Crusade, "Our situation has not improved."


The spare IDs are gone and the login has a very minimalist look now, but no other changes to report.


Can't we hack some configfiles here or sumthin'?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...