Jump to content
Sign in to follow this  
Not_Public

"mount: no medium found"

Recommended Posts

after trying to read my cdrom and cdburner from the newly created desktop icons (created via right click through KDE) I now get the error message on both drives "mount: no medium found" even though both drives used to work just fine. no system changes since the issue arose.

tried manually mounting/unmounting/remounting them, tried enabling/disabling supermount, tried letting harddrake set them, double checked the fstab.. (included here in latest revision) (note, cdrom2 is a cdrw)

 

/dev/hdc1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdc7 /home ext3 defaults 1 2
umask=0022,user,iocharset=iso8859-1,unhide,codepa /dev/hdb /mnt/cdrom auto ge=850
,noauto,ro,exec 0 0
umask=0,user,iocharset=iso8859-1,codepage=850,noa /dev/hdd /mnt/cdrom2 auto uto,r
o,exec 0 0
dev=/dev/fd0,fs=ext2:vfat,--,umask=0022,iocharset none /mnt/floppy supermount =is
o8859-1,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hdc6 /usr ext3 defaults 1 2
/dev/hdc5 swap swap defaults 0 0

 

would it be an option to delete their entries from the fstab and let harddrake "rediscover them"? since they worked fine on initial install?

 

the only thing that I know happened was that I created desktop icons to access the drives through via the KDE right click menu to create a link to a device... I think that was the point from which everything went miserable..

 

latest revised cut-n-pasted fstab

/dev/hdc1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdc7 /home ext3 defaults 1 2
/dev/hdf1 /home/shares/drive1 vfat umask=0,defaults 0 0
/dev/hdd /mnt/cdrom2 auto umask=0022,user,codepage=850,iocharset=iso8859-1,noauto,ro,exec 0 0
/dev/hdb /mnt/cdrom auto umask=0022,user,codepage=850,iocharset=iso8859-1,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0022,iocharset=iso8859-1,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hdc6 /usr ext3 defaults 1 2
/dev/hdc5 swap swap defaults 0 0

Edited by Not_Public

Share this post


Link to post
Share on other sites

Is this your current fstab copy and pasted or written by hand? Cuz there's some syntax errors:

umask=0022,user,iocharset=iso8859-1,unhide,codepa /dev/hdb /mnt/cdrom auto ge=850

,noauto,ro,exec 0 0

umask=0,user,iocharset=iso8859-1,codepage=850,noa /dev/hdd /mnt/cdrom2 auto uto,r

o,exec 0 0

dev=/dev/fd0,fs=ext2:vfat,--,umask=0022,iocharset none /mnt/floppy supermount =iso8859-1,sync,codepage=850 0 0

 

Note that the parts highlighted in bold look they are split by the stuff in between.

 

Should be more like this:

/dev/hdb /mnt/cdrom auto umask=0022,user,iocharset=iso8859-1,unhide,codepage=850,noauto,ro,exec 0 0

/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,ro,exec 0 0

none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0022,iocharset=iso8859-1,sync,codepage=850 0 0

 

Here's mine (/dev/hdd is my dvd burner):

/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0

/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0

none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0

 

There should be an option in KDE Control Center to show icons for devices without adding them with a right-click. Look-N-Feel->Behavior->Device Icons tab.

Edited by Steve Scrimpshire

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...