Jump to content

How I got World of Warcraft to work


Recommended Posts

Ok, I am now completely happy with my mandrake box because I have World of Warcraft running and I now have absolutely no reason to boot into Windows (I erased it a month ago WOOOOOOHOOO).


Anyways heres what I did


1. Get Cedega - its the new WineX, its technically free so if you know what CVS is you can get it that way. I just paid 15$ to get it in RPM format (its a monthly subscription thing but I just paid for 3 months worth and cancelled.) You might also be able to find the RPMS through other ways, I dont think that its illegal to not pay for this product. Get it here http://www.transgaming.com/


2. Install World Of Warcraft. My first problem was I couldn't get WOW to install... not with Wine, not with Cedega. So what I did was install it on a windows box, copy the dir to a cd and then put it in a directory on my linux box... that worked fine.


3. Run WOW! Now there are 2 modes you can run WOW in, opengl and directdraw. DirectDraw has a problem where you cant see the cursor, there is a program called wowfix that you can run after you have run wow to fix that... i couldnt get it working, more on that here http://digital-conquest.ath.cx/wiki/index.php/WoW


OpenGL - if you run cedega WoW.exe -opengl then you have it in opengl mode. There is only one problem that I have found in opengl mode, if you have the minimap on inside buildings then the whole program crashes. So for the first bit I just shut off the minimap but that didnt work to well because some classes start indoors with the minimap ON! So I downloaded Cosmos a WOW MOD and an addon called "HideMiniMapFromStart".


Notes: I use XGAME - a cool program that launches games in a new XServer that way you can CTRL-ALT-F7 to go back to your kde session sort of like alt tabbing...



Anyways, it works awesome, hope you get it working too!



Link to comment
Share on other sites

  • 2 weeks later...
So I downloaded Cosmos a WOW MOD and an addon called "HideMiniMapFromStart".

I have Cosmos but need that addon....

Could you give me a link for that ADDON? I've searched everywhere and cannot fint it.



Edited by Ralph
Link to comment
Share on other sites

In case anyone reads this and doesn't know, the commercial version of Cedega that you get when you pay for a subscription is NOT the same as the cvs version. The CVS does not contain several very important dll's, so don't expect the CVS version to work nearly as well.

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 months later...

Run wow with NORMAL WINE, don't need to buy the Cedega.


I now have WOW working in my Mandriva LE2005, almos perfect, only some glitches on sound but disabling ambience sounds help a lot.


My wine configuration is the same of my post of how to get MuOnline running: https://mandrivausers.org/index.php?showtopic=23390


The only difference is that I need to upgrade the wine to a more recent version, in that case the wine-20050628-3mdk version and install the Mozilla ActiveX under wine that you can get at http://www.iol.ie/~locka/mozilla/mozilla.htm and in this moment is on version 1.7.7. To install the Mozilla ActiveX, just run the exe with wine, like you do in Window$ that will work. You don't need to install the Mozilla or Firefox browser to get WoW to work. And I belive if you only want to play wow, you don't need to install M$ Internet Explorer too. The IE is needed only to Mu.


I have copied a installed wow from window$, so I don't know if the install works.


And only edited the ~/World of Warcraft/WTF/Config.wtf file and added the line: SET gxApi "opengl" and give a chmod 777 to the ~/World of Warcraft/WTF/Account and ~/World of Warcraft/Logs directorys, so any user can use this installation and have permission to write to that dirs.


Go now run WoW.exe, and good game.


Ps. I run all my games with XGAME, cose this give you the ability to play the games in another tty and let KDE free to use in alt+ctrl+F7. You can get XGAME here: http://www.xs4all.nl/~masterpe/Perl/Xgame-bundle.tar.gz


:headbang: Linux rox ;)

Edited by ethraza
Link to comment
Share on other sites

  • 1 month later...

I play it in Cedega with no problems. And the mouse cursor issue is best resolved by adding this to your Transgaming config file (/home/user/.transgaming/config or /home/user/.point2play/config):

;; World of Warcraft
"MemoryLayoutOverride" = "0x10000000"

Using that entry you can play with Direct Draw or OpenGL.


I play with all the settings on full with my FX5700 Ultra. I haven't enabled Antrostropic filtering though, so I can't comment on that.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...