Jump to content

Home network: shared printer on XP

Recommended Posts



Samba works fine on our home network, I can access the shared folder we setup on a Windows XP PC. I marked the printer Sharable on the WinXP machine, but I cannot add the printer via config tool (Kprinter or Yast).


However, a folder called 'print$' does show up under my local networks in Konqueror... In it are some files and other folders with drivers, color profiles, ...


Printer is HP deskjet 990C



Any ideas?

Link to comment
Share on other sites

I tried with LPD and cups, but it says:


Description: downstairs

Location: desk

Printer State: processing, accepting jobs.


"Unable to connect to printer; will retry in 30 seconds...: Connection timed out"

Device URI: lpd://


Unable to connect to printer; will retry in 30 seconds...: Connection timed out"

Device URI: lpd://


Edit: maybe this is because my Wireless card and/or Gateway is in between and it cannot connect to the PC ?



When I try to connect with telnet to this PC on port 515, it gives:


darkelve@linux:~> telnet 515


telnet: connect to address No route to host


Also I can ping this address, but traceroute delivers no results?

Link to comment
Share on other sites

Have you seen any of the cups/samba documentation: from cups Documentation>FAQs>Network Questions>How Do I Use SAMBA With CUPS


I use CUPS but its across a linux network, so no experience of samba. Here are a couple of samba related posts which *might* contain something useful








EDIT: you probably know this, but I'm sure it'll be useful for someone's first intorduction to CUPS. If configuring at http://localhost:631 you will at some point be prompted for a username and password.


username, type root

password is your root password

Edited by ChrisM
Link to comment
Share on other sites

It doesn't accept my root password!? what the h*ll?


those are definately the username/pswd you need to use - I just double checked.


Well, it still does not accept it.


User name: root

Password: (I'm sure of this)


I tried these >10 times. The password box keeps rejecting me.

Link to comment
Share on other sites

Just reading through an article on CUPS in the Nov2002 no.48 Linux Magazine (I looked at the web site, but its not available online yet)


Have you the full set of CUPS packages installed? urpmi/MCC should take care of this.


The mag says that you should have a collection of drivers - look for foomatic in the driver names.




If you have a Hewlett-Packard Deskjet or OfficeJet you should additionally install the hpijs package.


I can scan the article - but it will be done at work and may not be until wednesday when I'm most likely to be in the office - if you want it, PM your email address.


Dunno why it wont take your password though - I've tried a few times and it works OK.

Link to comment
Share on other sites

Have you tried setting the printer up as a samba printer (uri smb// etc)? Also did you try to send something to the printer via smbclient?


I have had numerous problems geting printers on win2000 winxp seen. I have a wired network and have had to apply all sorts of tricks - usually having to reset my router, boot up win first, and then linux- to get things set up. I also access my printer as a samba share, not lpd.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...