Jump to content

Upgrade to the Current Gentoo Release

Recommended Posts

First Its important to note that gentoo users can upgrade all packages to current level by the "emerge -u world" command. But their system may not be equal to the current Gentoo release, so here we go.


My system runs ~x86 (unstable), and is pretty clutterd. Some things are broke, some are hacked to work. But all in all a good running system.


<cut from the Gentoo page>

Here in Gentoo land, the concept of upgrading is quite different compared to the rest of the Linux world. You probably already know that we never got in touch with the "classic" way of upgrading software: waiting for a new release, downloading it, burning, putting it in the cdrom drive and then following the upgrade instructions.


You know (being a Gentoo user after all) that this process is extremely frustrating for power users that want to live on the bleeding edge. Even power users from other distributions probably share the same feelings, given the popularity and spread of tools like apt or apt-rpm which make it possible to have quick and frequent updates. However, no distibution is more suited than Gentoo to satisfy these kind of demanding users. From the beginning, Gentoo was designed around the concept of fast, incremental updates.


Ideally, you install once and then do not to bother with releases: just follow the instructions in A Portage Introduction in the Gentoo Handbook that explain how to keep your system up to date. While that's the way things usually go, sometimes changes are made to the core system which require updates to be done manually.


OK Im ready - Lets go:


First make sure you have the gentoolkit installed:

#emerge -u gentoolkit

Then make sure you have a current portage:

#emerge sync


<<Now may be a good time for a backup (/etc)>>


Now time for the fun:


First we need to update your profile to the current one. Come to find out I was useing the 2004.1 profile.


Remove old profile:

# rm /etc/make.profile


Now link to the current profile:

# ln -s ../usr/portage/profiles/default-linux/x86/200X.X /etc/make.profile


Note: Replace the above X.X with the current release.


Once that is done its time to upgrade your Gentoo:


First check for dependency problems:

# emerge --pretend --update --deep --newuse world


From here you may need to adjust your settings in /etc/portage. I found out I had a package masked in /etc/portage/package.mask that I forgot about. Once all that was worked out:


# emerge --update --deep --newuse world


For me I had 99 Packages to upgrade. I normally dont do a --deep option when upgrading. Also running ~x86 makes this even more dangerous.


But here are the next steps Ill take:


<<cut from Gentoo docs>>

Some packages in the Portage tree don't have any real content but are used to install a collection of packages. For instance, the kde package will install a complete KDE environment on your system by pulling in various KDE-related packages as dependencies.


So now its time to remove the orphaned dependencies.


First again check for dependency issues:

# emerge �p depclean


Some people have reported that this step has tried to unmerge sys-apps/slocate and net-misc/dhcpcd so a edit of your world file may be in order! Once all checks out:


I found depclean wanted to unemerge two packages I needed: net-misc/dhcpcd and dev-java/blackdown-jre


# emerge depclean


Now you should have a clean(er) system. But to make sure you didnt break any dependency:


Recheck all dependency issues and reinstall if needed:


# revdep-rebuild


Have fun - Hope it works as good for you as it did for me :P



Some Sites I got my idea / info from:








Gentoo Rocks :headbang:

Edited by iphitus
Link to comment
Share on other sites

Excellent guide ac! Thanks!


Guess what I'll be doing this afternoon :P


Ahhh.... Gentoo :woops:


EDIT: Done! All up to date and shiny - also a noticeable increase in portage speed. :banana:


depclean wanted to take out half my system though, including gnome, gimp, abiword, ut2004, doom3 and a whole lot more! My world file is way long now...

Link to comment
Share on other sites

  • 4 months later...

Yes, and just like you running "gentoo unstable" I run fedora/rawhide(unstable) and all it takes for me is


yum update



slocate *.rpmnew


That's it :D


The only diff is mine is updated in minutes rather than hours. :lol2:



The same can be said for many distro's. :zzz:

Link to comment
Share on other sites

In the next Saga of "How fast to upgrade Distro Wars!"


Much less time between binary distro's is probably more subjective than reality. Binary vs. Source is easy to figure out which one is faster! :D

Link to comment
Share on other sites



Theres a chance I was using gentoo before you started using Linux, but I'm only guessing since I don't know how long you have been in Linux.


Gentoo isn't bad at all, in the distro list, I would put them in 2 or 3 with Ubuntu.


None of them do all I want like Fedora does so BLAH!

Link to comment
Share on other sites



I started back in RH 5.2 I think it was called Hurrican but never really got serious until 9.0.


Ah yes back in the "Texstar" packages for Mandrake.






Im building a 64bit cpu soon - Whats the best Distro (most packages) for a 64bit system?

Link to comment
Share on other sites



I started back in RH 5.2 I think it was called Hurrican but never really got serious until 9.0.


Ah yes back in the "Texstar" packages for Mandrake.






Im building a 64bit cpu soon - Whats the best Distro (most packages) for a 64bit system?

:D I didn't use rh back then I used suse/slackware


As far as 64, your going to shoot me but I would say Fedora of course :P


My reasons are follows,


There are a ton of apps/programs, uses multilib, I moved to rawhide sometime early in fc3 and right about fc4t1 came out they moved almost everything over to gcc4, source based doesn't really optimize anything on a 64 :D (i have tried gentoo on it)


Gentoo-64: Good, but still compile times will always blow, they don't seem to have everything together yet, everytime I've ran it on the 64, seems to bounce back and forth. gcc3.4.3 is standard so you will have to go through the pains of recompiling, not as bleeding edge as rawhide.


Ubuntu-64, no multilib <---- pretty much finishes it for me :D


Suse, can't stand them


mdk64, used to be pay-to-play and I"ve never been a mandy fan anyway.

Edited by cybrjackle
Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...