Jump to content

XOrg font hell [solved by reinstalling]


Recommended Posts

Ok, here's the deal


1. Fresh 10.1 Official install - downloaded ISOs


2. Remove my cd sources, and urpmi internet ones.


3. urpmi fluxbox

- says that there are a lot of XOrg dependencies - these are the latest security patched updates from Mandrake.


4. I said yes, downloaded packages - restarted KDE - and i'm in font hell.

Firefox fonts are badly affected - i just have a choice of very small and too big when i do CTRL - and CTRL + to resize. Certain fonts elsewhere (konqueror,konsole) are messed up too.


Note that this is FRESH install - and i didnt tweak the fonts at all nor did i tweak or configure any XOrg config files. Out of the box, Mdk 10.1 off the ISOs has great ,crisp fonts.


Try uprmi'ng fluxbox and you end up with a real nasty font mess.


Any idea why exactly the fonts would mess up so badly after such a simple procedure as detailed above?


Here's a snippet of Google news in Firefox 1.0 - my Firefox font config is :

Proportional Font is Sans Serif, size 14 , minimum font size none.


Ugly isn't it?


Edited by kde-head
Link to comment
Share on other sites

did some google searching - looks like the Gentoo folks are also experiencing Xorg fonts problems too.


Came across this Gentoo FAQ about solving xorg font issues , which might give some clues.





Let me re-iterate that the way to replicate the problem is


1. fresh install off CD isos

2. change sources to easyurpmi ones

3. urpmi fluxbox - say yes to Xorg dependencies


viola - crappy fonts.

Link to comment
Share on other sites

umm... where are the crappy fonts? i don't see any  :geek:


"Google Smacks" - right hand side - note how the "a" and "c" are nearly joined together


This is way different to a fresh 10.1 install - and over a whole page of text you really notice it.


And it's not just google news - the fonts are screwed up on numerous sites - i guess the only way to prove it is to post up before and after pictures to make it clearer.

Link to comment
Share on other sites

The only thing you might want to look at is the dpi setting at the bottom of /etc/X11/Xresources . Mess with it. There's a canonical 'right' value (measure your screen horizontally in inches, divide the result into the horizontal part of your resolution - 1024, 1600, whatever it is - and that's your dpi value) but Mandrake ships with a 'safe' default and this might've been patched to a different value in an update. If it's 75, try 96, if it's 96, try 75...

Edited by adamw
Link to comment
Share on other sites

Oooh, actually!


You didn't define plf sources by any chance, did you? You might have wound up with PLF freetype, which is a bit pants these days. Do rpm -qa | grep freetype to check. If you see anything with plf in the name, there's your problem. Fixing this can be a pain because urpmi is quite convinced the plf version is the newest. You have to forcibly remove the libfreetype6 package - do rpm -e --nodeps libfreetype6 - and then reinstall the non-PLF one (disable the PLF source with the source editing tool, edit-urpm-media or something, it's called, then do 'urpmi libfreetype6'). Then you might want to add libfreetype6 to /etc/urpmi/skip.list , to stop it happening again. HTH.

Link to comment
Share on other sites

thanks - but neither has worked - font rendering still sucks.


what fonts packages are installed by default on a fresh 10.1 install?



solved it by re-installing 10.1 Official [download edition] to "/" (preserved my /home, so it was no big deal)


i think i'll wait until Xorg 6.8 comes out on mdk - i'll avoid any 6.7 "updates" in future.

Link to comment
Share on other sites

You won't get x.org 6.8 in Mandrake 10.1. It'll be in 10.2, though (Cooker is on 6.8.2rc1, now). If you don't install any updates, make sure you never open .xpm images from untrusted sources. The X updates in 10.1 cover vulnerabilities in the library that handles xpm images; without the updates, your system can be completely compromised by a maliciously crafted .xpm image.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...