Jump to content
SwiftDeath

Installed linux, then windows.

Recommended Posts

I bought another hard drive that was 80 gigabytes just for windows. I have been using Fedora linux for about 2 months. Yesterday I installed the second harddrive and installed Windows on it.

 

It wanted to go over my mbr (grub), so I thought I was smart, and i disconnected the main harrdrive. So it put the mbr on the second drive. So when i boot, grub still shows up.

So anyways I added this to my grub

 

title windows

rootnovrify (hd1,0)

chainloader +1

 

That boot never worked. It would just sit there for at least 20 seconds. But I could still go into fedora.

 

So I asked for help from someone in the channel #Fedora. His name was Plixed. He suggested I change the harddrives so windows is the first one, for some reason. So now the mbr boots to windows, and grub is on the other harddrive and disabled.

 

I was supposed to do 3 steps.

 

1. Change the fstab entries from hda to hdb.

2. Switch the harddrives

3. Reinstall grub over windows mbr

 

I got stuck on the third one. He said put in the first fedora cd. Type Linux Rescue.

I did that.

 

Then do:

Chroot /mnt/sysimage

grub-install /dev/hda (I also tried grub-install --root-directory=/boot /dev/hda)

 

Both times I got an error message saying /dev/hdb1 couldn't correspond with something (which is now the linux harddrive). So now I'm stuck in Windows. Can someone help me fix this mess?

 

I just want to be able to dual-boot Fedora Linux and Windows.

 

Thanks,

SwiftDeath

Share this post


Link to post
Share on other sites

I think you are going to ask the Fedora crowd for an answer.

If it had been Mandrake then I and lots of others would have been able to help you.

Sorry. John

Share this post


Link to post
Share on other sites

The easiest way to have a dual boot machine between Linux and Windows is to install Windows first and then Linux. However, you install Windows, it is going to overwrite your MBR. If you do not let it, then you are probably not going to be able to install Windows.

 

What you need is a way to boot into Linux after you do the Windows install. This will required a linux boot floppy. Then, install windows, let it overwrite your MBR and make sure that you can boot into it first. Once you have that done, then you should be able to go into Fedora, using the boot floppy, and fix Grub so that it recognizes both Windows and Linux.

 

As far as I know, the order of the disks does not matter if you are installing windows 2000, XP.

Share this post


Link to post
Share on other sites

FuzzyLizard: I had linux installed months before windows. And I tricked the windows mbr by disconnecting one of the harddrives like I earlier. Unfortunatly, I did not make a linux boot cd.

 

Cybr:

In my first post I said I got an error kinda like this when doing that"

Chroot /mnt/sysimage

grub-install /dev/hda (I also tried grub-install --root-directory=/boot /dev/hda)

 

Both times I got an error message saying /dev/hdb1 couldn't correspond with something (which is now the linux harddrive). So now I'm stuck in Windows. Can someone help me fix this mess?

 

I was using the first fedora cd though, and that site said to use the rescue one. (Which I don't have).

 

I do have knoppix though, and suze live. But for someone reason, like I said, installing grub is a weird issue. It says something like /dev/hdb1 cannot coresspond with a certain device.

Share this post


Link to post
Share on other sites

Hmm, well I got grub to reinstall.

 

But unfortunatly, grub doesn't work right now.

Its just a black screen, and its says

 

>grub

 

and It allows me to type commands. Unfortunatly I don't know what to do. I cannot boot into eitheir operating system and I'm stuck using knoppix for the moment. Which is incredibly distro btw.

 

Please Help soon,

Thanks,

SwiftDeath

Share this post


Link to post
Share on other sites

I figured some more stuff out.

I can boot into windows if i Type

 

rootnoverify (hd0,0)

chainloader + 1

boot

 

I can also start the boot of linux if i type

kernel /vmlinuz-2.2.6.7-1.494.2.2 ro root=/dev/hdb2

initrd /initrd-2.2.6.7-1.494.2.2.img

boot

 

Unfortunatly, on linux I get a kernel panic. I think its because I swapped harddrives. I added the ro root=/dev/hdb2 because I thought that would fix it. I also tried variations of that like" ro root=/LABEL/ and without ro root at all. They all get kernel panics.

Can someone please help me boot into linux and then restore grub back to a normal menu?

 

Thanks,

SwiftDeath

Share this post


Link to post
Share on other sites

from a livecd, post your fedora /etc/fstab and /boot/grub/menu.lst

 

at the grub shell

grub>

 

do;

find menu.lst

what does it say?

Share this post


Link to post
Share on other sites

This is my fstab.

root@ttyp0[hdb6]# cat /etc/fstab

/proc      /proc       proc   defaults            0 0

/sys       /sys        sysfs  noauto              0 0

/dev/pts   /dev/pts    devpts mode=0622           0 0

/dev/fd0   /mnt/auto/floppy auto   user,noauto,exec,umask=000    0 0

/dev/cdrom /mnt/auto/cdrom  auto   user,noauto,exec,ro 0 0

/dev/cdrom1 /mnt/auto/cdrom1  auto   users,noauto,exec,ro 0 0

# Added by KNOPPIX

/dev/hda1 /mnt/hda1 ntfs noauto,users,exec,ro,umask=000,uid=knoppix,gid=knoppix                                                               0 0

# Added by KNOPPIX

/dev/hdb1 /mnt/hdb1 ext3 noauto,users,exec 0 0

# Added by KNOPPIX

/dev/hdb3 none swap defaults 0 0

# Added by KNOPPIX

/dev/hdb5 /mnt/hdb5 reiserfs noauto,users,exec 0 0

# Added by KNOPPIX

/dev/hdb6 /mnt/hdb6 ext3 noauto,users,exec 0 0

# Added by KNOPPIX

/dev/hdb7 /mnt/hdb7 ext3 noauto,users,exec 0 0

root@ttyp0[hdb6]#

Grub Menu Below (none found)

root@ttyp0[hdb6]# cd /mnt/hdb1

root@ttyp0[hdb1]# ls

System.map-2.6.5-1.358      boot                    config-2.6.7-1.494.2.2  initrd-2.6.6-1.435.2.3.img  vmlinuz-2.6.5-1.358      vmlinuz-SD

System.map-2.6.6-1.435.2.3  config-2.6.5-1.358      grub                    initrd-2.6.7-1.494.2.2.img  vmlinuz-2.6.6-1.435.2.3

System.map-2.6.7-1.494.2.2  config-2.6.6-1.435.2.3  initrd-2.6.5-1.358.img  lost+found                  vmlinuz-2.6.7-1.494.2.2

root@ttyp0[hdb1]# cat /boot/grub/menu.lst

cat: /boot/grub/menu.lst: No such file or directory

root@ttyp0[hdb1]# cd boot

root@ttyp0[boot]# ls

grub

root@ttyp0[boot]# cd grub

root@ttyp0[grub]# ls

device.map     fat_stage1_5  jfs_stage1_5    reiserfs_stage1_5  stage2           xfs_stage1_5

e2fs_stage1_5  ffs_stage1_5  minix_stage1_5  stage1             vstafs_stage1_5

root@ttyp0[grub]#

Below is my menu.lst

 

I dunno if that is the right grub though, because its on the second harddrive (hdb). I dunno how grub works, but I never found a hda1, so I'm assuming grub is loading from here.

Edited by SwiftDeath

Share this post


Link to post
Share on other sites

that's knoppix's fstab

to get hdb6's --->

root@ttyp0[hdb6]# cat etc/fstab

 

 

that's why I said to use find from the grub shell.....it searches all partitions.

grub>find menu.lst

Share this post


Link to post
Share on other sites
find menu.lst

Error 15: File Not Foud

 

I get that.

 

As for this suggestion:

that's knoppix's fstab

to get hdb6's --->

root@ttyp0[hdb6]# cat etc/fstab

 

root@ttyp0[hdb6]# cat /etc/fstab

/proc      /proc      proc  defaults            0 0

/sys      /sys        sysfs  noauto              0 0

/dev/pts  /dev/pts    devpts mode=0622          0 0

/dev/fd0  /mnt/auto/floppy auto  user,noauto,exec,umask=000    0 0

/dev/cdrom /mnt/auto/cdrom  auto  user,noauto,exec,ro 0 0

/dev/cdrom1 /mnt/auto/cdrom1  auto  users,noauto,exec,ro 0 0

# Added by KNOPPIX

/dev/hda1 /mnt/hda1 ntfs noauto,users,exec,ro,umask=000,uid=knoppix,gid=knoppix                                                              0 0

# Added by KNOPPIX

/dev/hdb1 /mnt/hdb1 ext3 noauto,users,exec 0 0

# Added by KNOPPIX

/dev/hdb3 none swap defaults 0 0

# Added by KNOPPIX

/dev/hdb5 /mnt/hdb5 reiserfs noauto,users,exec 0 0

# Added by KNOPPIX

/dev/hdb6 /mnt/hdb6 ext3 noauto,users,exec 0 0

# Added by KNOPPIX

/dev/hdb7 /mnt/hdb7 ext3 noauto,users,exec 0 0

root@ttyp0[hdb6]#

 

I did do that, thats not the knoppix fstab, I think knoppix will just add some lines to the bottom temporarily.

Edited by SwiftDeath

Share this post


Link to post
Share on other sites

Why don't you insert the first CDROM of your Linux Fedoras' CDs and do a pretend up-grade.

 

This will take you through the procedure band will not usually change any packages but check them out and will take you through to the final set-up stages where you can make your choice of boot program and also make the boot settings as well.

 

I do this routine with Mandrake and it has saved me on dozens of occassions.

I should imagine that you could do similar with Fedora.

 

Cheers. John.

Share this post


Link to post
Share on other sites

I wish soo too, That was one of the first things I tried. For someone reason it does not replace the boot-loader.

 

I tried it three times, with no sucess.

Share this post


Link to post
Share on other sites

It is obvious from what you report that this trick does not work with Fedora but I know it does with Mandrake.

Now I know another good reason why I stick with Mandrake. ;) ;) ;)

Share this post


Link to post
Share on other sites
I think you are going to ask the Fedora crowd for an answer.

If it had been Mandrake then I and lots of others would have been able to help you.

Sorry.                            John

Not cool.

 

We have plenty of Fedora users here and we're more than happy and fully able to help Fedora users on the musb.

 

Our name "Mandrake Users Board" is more part of our legacy than anything else, we've evolved into a meeting place for all Linux users, not just Mandrake. :deal:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...