Jump to content

XFree86 and chkfontpath problems


Recommended Posts

I'm trying to install Gnome 2.6.2 on my Mandrake 9.2 Chinese (Traditional TW) system. I seem to be in dependency hell.


Gnome 2.6 shows up in the RPMdrake list, but when I try to install it, I get the following error:

The following packages have to be removed for other to be upgraded:

chkfontpath-1.9.10-1mdk.i586 (due to missing XFree86-xfs)

Is it okay to continue?


When I try to install XFree86-xfs, I get the following message:

Some package requested cannot be installed:
XFree86-xfs-4.3-32.2.100mdk.i586 (due to unsatisfied XFree86-libs[== 4.3-32.2.100mdk])
do you agree ?


As far as I can tell, that package doesn't exist. There is, however, something called libxfree-4.3-32.2.100mdk. However, when I try to install that, I get the following error:

Some package requested cannot be installed:
XFree86-4.3-24.5.92mdk.i586 (due to unsatisfied libxfree86[== 4.3-24.5.92mdk])
do you agree ?


I found and tried to install libxfree86-4.3-24.5.92mdk, but I then get this error:

Some package requested cannot be installed:
XFree86-server-4.3-24.5.92mdk.i586 (due to missing XFree86-xfs-4.3-23mdk.i586)
XFree86-xfs-4.3-23mdk.i586 (trying to promote XFree86-xfs)
xorg-x11-xfs-6.7.0-3mdk.i586 (due to unsatisfied chkfontpath[*])
do you agree ?


So the thing requires an earlier version of itself?!? And I've now looped back to the chkfontpath requirement. Is this not the very definition of dependency hell?


What should I do? Try to install gnome-2.6.2 with nodeps? But I get the same problem with many other apps (bittorrent gui, amarok, etc.), so I'd really like to get the problem solved once and for all. I'm pretty lost here.


Thanks in advance for any help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...