Jump to content
payasam

No CD writer on desktop - SOLVED

Recommended Posts

While there are icons on the desktop for both of my floppy drives, there is none for my CD writer. I have so far been unable to make one by right-clicking on the desktop as I have done for several programs. I am on 10.0 Official and can see the drive under /mnt.

Share this post


Link to post
Share on other sites

What do you mean no CD-Witer?

 

Usually there is not one of those afaik. If your looking for something to burn cd's the you should use k3b. I think you can open it by, opening up a terminal typing in ' k3b '. You might have to do it from root.

 

If it's not installed then get it from uprmi by doing ' urpmi k3b ' and that should install it.

 

-Luis

Share this post


Link to post
Share on other sites

My system has two floppy drives and one CD writer. When I installed 10.0 Official, icons were created on the desktop for the floppy drives but none was created for the CD writer. All three are present in /mnt. I doubt that I can put it more clearly than that.

Share this post


Link to post
Share on other sites
My system has two floppy drives and one CD writer. When I installed 10.0 Official, icons were created on the desktop for the floppy drives but none was created for the CD writer. All three are present in /mnt. I doubt that I can put it more clearly than that.

Ok, as far as I know, mandrake should create an icon for CD-ROM, and it does not create a special icon for CD burner. My understanding, is that icons are created for file systems, cd burning is handled differently. Anyway, if you use KDE, to add a CD-ROM to desktop, right-click on the desktop, choose "Create New...", then choose "CD/DVD-ROM device", fill out the info. That should be it.

 

Double-click vs single click - There should be an option in KDE control centre somewhere. You should be able to find the answer by seerching this forum.

Share this post


Link to post
Share on other sites

Seems a little strange, Coverup, because CD writing is also a file system to the extent that the burner also reads CDs. However, I learnt long ago that computers and rationality are seldom related to each other. As I said, I did try the Rt-click-on-desktop method: but maybe the option I chose after that was not the one you advise.

 

As for the double-click / single-click matter, are you answering someone else's question? I didn't ask it. Yes, there certainly is an option, and I have seen it with mine own enfeebled eyes -- and, like you, I cannot remember where it is. Possibly Look & Feel.

Share this post


Link to post
Share on other sites

Since 10.0 mandrake does not put an icon for cdrom/writer/dvd on the desktop by default but uses magicdev/dynamic scripts to create them: if I insert a data cd into my drive, an icon appears on my desktop.

Inserting a blank cd-r: k3b opens

Inserting an audio cd: the audio player is started automatically.

Connecting a usb mass storage: new hd icon on the desktop appears.

 

Are you saying that does not work for you?

 

If I would create manually another icon, I would get two icons ;-) for the same device.

 

Creating them: right click desktop --> create new --> device --> burner, don't forget to click on the third tab: device and fill in: /dev/hdb or /dev/hdc or /dev/hdd, depends where your drive is.

Edited by anna

Share this post


Link to post
Share on other sites

Thanks, Anna, but the fact is that I've been a silly old fool. A while ago I discovered what you've pointed out. The CD drive icon is on the desktop when there's a CD in it. Take the CD out and it disappears. One conclusion is that jokers of 54 need good ophthalmologists. I shall not boast about how unobservant I am (despite having been a photographer since the 1960s) or how lacking in intelligence (despite having been a university teacher since 1977). Long ago someone told me that the older we get and the more we learn, the more obvious becomes our ignorance: and the more appalling.

Edited by payasam

Share this post


Link to post
Share on other sites

That's immensely reassuring, Counterspy, but just whom are you calling old?

Share this post


Link to post
Share on other sites

Good god, Anna, how did you get in here? Didn't you see the notice at the top, CHILDREN NOT ALLOWED? Ah, yes, I forget. You still haven't learnt how to read.

Share this post


Link to post
Share on other sites

btw, with 10.1 we now actually use dbus to do insert notification, and the gnome-volume-manager tool to actually run the application or create the icon, with GNOME. Dunno what's used in KDE, something equivalent. The end result is the same, though - an appropriate app pops up for writable CDs, audio CDs, DVDs etc, and an icon appears for data disks. when you do an upgrade from 9.2 (which used supermount) or 10.0 (which used magicdev) and the systems collide, Exciting Things may happen...

Share this post


Link to post
Share on other sites

It's only been a few days since I got into 10.0, Adamw, and I don't foresee moving to 10.1 or later until I learn to find my way about in this one. Besides, as I understand it, 10.1 is still in the pre-final stage. In short, I think I shall keep away from your no doubt excellent product with the trade mark.

Share this post


Link to post
Share on other sites

What you have to look for to fix the single or double click mouse choice is --------> KDE Control Centre ----------> Peripherals -----------------> Mouse ---------> General.

 

To have your cd burner and other cdrom devices on the desktop -----------------> KDE Control Centre --------------> Look & Feel ----------> Behavior --------------> Device Icons ...... then put a checkmark in the appropriate boxes for both mounted and unmounted then click APPLY.

 

Done. Cheers. John.

Edited by AussieJohn

Share this post


Link to post
Share on other sites

Thanks, John. Clearly I must have missed the device options thing. Will do what you advise first chance I get.

 

I cannot understand why I am being told about single and double clicks, which is not a matter I asked about. I've seen the options and chosen those that I want. Thanks anyway.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...