Jump to content

Yet another newbie with sound issues...

Guest Malaclypse

Recommended Posts

Guest Malaclypse

I've recently installed Mandrake 10 (the community version from the LXF coverdiscs) and am having problems getting the sound to work.


From reading the thread, my problem seems identical to Ryan's here.


lspcidrake -v | fgrep AUDIO says my soundcard's default driver is snd-intel8x0 and grep sound-slot /etc/modules.conf tells me that is what it's using. According to /sbin/lsmod the driver is loaded (and isn't being used by any programs). /sbin/chkconfig tells me that both alsa and sound are set to run on initlevels 2,3,4 and 5.


There is no /dev/dsp or /dev/sound/dsp but MCC states that both alsa and sound are running, and are set to run at boot (stopping and starting them has no effect).


I've been trying a few different distros and had similar sound problems with Slackware and Debian, but in Fedora Core 2 the sound worked perfectly right from the start, and it was using the same driver - snd-intel8x0 - so I know that's not the issue.


I've been searching the web for a while and it seems like a few people have had similar problems, but I haven't seen any solutions yet. I don't particularly want to give up on Mandrake and use Fedora, for various reasons, so if anybody has any ideas I would be most grateful!


[link fixed by spinynorman]

Link to comment
Share on other sites

Guest Malaclypse

I get the following error when KDE starts:


"Error while initializing the sound driver:

device /dev/dsp can't be opened (No such file or directory)

The sound server will continue, using the null output device."


And when booting the system there is this:


"localhost alsactl: alsactl: load_state:1134:

Sep 8 19:18:31 localhost alsactl: No soundcards found..."

Link to comment
Share on other sites

Guest Malaclypse



I have no idea why this worked, but it did. I went into my Bios and in the "Are you using a Plug n Play OS?" selected "No". Since doing that the sound works perfectly without me doing anything else.


I'm guessing some sort of conflict with the Mandrake kernel? I know little, but Fedora Core 2 worked perfectly with the plug n play left on in the Bios, so I would imagine it's related to one of the Mandrake patches to the kernel?


It's a shame that Ryanw guy gave up, it would have been interesting to see if this worked for him too.

Link to comment
Share on other sites



The problem is not a conflict with the kernel. It is simply that when P&P is selected, the bios assigns the interrupts and thus prevents Linux from detecting and assigning the interrupts itself.


That is why the sound card was not detected. When the P&P was disabled then Mandrake was able to detect the audio card and thus proceed from there. So there is no mystery about why sound came to life

This is the cause of more problems than you can poke a stick at. Even if the install seems to have gone OK there is almost always problems that intermittently crop up and seem to have no rhyme or reason to them and seem to sometimes magically disappear. and reappear.


For a stable system you MUST do this and follow this up by disabling harddrake in Mandrake Control Centre -------> System -----------> Services , AFTER you have completed the install .



Cheers. John.

Edited by AussieJohn
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...