Jump to content

Bootsplash graphic/frame buffer mode


Recommended Posts

My bootsplash/progress bar/frame buffer boot up (?) has disappeared again!

 

Saga is :

 

Notice update of kernel sources from 2.6.3-15 to 2.6.3-16 in the MCC>software manager>updates section.

 

Do the update (as umpteen times previously).

 

Zilch. Appear's at lilo offering as 2.6.3-16, but when checking uname -r post boot, still booting 2.6.3-15 (something like this happens everytime!).

 

So, remove the new kernel version and kernel source version (both installed - nvidia graphics card!).

 

Try to reinstall the updates - same as above, but this time, it just freezes my lilo screen.

 

Remove kernel/sources (updates) again. Still no boot, except for "non-fb linux" in lilo, everything else freezes.

 

So, after various other attempt's, revert to the old kernel version 2.6.3-7 (kernel and sources), check system - It boot's (boot option appearing as 2.6.3-7).

 

Great. So now try the updates again.

 

Yes, bingo, 2.6.3-16 now appears in lilo boot screen. uname -r yes it's booting into 2.6.3-16 OK.

 

Change the label, and so my current install appear's second in list (windows first, due to domestic politic's/self preservation!:D).

 

But now, it only boot's into what appears to be the "non-fb linux" mode with the "clunky" verbose text scrolling up the screen.

 

How would I check to see whether it'd be just changing lilo options, or setting it to boot with framebuffer enabled and can see the nice pleasant graphic start up with the progress bar etc ? (sorry I'm just really sad, and prefer the eye candy stuff)

 

Any advice much appreciated

 

regards

 

John

 

p.s. Sorry if this is in the wrong forum, but I figured it's just a "software thing" rather than installing, or programming and whatever!

 

[moved from Software by spinynorman B) ]

Link to comment
Share on other sites

Read this: http://www.bootsplash.org/

 

Or the short answer is that you need to compile support in the kernel and create an initrd.

 

Whoosh! (the noise of that going straight over my head).

 

Erm, surely, if my system has previously had a bootsplash screen running, then the facility is still there? (please feel free to correct me if incorrect).

 

Isn't there just a way of "turning it on"?

 

regards

 

John

 

p.s. I don't follow why this was moved to the "Terminal Shell Commands, Kernel and Programming" forum i.e. I don't understand what it might have to do with terminal shell commands etc etc Surely it's just a graphical software "thing" ?

Link to comment
Share on other sites

p.s. I don't follow why this was moved to the "Terminal Shell Commands, Kernel and Programming" forum i.e. I don't understand what it might have to do with terminal shell commands etc etc Surely it's just a graphical software "thing" ?

It might be something to do with the kernel thingy, or I might have moved it just to confuse you...

 

Anyway, how come you're suddenly an expert, when you didn't know where to post in the first place? :cheeky:

Link to comment
Share on other sites

<snip>

Anyway, how come you're suddenly an expert, when you didn't know where to post in the first place?

</snip>

 

Ha ha! I've only been taking reading and watching lesson's B)

 

 

In truth, well I don't do anything with a terminal unless I have too! - <mantra>graphic is good, graphic is good, graphic is good,

graphic is good</mantra> :lol2:

 

regards

 

John

 

p.s I don't suppose you know how I'd switch the bootsplash graphics back on do you Norm?

Link to comment
Share on other sites

Look in /boot to see if there is a initrd with the same name as the new kernel. If here is look in /etc/lilo.conf if in the append line it says splash=silent and vga=788. If it does and you don't see a bootsplash and image is missing in that initrd (initial ramdisk).

 

So you need to make an other one (backup your /boot/.initrd) and give as root: splash -s -f /etc/bootsplash/themes/Mandrake/config/xxxxx.cfg > /boot/initrd (where xxx is the theme you want to use).

 

(If it doesn't work you need to recompile the kernel)

 

Good luck

Link to comment
Share on other sites

have you tried going to MCC->boot->boot theme & re-enabling the boot splash? when you install a new kernel/source, you need to also re-enable the bootsplash. run lilo -v afterwards, reboot, it should be back.

 

Chris

Edited by chris z
Link to comment
Share on other sites

That seem's to have done the job.

 

I tried Chris Z's answer first (it looked the easier option).

 

When I tried to just switch it on, as per, I got a little dialogue box saying something about video mode resolution in frame buffer mode and selecting it in lilo.

 

So I hit OK and went back into the bootloader config section and in the advanced dialogue box, I found the bit about video modes. It was set to 100x80 (or vice versa), so I've selected the 1024x768 in frame buffer mode.

 

When I rebooted, the only difference was that the text was a lot smaller.

 

So, I started checking into devries answer. The initrd was there for the kernel version, and when I looked at the /etc/lilo.conf, I just added the splash=silent to the append line, there was already a vga= line further down (vga=791) so I didn't bother putting another one in the append line.

 

reboot and bingo, it's working.

 

Thank's very much for all who have helped. Very much appreciated.

 

regards

 

John.

 

p.s. don't forget - <mantra>graphic is good, graphic is good, graphic is good, etc etc.</mantra> :lol2:

Link to comment
Share on other sites

All that mucking around. Wow.

 

I am glad I use MCC and use Grub as bootloader. It doesn't appear as pretty as Lilo but is a hellava lot easier to use (and far more reliable).

When ever you select a new kernel to boot in to you must always check that the boot settings are what you want with that kernel. The system does not automatically apply pre-chosen boot settings to all kernel choices. Try adding some boot themes. There are some nice ones around and when installed you can select the one you want from within MCC ---> Boot

 

Cheers. John.

Link to comment
Share on other sites

<snip>

Try adding some boot themes.  There are some nice ones around and when installed you can select the one you want

</snip>

 

Yup, I sort of intend to get round to looking into that John. I figured that there's got to be some nice stuff around after looking at (and getting confused by) the bootsplash.org site!

 

regards

 

John

Link to comment
Share on other sites

All that mucking around.  Wow.

 

I am glad I use MCC and use Grub as bootloader.  It doesn't appear as pretty as Lilo but is a hellava lot easier to use (and far more reliable).

When ever you select a new kernel to boot in to you must always check that the boot settings are what you want with that kernel.  The system does not automatically apply pre-chosen boot settings to all kernel choices.  Try adding some boot themes.  There are some nice ones around and when installed you can select the one you want from within MCC  --->    Boot

 

Cheers.                John.

 

Grub is not easier to use... and lilo has been around alot longer than grub has, I have never had problems with lilo not being reliable. *tsk* you are probably one of those emacs users too :jester: when everyone knows vi is better.

Link to comment
Share on other sites

Wrong thinkliberty.

I am not an emacs user and I wouldn't know what it was if it hit me. I am simply one who follows a set of instructions that have been laid out by people who know a whole lot more about a subject than I do.

 

Maybe you don't, but I am one who was trained to READ THE MANUAL FIRST and don't presume you ( meaning me) know. When an instruction says use vim then that is what I use. In another thread involving an NVIDIA driver install problem, (which you are probably alluding to) a poster had no end of trouble because he made what seemed a minor insignificant change to the procedure, namely using vi instead of the advised vim. I have NEVER had a problem installing or reinstalling the nvidia driver on my machine or two other friends machines which have different nvidia video cards. I do not think good luck had anything to do with it and I am not a trained and certified computer tech so I follow instructions exactly.

 

Grub is rapidly becoming the default for LINUX OSs from what I am hearing. The fact that LILO has been out much longer does NOT make it superior, only older.

It is not as user friendly as Grub but this would not matter to a geek who thinks user friendly is sissy woosses stuff. To them if it isn't difficult to use then it cannot be any good.

 

Like most computer users, I like to use my machine for actual work and playing with it is only sideline interest.

 

John.

Link to comment
Share on other sites

Ha Ha Ha .

BVC it was you that convinced me about my thoughts about Grub when I read all your help posts dealing with boot loaders over the past year. :thanks:

Don't know anything about vi. I have only used vim for the Nvidia driver install routine. Also I only use the command line mode for installing source programs so I don't know a lot about command line either.

However I get by and still have a good operating system that does what I want. Not too bad for a Great GrandFather huh.

 

I sense you have been or are having difficult times at the moment. I hope things go well for you quickly. :thumbs::thumbs::thumbs:

Cheers. John.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...