Jump to content

SATA Mount point issue


Recommended Posts

Hi Everyone,


I am running Mandrake 9.2 clean install on a 40gig ATA drive. I have a 2nd drive in the system a 120gig SATA drive using the Sil3112A built in card on my MB. Anyway, there were 2 partitions on the drive that were mounted on the 9.2 install /mnt/Windows_C and /mnt/Windows_D and they read fine. Using DiskDrake I crated a 3rd 40gig partition FAT32 and tried to add the mount point as /mnt/storage and it seem to work except that did not show in /mnt directory. I rebooted and got an error that could not mount /mnt/storage. Can not remember the exact error except that it said something about magic in the error message. I had to boot in INIT 3 ignore the error and switch to INIT 5 then using diskdrake remove the mount to be able to startX again on boot. I tried the same process again except that instead of FAT32 I used ext3 file system - same error again. I have not tried creating the partition in XP yet then trying to mount in linux. I use Linux as my main OS thus I try to do as little as possible in XP. Any Ideas ? I know I can not use SATA as my main drive even in MDK10 as it will not work but as a 2nd drive it seems to be fine other than this issues as the other 2 windows partitions read and write just fine. I really wanted that third partition as ext3 if possible and XP can not create that FS type.


Thanks in Advance for your help, :thanks:




here are my specs:


Abit NF7-S

XP 2800+

OCZ 512mb Dual DDR kit (2x256mb)

Intel LAN 10/100 Pro NIC

MSI GF4 Ti4200 VTD vid card

Maxtor 40Gig ATA drive (hda)

Seagate 120Gig SATA (hde)

LG 12X Dual Layer DVD burner

Sony 52x32x52 CDRW/DVD combo drive

Swiftech XP Block Watercooling system

Enermax 365 Pro Power Supply

Link to comment
Share on other sites

I tried 7 times with MDK 10 to install to SATA even though my controller is supported according to the documentation SIL3112A. But all 7 times it failed and only way I could get installed was through ATA drive as hda. I never tried with 9.2 on 10. So I re-installed the ATA drive and loaded 10 - but it kept crashing so I formatted and loaded 9.2 on the ATA. Are you saying that the SATA load will work on 9.2 as documentation does not show SIL3112A controller as supported and I found no articles that indicate that it would work with 9.2 - 9.1 failed and 10.0 failed so I assumed that 9.2 would too - never attempted it. And from my current issues, with SATA, it looks like it has similar issues. If you have more to add please feel free to advise.


Thanks, :thanks:



Link to comment
Share on other sites

Mandrake 10 should support it (don't know about 9.2 but the 2.4 kernel had SATA support as well). You might have to modprobe the modules during installation. And try installing with linux noapic noapci.


Good luck.

Edited by devries
Link to comment
Share on other sites

Sata support varies by sata controller chipset and kernel. Here's my experience with an intel mb with an ICH5 sata controller and a seagate 200GB sata hard drive:


mdk9.2 - undetected with the 2.4 kernels when sata drive was added after install


mdk10(2.6.3 kernel) - detected fine and works as second drive; didn't try reinstalling mdk10 on it; sata hd is reported as /dev/hde


mdk10.1 and slack10(kernels 2.68 and 2.67) - detected, and works fine but sata drive is now reported as /dev/sda; had to do some fancy footwork to get it to work in slack10; was able to install mdk10.1-beta1&2 on the sata drive


kernel 2.4.27 - drive not detected; booting a linux distro with this kernel installed on an ide drive with the sata drive connected will hang the boot process unless hde=ide-scsi is passed as a boot parameter and then it will boot but the sata drive will not be detected


kernel 2.4.28-pre2 - drive detected/works and reported as /dev/sda


The moral of the story is that sata support is evolving and seems to have settled down in kernels 2.6.7 and above. The 2.4.28 kernels coming out have backported the sata patches from 2.6. The big changes are in libata and associated sata kernel modules if you look at the change logs. I would suspect that mdk10.1 will have good support for your sata controller as it uses the kernel 2.6.8.


I'm curious as to how your sata drive is handled in fstab(hdx or sda).

Link to comment
Share on other sites

OK, I fixed it and I think I may have found something at least with this kernel, and 10.0's kernel too for SIL3112A


The reasons the mounts worked from the install was that they were primary partitions on the SATA drive - diskdrake when I was creating the new partition was trying to create an extended partition. For whatever reason MDK 9.2 and 10.0 could not mount that extended Partition. HOWEVER, I used PQ MAGIC to create a third Primary Partition on the STAT (NTFS) and used diskdrake to set the mount point and it mounted successfully. I am going to test with an ext3 fs Primary Partition. AND I think that also may be the issue with the install on the SATA for 9.2 & 10.0. I was using Auto allocate which uses the same partitioning programs as Diskdrake does. Therefore in theory if I create the 3 partitions on the drive that the install does (i.e. /, /swap, /home) using PQ Magic then try to install to the existing partitions now on the SATA it may work. The question is will the install or system be hindered in any way by doing the partition table this way? I will try the ext3 one first and then the install and let you know, also as requested here is my fstab file.


/dev/hda1 / ext3 defaults 1 1

none /dev/pts devpts mode=0620 0 0

/dev/hda6 /home ext3 defaults 1 2

none /mnt/cdrom supermount dev=/dev/scd0,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0

none /mnt/cdrom2 supermount dev=/dev/scd1,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0

none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,sync,iocharset=iso8859-1,umask=0,codepage=850 0 0

/dev/hde1 /mnt/win_c ntfs iocharset=iso8859-1,umask=0,ro 0 0

/dev/hde2 /mnt/win_d ntfs iocharset=iso8859-1,umask=0,ro 0 0

/dev/hde3 /mnt/win_e ntfs defaults 0 0

none /proc proc defaults 0 0

/dev/hda5 swap swap defaults 0 0



Thanks for your help everyone, 1 less confused newbie, :thumbs:



Link to comment
Share on other sites

Mine are all extended/logical partitions on my sata drive which might explain some of my results. Sata drives tend to be big and I didn't want to limit myself to four primary partitions of 50GB. I'm pretty sure you won't have that problem with mdk10.1 and your drive will probably be reported as sdx in kernel 2.6.7 and above. My research indicated that your sata controller and intel's ICH5 sata controller were known to cause problems in the earlier 2.6 kernels but it seems to be all straighted out now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...