Jump to content
Sign in to follow this  
flightcrank

Mandrake 10 ICS help

Recommended Posts

ok i want to know how to use mandrake to share my internet connection. sounds simple..........ITS NOT

 

well not for a windows user anyway. but i want to learn

 

heres my set up

 

my linix box is connected to the internet on eth0, which is my CABLE internet connection and has a DYNAMIC IP(one which changes all the time)

 

i have a second network card which is eth1, it has the ip 192.168.0.1

 

my second computer in rinning windows XP with the ip adress 192.168.0.2

 

so computer 2 is set up pefectly with the gateway set to 192.168.0.1 which has been tested and works (using winXP as the ICS host on my server computer which now obivously has mandrake linux on it)

 

with wndows XP all u do is share your internet connection on your first network card, and set your second network card with a static ip of 192.168.0.1 and.........THATS IT it works fine, mandrake is supposed to be userfriendly..(not when it comes to networking i guess)

 

i also want to disable all the stuff that mandrake runs lke squid and just run the internct connection sharing.

 

also please dont tell me to go to here http://web.onetel.net.uk/~showerail/ics_setup.html

 

and try that because i have and it dosnt work.

 

also the person who wrote it dosent even know if it works as he hasent even tested it yet

Edited by flightcrank

Share this post


Link to post
Share on other sites

hello all, no need to respond i have it working now

 

here is EXACLTLY what i did to get it working for anyone who cares, u all know my coputer congiuration so if any one with the same harware setup is having troubles this may help

 

Edit the file /etc/sysctl.conf and on the line net.ipv4.ip_forward = 0, change 0 to 1.

# Controls IP packet forwarding
net.ipv4.ip_forward = 1

In order for the changes to take effect,

at the command line, type: service network restart

 

Now you need to setup IP forwarding and Masquerading.

First, you need to flush the old rules.

So open a console window and at the command line, type:

service iptables stop
service iptables save

The following commands will create new rules for your system.

iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD DROP

iptables -A FORWARD -i eth0 -o eth1 -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i eth1 -o eth0 -j ACCEPT

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

NOTE: In this case, eth0 connects to the internet and eth1 connects to the local network.

You may need to switch eth0 and eth1.

The ifconfig command will give you more information.

 

To save iptables modifications, at the command line, type: service iptables save.

IPtable rules are located in the /etc/sysconfig/iptables file.

 

Don't forget to start iptables: service iptables start

Share this post


Link to post
Share on other sites

now what i would like to know is why typeing in that code works so well while the wizard dose not ????

 

i mean mandrake is at verson 10 now, you would think they would have got it right by now.

 

so why doses this code work so well ?. if any one here is good at linux and has a bit of spare time can u tell me line by line what each peice of code dose exatly? or point me to a reasource which may help

 

i want to learn,

 

thanks

Share this post


Link to post
Share on other sites
here is EXACLTLY what i did to get it working for anyone who cares, u all know my coputer congiuration so if any one with the same harware setup is having troubles this may help

.....

You rule!! :thanks:

I did exactly what you wrote and it's working for me as well.

 

Now there is still one problem in fact: on my client (windows) machines, the DNS is set to 127.0.0.1

What would be the correct setting and how can I set it up?

Share this post


Link to post
Share on other sites

I mean: I don't want to add the DNS IP on every client machine to be 192.168.1.1

I want it to work with the setting "Optain DNS IP from DHCP server"

Share this post


Link to post
Share on other sites
with wndows XP all u do is share your internet connection on your first network card, and set your second network card with a static ip of 192.168.0.1 and.........THATS IT it works fine, mandrake is supposed to be userfriendly..(not when it comes to networking i guess)

Sorry, but this statement couldn't be left alone. Indeed, you have to tell the machine to do ip forwarding. Madrake isn't network unfriendly.. Non network people find networking unfriendly. There is a lot to networking. Just because doze finds a cute way to put wizards together to hide what is going on and allow shcool kids to "set up networking" and really don't have any idea how a network works, doesn't mean Mandrake isn't network unfriendly. Look at any real OS. You are expected to know something about networking to set it up, or at least be able to type intelligent search criteria into google.

Edited by Vdubjunkie

Share this post


Link to post
Share on other sites
Sorry, but this statement couldn't be left alone.  Indeed, you have to tell the machine to do ip forwarding.  Madrake isn't network unfriendly..  Non network people find networking unfriendly.  There is a lot to networking.  Just because doze finds a cute way to put wizards together to hide what is going on and allow shcool kids to "set up networking" and really don't have any idea how a network works, doesn't mean Mandrake isn't network unfriendly.  Look at any real OS.  You are expected to know something about networking to set it up, or at least be able to type intelligent search criteria into google.

it is un friendly when compared to other os's, why do u think this thread and many like it exist,

 

idiot

Share this post


Link to post
Share on other sites

:D

 

wow i have used this thread many times when ever i set up a mandrake system. it always works without fail.

 

flightcrank said he wanted to know what all this code means ? i would also like to know.

 

dose anyone here know what each line does ???

Share this post


Link to post
Share on other sites

i have another problem, i upgraded to mandrake 10 to mandrake 10.1 and after a period of inactivity, my windows machince have no internet access i get timeout messages.

 

so on my mandrake box i type

 

"service network restart"

 

and my internet connection shareing works again.

 

any idea on whats going worng, i like mandrake and dont want to change distros

Share this post


Link to post
Share on other sites

well i still have this problem with my windows machines alwas losing the internet. when it goes down i can ping both my network cards fine, i believe the problem is in the routing,.

 

any ideas on why this is happing?? ive tryed everything

Edited by flightcrank

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...