Jump to content

Too many options in lilo


Recommended Posts

My lilo menu has half a dozen of options but I only need MDK and Win2K.

(why are there so many options??)


In MDK CC Boot loader there is only Windows (/dev/hda1)*

I guess Linux is implicit?

Also the star supposedly makes windows the default but when I boot it's Linux the default.


How do I clean up the boot menu to only have Win32 (default) and MDK 10 when the control center is of no help? I read about a liilo.conf file...

Here is my /etc/ lilo.conf :

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file


If I run "lilo" as root I get "Fatal: open /boot/message: No such file or directory"


What should I change in my lilo.conf?

Win2k is on hda1 (there are 3 NTFS partitions on the hda HD) and MDK on hdb3 I think... There are 3 linux partitions on hdb but I could not find out a way to display information about it. I think hdb1 is a boot partition, hdb2 a swap and hdb3 is where the MDK install is on.

Link to comment
Share on other sites

changing lilo.conf has NO EFFECT until you sucessfully run lilo....


since your messeges is messing up its not running and hence not changing the MBR..


think about it its a safety feature, if it encounters an error then it could leave you unable to boot at all so it does nothing....


Check if /boot/medssages is there!

Link to comment
Share on other sites

/boot/message exists, it's a link that points to "message-graphic" but there is no such file in /boot

I don't know what to do with that. I thought that using MDK boot loader was straitforward but apparently you have to modifiy that lilo.conf yourself :screwy:

Link to comment
Share on other sites

I am not sure how your computer is booting to linux. I do not see it listed in your boot record, and since there is an error when you run lilo -v, I must assume that you did not place lilo in the default position, the mbr. I would first use the rescue disk (cd1, F1, "rescue") and reinstall lilo to the mbr.


The boot options in lilo do not really matter much in the grand scheme of things, and are useful at precisely the right time. Although, if you have a good live cd (MandrakeMove, MEPIS) you can get into your system as root in order to discover why your linux won't boot. When I edit lilo, I use hash marks (#) which remove the lines but do not remove the text in case I wish to restore it later.


Reinstall lilo to the mbr. lilo works out of the box.

Link to comment
Share on other sites

  • 2 weeks later...
use the rescue disk (cd1, F1,  "rescue") and reinstall lilo to the mbr.

I tried that and I got exactly the same error message: "Fatal: open /boot/message: No such file or directory"


What's puzzling me is that the lilo.conf content does not correspond to the menu that is displayed on boot. The boot menu is working fine for both Win2K and MDK, I don't mind the extra options, but I'd like windows to be the default selected option. How can I change that with a corrupted lilo.conf file?

Link to comment
Share on other sites

Just backup /etc/lilo.conf (boy I got the slashes right that time!)


cp lilo.conf lilo.bkup


Now make all the changes you want, strip out the other kernals leaving yourself with windows and linux..


Then open a console and run the lilo command






Did it work? If not, do not reboot until you have no issues..

Link to comment
Share on other sites

No, no it's not the problem.

I have a working dual boot MBR, but no lilo.conf file that correspond to it.

What's the point of backing up a lilo.conf file that is of no use?


I cannot play with the lilo command because if I mess things up, I have no lilo.conf to restore a working MBR.


And the trouble is, I need windows to be the default selected option at boot.


Is there a way to "create" a lilo.conf file out of an installed MBR? I know you usually do it the other way round, but is it possible?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...