Jump to content

Recommended Posts

Hello everyone,

I just installed slackware and the installation seemed to be going fine but when I booted into it, it booted into text mode, so I typed kdm and it went to just a pure black screen and the power light on my monitor started blinking. I had a problem with this in mandrake a while back and it had to do with the video card. Im using slackware 10.0 with an Nvidia GeForce FX 5200 video card. I need :help:

 

 

 

 

-Neocytrix

Share this post


Link to post
Share on other sites

have you configured X?

 

have you installed the nvidia driver?

 

One of these might work

 

iphitus

Share this post


Link to post
Share on other sites

Linux IA32

 

it's for Intel Architecture, 32-bit (this is fine for athlons also, btw). IA64 is for 64-bit (if my understanding is correct).

Share this post


Link to post
Share on other sites

/usr/X11R6/bin/xorgconfig

 

 

Do you know your values for Monitor? What type of monitor?

Share this post


Link to post
Share on other sites

I still can't get it to work, I went to install the Nvidia driver from here and the script ran fine but it said something about making sure my kernal source was there or something like that, and it is there. So then I went to install my 3com drivers from here and that had a bunch of errors also. Can someone tell me maybe how to configure X or what I should be looking for in my logs? IM LOST lol. :angry:

 

 

-neocytrix

Share this post


Link to post
Share on other sites

I have the same card (chipset) as you running slack 10 with nvidia drivers. If you don't have the nvidia drivers set up you should still be able to run X using the default configuration

 

I don't know which Mag Innovision you have, but the lowest model has frequency 30-70kHz horizontal and 50-130Hz vertical.

 

Edit your /etc/Xorg.conf file and put those values in the monitor section. You could probably put in higher values, but leave that until you know which model monitor you have.

 

If you have nvidia drivers working, change the Xorg.conf file accordingly (module "nvidia", enable GLX, etc). I'm not in Linux right now, so I can't be more specific. If you don't have nvidia working, use the "nv" or "vesa" module with GLX disabled.

 

See if that makes a difference. If not, post again

Share this post


Link to post
Share on other sites

I tried a new set of drivers and when I went to install them it said that there was a problem (rivafb confilicted with the driver) How do I fix that?

 

 

 

 

 

-Neocytrix

Share this post


Link to post
Share on other sites

Do "lsmod" in terminal to see what modules are being loaded and post the results.

 

In general, you need to install your kernel source, as root

installpkg kernel-source-2.4.26-noarch-4.tgz

if you're using the default kernel.

 

 

Download the nvidia drivers (NVIDIA-Linux-x86-1.0-6106-pkg1.run) from this page and install with

sh NVIDIA-Linux-x86-1.0-6106-pkg1.run

as root.

 

 

Edit /etc/X11/xorg/conf to look like this:

 

In the "Modules" section, uncomment the Load "GLX" line

 

In the "Graphics Device Section", change "driver to "nvidia"

 

 

I think you said you had done all this, but you mentioned "rivafb", which sounds like an old nvidia card, maybe the wrong file was downloaded

 

Hope you make some headway with this

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...