Jump to content

nvidia drivers


Recommended Posts

Just another person who can't seem to get the nvidia drivers to work.


Here is what i've done so far:

1. I tried installing the kernel source via RPMdrake (i've heard that there are other ways to do this that work better...what are they?)

2. I tried installing the driver provided by nvidia and it gave me the error message about a missing "/lib/modules/2.6.3-9mdk/buil/include/linux/modvershions.h"

3. I tried installing the same sort of thing but from this guy's website...someone said he had the 2.6 drivers in the compressed file or something http://www.sh.nu/download/nvidia/linux-2.6/

-this worked but...if i try to startx i get "Failed to initialize NVIDIA kernel module"


I've tried all of these things in init 3 like i'm supposed to as root and not under su. I also took a look at the x-log and it went through all the device detection and properly picked out my video card. I also changed the line from "nv" to "nvidia", I have a glx line, and i don't have a DRI line.


Any ideas...perhaps a better way to make sure i have the right kernel source and it is configured properly.


(btw I'm using mdk10 rc1 for amd64...not that it should matter that much)


[moved from Installing Mandrake by spinynorman]

Link to comment
Share on other sites

type in you favorite terminal window:

uname -r


rpm -qa | grep kernel

maybe, you don't have kernel-source installed.


edited to say: and of course paste the outputs here... :thumbs:

Edited by william
Link to comment
Share on other sites

You probably installed the wrong kernel source. The kernel and kernel source version numbers must match. Run this to see if they do:


$ uname -a
Linux localhost 2.6.3-7mdk #1 Fri Apr 2 09:48:58 CEST 2004 i686 unknown unknown GNU/Linux
$ rpm -qa | grep kernel-source


If they don't match, uninstall the kernel-source package and reinstall the correct one.

Edited by pmpatrick
Link to comment
Share on other sites

ok here are the steps that i did:


1. download the drivers from nvidia: Drivers save the drivers to your home folder


2. do what pmpatrick said: type these commands in the console:

uname -r
rpm -qa | grep kernel-source


3. now at this point you have some stuff displayed in the console. When you type uname -r it gives you the kernel that you are running. when you type rpm -qa | grep kernel-source, this searches your computer for anything that has "kernel-source" in its name and displays the results.


4. now the numbers from your kernel should match with the numbers for your kernel-source For example:

[imwithstupid@localhost imwithstupid]$ uname -r

this is your kernel (in this example)

[imwithstupid@localhost imwithstupid]$ rpm -qa | grep kernel-source

ok as you can see in this example the kernel-source number does not match the kernel version. if this is the case you will have to get the correct one.

to continue this example i will now tell you how to update to the correct version:

so you have kernel 2.6.3-7mdk, but you have kernel-source-2.6.3-4, now you are going to have to use urpmi.

ok, open a new terminal, and type su

[imwithstupid@localhost imwithstupid]$ su
[root@localhost imwithstupid]#

enter your password as prompted

you are now the super user and you can do special things, like urpmi,

you are now going to update your kernel-source type this in the console:

[root@localhost imwithstupid]# urpmi kernel-source-2.6.3-7

of course you would replace "2.6.3-7" with the number part outputed from your kernel using the command uname -r

now you are updated.


5. ok now this is the easy way to do this, but:

go to the mandrake control center, then go to boot

then auto login. under this menu you should see a checked box that says "launch graphical environment" or something along those lines, uncheck that box. press apply and ok


6.now reboot your computer


7.it should now come up to a prompt that says:

bla bla bla bla bla bla bla bla bla bla bla bla bla
bla bla bla bla bla bla

type root, and enter the root password

you are now loged in as root,

now "cd" to you home folder

[root@localhost root]# cd /home/imwithstupid
[root@localhost imwithstupid]#

now you are ready to install the driver by typing this command

[root@localhost imwithstupid]# sh *.run

you will now be presented with a graphical setup, say ok to everything and eventually you should get to a thing that says "building kernel module" or something like that and it will have a progress bar, after that is done it will say that the driver is done and you will have to change you XF86config-4 file, press ok


8. you will be returned to the prompt


9. now type startx

[root@localhost imwithstupid]# startx

and now you will be brought back into the graphical enviro...


10. go to the start menu and click on home, a konquorer browser should start up


11. type this in the address bar : /etc/X11/


12. you should see a file called XF86config-4


13. open it


14. under the module section (think it is the third section down) make sure there is a line that says: load glx

make sure that there are no # signs before this line also....


15. keep scrolling down and you should see a place where it says, section "device"


16. in this section there is a line that says: driver "nv"


17. change this line to say: driver "nvidia"


18. save and close


19. now go back to mandrake control center>>boot>>autologin and recheck that box that says "launch graphical enviro..."


20. press apply and ok


21. go to log out


22. you will be brought back to a prompt


23. type reboot


24. your computer will restart any you should come back to a graphical login screen :)


25. your done



hope this helps

Link to comment
Share on other sites

Ok here is where i'm at now


i did uname -r and rpm -qa | grep kernel-source and they didn't match. So I uninstalled the 2 that were there that didn't match. Then I installed the one that matches. Then I tried installing the driver...but I still get the error that says it is looking for /lib/modules/2.6.3-9mdk/build/include/linux/modversions.h and that it is probably because the kernel sources aren't configured properly. Problem is...according to you guys and rpm -qa | grep kernel-source the source is properly configured. Do I have to compile object files or something? Any ideas would be helpful...


Also mods you might want to sticky this post...Sherpa has a lot of good info here.

Link to comment
Share on other sites

Ok I got it to work:


-I used the drivers from that brazilian website that I had previously installed that didn't look like they worked.


-All I had to do was type

modprobe nvidia

and it worked.



Now my question is: If that works, is there some sort of startup file or script or something I should put modprobe nvidia into?

Link to comment
Share on other sites



to /etc/modprobe.preload

[william@poseidon william]$ cat /etc/modprobe.preload 

# /etc/modprobe.preload: kernel modules to load at boot time.


# This file should contain the names of kernel modules that are

# to be loaded at boot time, one per line. Comments begin with

# a `#', and everything on the line after them are ignored.

# this file is for module-init-tools (kernel 2.5 and above) ONLY

# for old kernel use /etc/modules





Link to comment
Share on other sites

Please, correct someone if I'm wrong. But I'd also add in etc/rc.d/rc.local:

modprobe nvidia


Actually, I don't know the difference in editing these 2 files. Adding nvida in preload file has the same effect of adding in etc/rc.d/rc.local?


imwithstupid: run in terminal glxgears to check how many FPS you get.


PS: if you had been there before and installed the patch, it means that the problem was that your source was not matching the kernel version.

Edited by william
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...