Jump to content
Sign in to follow this  
kmc77

Internet? I don't need no stinking internet.

Recommended Posts

Looks like you're picking up an external IP. Seems like a DNS issue to me. Might want to call the ISp and ask them for a DNS server address. In the control center you can put in a DNS server address. I'm not at my linux box right now (at work on crappy XP) or I could give you specific directions to set it up. You can set it up from the command line, but I have always had good luck with mcc. The fact that your eth0 is coming up and picking up an external IP is good, I just think it cannot do a DNS lookup. Try opening a browser and typing http://68.3.180.152:8080/ in the address bar. If you get my Linux page that is under construction, then we need to configure a DNS server for you. :wall:

Share this post


Link to post
Share on other sites

no luck with your website, linuxbox4you. Also, when i click on the "configure hostname" button in MCC, it displays the correct DNS and Gateway. :wall:

 

Any other Ideas?

Share this post


Link to post
Share on other sites

Ummm..... lemme think about it some more. I'll post later today if I can come up with anything. You are so close to getting it. You could check your config from a console using the drakconf command while logged on as root. Also see if you can ping an outside IP address from the console. That should at least tell you if you have connectivity. :furious3:

Share this post


Link to post
Share on other sites

Drakconf oppened MCC. All settings looked normal. I'm not sure how to ping from console. If you can explain I'll try that also.

 

Computers - it's a love/hate relationship.

Share this post


Link to post
Share on other sites

you know you're right, I should have looked at it closer. I would edit the files to look like this;

search txucom.net

#nameserver 207.70.172.240

#nameserver 207.70.128.240

assuming that txucom.net is a good entry
DEVICE=eht0

BOOTPROTO=dhcp

ONBOOT=yes

HWADDR=00:c0:a8:87:01:38

MII_NOT_SUPPORTED=no

#DHCP_HOSTNAME=kevins.linux.box.com

#NEEDHOSTNAME=no

this will cause the network to search for some new values and hopefully find the right ones.

 

in a terminal;

ping google.com

Share this post


Link to post
Share on other sites

Made the changes. No effect.

Rebooted. No effect.

 

Google ping before and after change resulted in the following.

 

ping:unknown host google.com

 

I ran internet wizard again and the changes have been reset.

 

This is officialy my longest lasting Linux problem to date. :jester:

Share this post


Link to post
Share on other sites

try taking eth0 down then bring it back up, after this is done see what happens when you try pinging your local computer then try pinging the gateway that your tech support gave you, then if that works try pinging the nameserver addresses.

 

ie:

ifdown eth0
ifup eth0
ping 127.0.0.1
ping 235.23.23.1    <-whatever ip address tech support gave you for your gateway
ping 235.20.21.1    <-whatever ip address they gave you for your nameserver (dns)

Share this post


Link to post
Share on other sites

Here's the results from jdion81's suggestions.

 

ifdown eth0

ifup eth0

ping 127.0.0.1

ping 235.23.23.1    <-whatever ip address tech support gave you for your gateway

ping 235.20.21.1    <-whatever ip address they gave you for your nameserver (dns)

 

Took eth0 down and back up

 

Ping 127.0.0.1

PING 127.0.0.1 (127.0.0.1) 56 (84) bytes of data
64 bytes from 127.0.0.1 : icmp_seq=1 ttl=64 time=0.069 ms

 

Ping gateway address given by tech support (209.34.30.254)

PING 209.34.30.254 (209.34.30.254) 56 (84) bytes of data
From 209.34.26.91 icmp_seq=1 Destination Host Unreachable
Ping: sendmsg: operation not permited.

 

Ping DNS address given by tech support (207.70.128.240)

PING 207.70.128.240 (207.70.128.240) 56 (84) bytes of data
From 209.34.26.91 icmp_seq=1 Destination Host Unreachable
Ping: sendmsg: operation not permited.

 

Does this mean anything to you? Please tell me it does. :unsure:

Edited by kmc77

Share this post


Link to post
Share on other sites

Is there a way I can completely remove all internet/network settings and start from scratch? Prefferably without formating and reinstalling Mandrake, but if that is the only way, I've got to get my work computer back.

Share this post


Link to post
Share on other sites

The suggestion I made was taking down and bringing up eth0 (trying to see if this would help you get good network settings using dhcp) and then trying to ping your gateway (your gateway is the router or other device that your computer goes to when trying to reach the internet). Unfortunately you could not get a response from your gateway, since no response from your gateway you wont get a response from your dns server and also no response from any server on the internet.

 

This does not mean that we cannot get you on the internet with this computer.

 

Some more questions,

I beleive you said you have a dsl line right?

if so how do you connect in windows? do you use whats called pppoe?

if not do you use whats called dhcp or automatically assign network settings?

 

try this in a console:

route add default gateway 209.34.30.254 netmask 255.255.255.0 dev eth0

 

then try to ping 209.34.30.254

Share this post


Link to post
Share on other sites

I use a dhcp connection. Here are the settings that are working right in windows right now:

 

DNS - 207.70.128.240

Subnet Mask - 255.255.255.0

Default Gateway - 209.34.26.254

DHCP Server - 209.34.26.254

 

try this in a console:

route add default gateway 209.34.30.254 netmask 255.255.255.0 dev eth0

 

Result

SIOCADDRT: Network is unreachable

 

Then trying to ping 209.34.30.254 resulted in the standard "Destination Host Unreachable", error.

 

Does this tell you anything?

I appreciate all of the help that I am getting on this.

Share this post


Link to post
Share on other sites

post the output of the route command as root, then try the previous command but change the ip address of the gateway to the one that works in windows. then try to ping 209.34.26.254

 

ie:

route add default gateway 209.34.26.254 netmask 255.255.255.0 dev eth0

Share this post


Link to post
Share on other sites

Turn off your adsl modem at the powerpoint - not a switch on the modem - then turn it on and run "ifdown eth0 && ifup eth0" (without quotes)

 

This is what I have to do with my cable modem when I change it from computer to computer, I get the same symptoms as you have now when I dont turn it off.

 

And after doing that

 

ping www.mandrakeusers.org

 

And if things are still haywire, just make sure there are no penguins blocking it

Edited by iphitus

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...