Jump to content

kicker question...

chris z

Recommended Posts

hi guys & gals.....


i'm stumped with something. maybe somebody can unstump me........


here's the story..... i installed a KDE addon app called Kleardock. what it is basically, is a KDE Kicker that you can make transparent. (sorta along the lines of Slicker, or some Karamba themes out there). it installed fine & i really like it, except for one annoying problem. it apparently needs Kicker to be running in order for the K "start applications" menu to work. if i kill Kicker or stop Kicker from loading with KDE, i can still use Kleardock but the K "start applications" menu doesn't work. (IE: i click on it but absolutely nothing happens.......no app menus, no nuthin') i've searched high & low for a solution, but can't find one. i've tried editing the panel.desktop config file in /usr/share/autostart several different ways (commenting out the Exec=kicker line, replacing kicker with kleardock, commenting out the dcop & service start lines) to no avail. the executable path under properties to the K shortcut in Kleardock reads as such....


dcop kicker kicker popupKMenu 0


i've tried editing that in every way imaginable..........no go.


my 2 lines of thought to get this working are this.........


1. find the correct exectuable path to the K "start applications" menu (if there is one)


2. find a way to make Kicker load or run, but having it running in the background where it's not visible.


anybody have any ideas on how to do either of the above? or, maybe a totally different solution?


currently i'm running Kicker along with Kleardock, but i have Kicker hidden to the left by using the hide arrow. i really don't like the look of this half assed solution, but it's all i can come up with for now.


i'm all ears (or eyes, i suppose) :P



Edited by chris z
Link to comment
Share on other sites

You can load kicker and "send it invisible" by setting its size to 0 x 0 by using a line of code like this:


kicker && dcop kicker Panel setPanelSize 0,0


I use it in a shell script to open the K-menu in XFce4, like this:


kicker && dcop kicker Panel setPanelSize 0,0

dcop kicker kicker firstOpenPopupKMenu


which will open the menu and leave kicker running "invisible" or just open the menu if kicker has already been invoked.

Link to comment
Share on other sites



almost.....but not quite. :juggle:


that set of commands doesn't give me the effect i'm hoping for. it reduces my kicker to a very thin still visible line. almost invisible, but not quite totally. thanks for the info, though.


any other ideas?



Link to comment
Share on other sites

Are you sure ?


I just played with this for a while, and


dcop kicker Panel setPanelSize 0,0


invariably makes kicker disappear completely on my system (in KDE as well as XFce4)


If you are sure you only have one instance of kicker running (check with top or kpm) then issue the command above in a terminal and see if it works.


It's case sensitive, obviously, and I've tried it as root and as a user - works without fail.


Are you describing the thin line that's left when you use the hide button when you say it leaves a thin line ?


If so then it isn't working, because it makes that go away for me.


Only other thing I can think is you may have some applets loaded in kicker which can't resize -


I have the hide button on the left turned off in properties - also I have hide automatically turned OFF.


If none of that helps - you got me !!!

Link to comment
Share on other sites

hi again jimdunn.......


well, to answer your questions first........


yes, when i issued the commands you listed (cAp SensiTIve) it made my kicker turn into a pencil thin line, but not completely invisible. i did get some warnings in terminal after following your instructions about minimum size can't be negative (it wasn't, it was 0,0 like you posted) & something about trouble resizing the clock. i don't have the errors verbatim because since then i've found another solution which is prolly as good as it's gonna get it. sort of a "dirty hack", but it accompolishes the effect i was looking for. what i did was the following...........


(thanks to LinuxLearner for pointing me down the right path & Hook in #kde for showing me how to do this.....)


to make kicker become invisible without using a script or set of commands, but still run (thereby giving full functionality to the KlearDock K Menu), i did the following.....


start Kicker, right click on it, choose "panel menu"->"configure panel"->"hiding". select "hide automatically", select "immediately" where it says "after the cursor leaves the panel", & uncheck the "show panel hide buttons" (if you have them checked). then, in the "arrangement" tab, for it to work with KlearDock already docked at the bottom of my screen, i needed to set the hiding position to top center. (though i think any place will work except for the bottom points of the screen) click "apply" "ok" & walla........Kicker disappears completely. to make it reappear, simply hover your cursor over where Kicker was located. as long as your cursor is on the Kicker it will stay visible. move it, & Kicker goes outta sight, outta mind.


so, now that i've got this worked out, i can recommend the app KlearDock wholeheartedly if you want to have a really nice, fully functional, transparent Kicker in KDE!


thanks again for your help jimdunn!



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...