Jump to content

Getting SCIM running for Chinese input in Mdk 9.1


Recommended Posts

Just a short addendum to my previous post...


On a hunch, I tried getting SCIM set up and then logging into KDE instead of Gnome. Everything worked perfectly. So, it's a problem with Gnome. I already made sure both ~/.18n and /etc/sysconfig/i18n have the "GTK_IM_MODULE=xim" line, but that didn't change anything. As Mr. Su says on his page, I also ran "gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules" as root. This also didn't help. I tried "scim -f socket -ns socket -d", as he mentions, but that resulted in this:

Smart Common Input Method 0.9.0

Loading simple Config module ...
Creating backend ...
Loading Server module: pinyin ...
   Loading Server Factory 0 ... : OK
pinyin Server module is successfully loaded.
Loading Server module: rawcode ...
   Loading Server Factory 0 ... : OK
rawcode Server module is successfully loaded.
Loading Server module: table ...
   Loading Server Factory 0 ... : OK
   Loading Server Factory 1 ... : OK
   Loading Server Factory 2 ... : OK
   Loading Server Factory 3 ... : OK
   Loading Server Factory 4 ... : OK
   Loading Server Factory 5 ... : OK
   Loading Server Factory 6 ... : OK
table Server module is successfully loaded.
Loading socket FrontEnd module ...
Failed to load socket FrontEnd module.

I don't know what that means.


I'm getting closer to the solution, I can feel it. And all thanks to you, zero0w! :)

Link to comment
Share on other sites

Gnome2 and GTK2 applications can use a different input protocol, gtk2 immodule, in addition to XIM (X Input Method). The latter can be used in KDE/Qt and other GUI applications, while the former is for GTK2-apps only if my understanding is correct.


I am not sure about the benefit or difference between the two input protocols, but I can tell that some people have been experienceing problems without adding the line:




to the ~/.i18n file, I would guess the line means pointing gtk2 immodule to use the same input program which XIM is using. In other words, by making XIM=program1 and GTK_IM_MODULE=program2, you can make different applications using different input method. By stating GTK_IM_MODULE=xim (in lower case again) you will be using the same input method across GTK2 and non-GTK2 applications.


Also, SCIM's user manual in Simplified Chinese:



I don't use Gnome2 so I am not sure how that gtk2-immodule works for SCIM under Gnome, I think James Su is the person you should talk to for a direct answer in LinuxSir BBS.


Oh, and one more thing, the sodipodi screenshots are not my own artwork. :lol:

I hope I can achieve such quality of illustration in some day. My contention is only to show what SVG format and sodiopodi is capable to produce. By the way, in KDE 3.2 a SVG viewer is bundled called KSVG. Mozilla SVG support, hopefully will be available someday now that KSVG and Konqueror is offering some competition in the picture.

Edited by zero0w
Link to comment
Share on other sites

Just tried to login as Gnome, no problem with SCIM (without installing gtk2-immodule) whatsoever:


It is working with this setting in ~/.i18n, as I posted earlier:























Just check out this screenshot.


Link to comment
Share on other sites

I checked out the documentation page you mentioned. The combination of computer terms and simplified Chinese confused me quite a bit, but I noticed one thing: Su says to use GTK_IM_MODULE=scim, not GTK_IM_MODULE=xim. I changed this. On login, SCIM still wasn't working, so I put it on the back burner.


However, I was having some other problems -- something was making Gnome very slow, messing with the Gimp interface, etc. -- so I had to restart the system a couple times. On the most recent restart, among other benefits, SCIM was working correctly. SCIM 好像可以用了! It's a little slow, but it seems very stable. Now I just need to figure out how to use tones. :)


Thanks again for all your help, zero0w. I will credit you when I get this all written up as a how-to. Would you like me to say anything specific there (your homepage, e-mail address, etc.)?


Happy happy happy! :) I don't know how I got it fixed, but I got it fixed!

Link to comment
Share on other sites

I think maybe something is screwed up with your Gnome, other than that SCIM should be working fine once the ~/.i18n file is set properly.


SCIM is working fine in my Gnome desktop.


One approach to test this theory is to create a new user aco****, login w/ Gnome and put the modified ~/.i18n right into place, logout/re-login, and check if SCIM works properly.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...