Jump to content
Sign in to follow this  
red wire

Upgrade from Mandriva 2010 to 2011 problem

Recommended Posts

Hello I have problem update from Mandriva 2010 to Mandriva 2011. Always I got error report.

Trying to install the dependenci after "restarting urpmi" was printed.

It says "NÄ›které požadované balíÄky nebylo možné nainstalovat:" - the packets were not possible to install.

For reason libkexiv2_8-4.5.67-1mdv2011.0.i586 (z důvodu nesplněného libexiv2.so.9) unsatisfied...

Reports some conflicts with these two files:

libwebkitgtk1.0_2-1.2.7-4-mdv2011.0.i586 (z důvodu konfliktů s webkit1.0-1.4.2-0.2-mdv2011.0.i586)

sysvinit-2.87-11-mdv2011.0.i586 (z důvodu konfliktů s systemd-sysvinit-29-8.5-mdv2011.0.i586)

 

Can you help to fix it? I installed 2010 and updated cca 700 packages (2010). Then I started the upgrade to 2011.

 

.................................................

Original report is in Czech language:

 

libstdc++-devel-4.6.1-3.3-mdv2011.0.i586: HlaviÄkové soubory a knihovny pro vývoj v C++ (k instalaci)

 

 

 

restartuje se urpmi

Aby byly splnÄ›na závislost 'linux-userspace-headers', je tÅ™eba jeden z následujících balíÄků:

1- kernel-headers-2.6.39.4-4.2-mdv2011.0.i586: Linux kernel header files mostly used by your C library (k instalaci)

2- linux-userspace-headers-2.6.38.4-1-mdv2011.0.i586: HlaviÄkové soubory jádra pro uživatelský prostor (k instalaci)

Jaká je vaše volba? (1-2) 1

Aby byly splnÄ›na závislost 'libpsync.so.1', je tÅ™eba jeden z následujících balíÄků:

1- libpsync-0.1-14-mdv2011.0.i586: MandrivaSync client (k instalaci)

2- lib1-0.1-8-mdv2011.0.i586: ROSA Sync client (k instalaci)

Jaká je vaše volba? (1-2) 1

Aby byly splnÄ›na závislost 'devel(libstdc++)', je tÅ™eba jeden z následujících balíÄků:

1- libstdc++-devel-4.6.1-3.3-mdv2011.0.i586: HlaviÄkové soubory a knihovny pro vývoj v C++ (k instalaci)

2- cross-arm-c++-2010.09-2-mdv2011.0.i586: c++ based on Sourcery G++ Lite for ARM GNU/Linux (k instalaci)

Jaká je vaše volba? (1-2) 1

NÄ›které požadované balíÄky nebylo možné nainstalovat:

libkexiv2_8-4.5.67-1mdv2011.0.i586 (z důvodu nesplněného libexiv2.so.9)

libwebkitgtk1.0_2-1.2.7-4-mdv2011.0.i586 (z důvodu konfliktů s webkit1.0-1.4.2-0.2-mdv2011.0.i586)

sysvinit-2.87-11-mdv2011.0.i586 (z důvodu konfliktů s systemd-sysvinit-29-8.5-mdv2011.0.i586)

Share this post


Link to post
Share on other sites

I tried to update from 2010 to 2011 and it was not possible even to finish first package of cca 109 packages (or files). Exactly like they say:

http://archive.openmandriva.org/wiki/en/index.php?title=Upgrading_Mandriva_Linux_from_2010_to_2011

it ruined my Mandriva 2010 and I cannot login to KDE. Have to reinstall with newer version.

 

Anybody can suggest working Mandriva Live CD and full install DVD? I have to install it on 10GB partition.

Share this post


Link to post
Share on other sites

You tried from repos which probably no longer exist, because 2011 is extremely old now. It probably did not find files on there, and so of course failed to download.

 

You can try:

 

https://openmandriva.org/

 

try downloading DVD iso image here for Mandriva 2011 maybe:

 

http://mandriva.mirror.dkm.cz/pub/mandriva/official/iso/2011/

 

maybe it will be possible to fix failed upgrade booting from DVD once you burnt ISO image.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...