Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
Kieth

screensaver not working

Recommended Posts

Every time I boot up my computer, in konsole, I need to enter a command such as:

 

$ xset dpms 50000 55000 60000

 

Whether it's in root or not, doesn't matter. Anyway to make such changes permanent? Also, what command would be best, because I just randomly choose 50000 55000 and 60000.

 

Thanks,

Kieth

 

 

[moved from Everything Linux by spinynorman]

Share this post


Link to post
Share on other sites

to make it permanent you could add the command to /etc/rc.d/rc.local

 

I use xset dpms 0 360 420

 

this command disables DPMS standby and sets the DPMS suspend time to 360 seconds and the off time to 420 seconds

Share this post


Link to post
Share on other sites

This is what I have in rc.local.

 

#!/bin/sh

#

### BEGIN INIT INFO

# Provides: rc.local

# X-Mandriva-Compat-Mode

# Default-Start: 2 3 4 5

# Short-Description: Local initialization script

# Description: This script will be executed *after* all the other init scripts.

# You can put your own initialization stuff in here if you don't

# want to do the full Sys V style init stuff.

### END INIT INFO

 

touch /var/lock/subsys/local

xset dpms 0 360 420

 

It doesn't change DPMS at all. It's still:

 

DPMS (Energy Star):

Standby: 0 Suspend: 0 Off: 0

DPMS is Enabled

Monitor is On

 

Did I make a mistake on the command?

 

Thanks,

Kieth

Share this post


Link to post
Share on other sites

Do you have the DPMS option set in xorg.conf?

 

Section "Device"

Identifier "device1"

VendorName "nVidia Corp."

BoardName "NVIDIA GeForce2 DDR (generic)"

Driver "nvidia"

Option "DPMS"

Option "NvAGP" "3"

Option "IgnoreEDID" "1"

Option "RenderAccel" "0"

EndSection

Share this post


Link to post
Share on other sites

It looks like it.

 

Section "Device"

Identifier "device1"

VendorName "ATI Technologies Inc"

BoardName "ATI Radeon X1950 and earlier"

Driver "ati"

Option "DPMS"

Option "AccelMethod" "EXA"

EndSection

Share this post


Link to post
Share on other sites

Kieth, If you're using KDE... you can just copy this and save it as display-screen.sh (or whatever you want to name it) in ~/.kde4/Autostart/

#!/bin/bash
xset +dpms && xset dpms 0 360 420 &

you can adjust the times for your needs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×