Jump to content
linux_challenged

No sound in Mandriva 2010.2 Gnome

Recommended Posts

I need some help tracking down the cause and fix for no sound in Mandriva 2010.2.

 

I am using gnome desktop and have lost all sound. Nothing from any players, firefox flash, youtube, nothing.

 

I have tried disabling pulseaudio, that did nothing.

 

I should mention that this has been an issue for a couple of months, I suppose after I took some updates, but I can't be sure.

 

I used to have sound when I first upgrade from 2009.1 to 2010.1, but now I don't even have the startup sound or shutdown sound.

 

How can I figure out what the problem is?

 

thanx in advance...

Share this post


Link to post
Share on other sites

Try using alsamixer in konsole.

Share this post


Link to post
Share on other sites
I am using gnome desktop and have lost all sound. Nothing from any players, firefox flash, youtube, nothing. How can I figure out what the problem is?

 

If the sound works from another user account, such as the Guest account, then the problem is not system wide. When I had a similar problem with sound (I use kde4, not gnome) I was able to fix the problem simply by deleting the user's .kde4 directory while logged in as root in run level 2. The .kde4 directory was recreated with default settings and sound was restored.

 

Use Control-Alt-F1 to switch to text mode, log in as root, type "init 2", find the appropriate directory in /home/user/ and delete it. Then reboot using the command "shutdown -r now".

 

Anyone know the the name of the directory for settings in Gnome that's analogous to the .kde4 directory?

Share this post


Link to post
Share on other sites

That's a bit drastic Boatman.

 

LC. Run alsamixer as Isadora suggests, in a command window, and look for any control that is muted. If there are none then look for the 5.1 volume control, usually at the extreme right. Select it and press 'm' to mute it. Setting the control to '0' will not work, you have to mute it using the 'm' key.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...