Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here

Epson NX127 all-in one printer & scanner [solved]

Recommended Posts

Needed a new printer, picked up an Epson NX127 as Linuxprinting.org shows it as fully supported...

well... It apparently assumes a current version of cups, Gutenprint, iscan and foomatic.


Installed/updated Cooker and printer/scanner both worked once the avasys.jp rpms were installed.(has other showstoppers)


I installed/updated SUSE11.4 on a spare partition and installing the RPMs from avasys.jp (worked),

Unfortunately Mythtv is horribly hosed on both setups

(cooker kernel doesn't support v4l1 devices at the moment, SUSE recording playback simply doesnt, and I don't feel like fighting with it anymore)


So... I'm back to trying to get 2010.2 working again, painless install (only need to add "vmalloc=256M" for the nvidia card) fresh, ran printer setup, plugged in printer, system installed iscan 1.02 and the epson printing task, printer is setup and produces nothing but solid black prints, and gives a "ps2raster" failure, which I assume is the slid black page cause.


Install the Avasys rpms, selected the included ppd, restarted everything and nada, the print filter failed.

These rpm are for LSB3.2, perhaps an issue?


OK, so how do I gracefully update 2010.2 to ~current versions of cups, gutenprint, iscan and foomatic?

(Hint--- Even the versions in cooker are pretty ancient)

Edited by waferhead

Share this post

Link to post
Share on other sites

Update: Got the printer side working using the Epson Stylus NX115 Foomatic/gutenprint-ijs.5.2 driver

(this is what Ubuntu installed/selected automagically, Ubuntus RAID handling is horribly borked BTW)

Scanner worked after installing iscan-2.26 and the iscan-data-1.81 rpms off the avasys.jp site.


running iscan it came right up.


Scanner was still not found, manually configured it as an Epson RX420 and it worked, perhaps by chance.


Works from gimp/xsane etc now as well.

Edited by waferhead

Share this post

Link to post
Share on other sites

Thanks ;-)


Just an added note, you must install the latest versions of iscan and iscan-data OVER the std iscan that sane installs, there is a packaging bug.


use --nodeps to override the conflicts.

Share this post

Link to post
Share on other sites

If you want to install the proprietary iscan packages (without the conflicts), you first need to un-install the sane-backends-iscan package. It was separated out from the sane-backends package a few years ago in order that the conflicts that you referred to can be avoided.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now